LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-17-2004, 04:43 PM   #1
geniarse
Member
 
Registered: May 2003
Location: UK
Distribution: Gentoo
Posts: 141

Rep: Reputation: 15
jack compilation problem


I'm trying to install JACK-0.94, the configure script runs fine, bringing up no problems but when compiling an error is encountered with alsa_driver.c

alsa_driver.c:2087: error: parse error before '*' token
alsa_driver.c: In function `alsa_driver_listen_for_clock_sync_status':
alsa_driver.c:2094: error: `func' undeclared (first use in this function)
alsa_driver.c:2095: error: `arg' undeclared (first use in this function)
alsa_driver.c:2096: error: `driver' undeclared (first use in this function)
alsa_driver.c: At top level:
alsa_driver.c:2106: error: parse error before '*' token
alsa_driver.c: In function `alsa_driver_stop_listening_to_clock_sync_status':
alsa_driver.c:2112: error: `driver' undeclared (first use in this function)
alsa_driver.c:2115: error: `which' undeclared (first use in this function)
alsa_driver.c: At top level:
alsa_driver.c:2130: error: parse error before '*' token
alsa_driver.c: In function `alsa_driver_clock_sync_notify':
alsa_driver.c:2135: error: `driver' undeclared (first use in this function)
alsa_driver.c:2139: error: `chn' undeclared (first use in this function)
alsa_driver.c:2139: error: `status' undeclared (first use in this function)
alsa_driver.c: In function `driver_finish':
alsa_driver.c:2508: error: parse error before ')' token
make[3]: *** [alsa_driver.lo] Error 1

and a load more, is anyone else having this trouble and know a solution. I can't find any prevvious posts.

cheers
 
Old 03-17-2004, 04:56 PM   #2
hollywoodb
Member
 
Registered: Aug 2003
Location: Minnesota, U.S.A.
Distribution: Debian, openSUSE
Posts: 400

Rep: Reputation: 30
There's a jack & alsa howto in the docs/tips/tricks forum with some tips... I followed it to the leter with 0.94 and had no problems whatsoever.

you'll probably have to search for it.
 
Old 03-17-2004, 05:08 PM   #3
geniarse
Member
 
Registered: May 2003
Location: UK
Distribution: Gentoo
Posts: 141

Original Poster
Rep: Reputation: 15
i've solved the problem, stupid me didn't realise the alsa-devel package wasn't installed. Just needed the extra 5 mins to think it through. cheers for the help anyhow
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
suse 9.2 problem with jack js72 SUSE / openSUSE 1 01-28-2005 03:34 PM
alsaplayer and jack problem Ross Clement Linux - Software 0 06-11-2004 06:11 PM
c compilation problem edreddy Programming 5 06-02-2004 01:37 PM
Sound problem after installing/uninstalling JACK sound server bastupungen Linux - Software 1 02-28-2004 01:50 PM
Compilation problem... need help Korshun Programming 2 05-07-2002 01:33 PM


All times are GMT -5. The time now is 10:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration