LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Jack-Audio-Control-Kit will not display midi devices as regular user: (http://www.linuxquestions.org/questions/linux-software-2/jack-audio-control-kit-will-not-display-midi-devices-as-regular-user-639427/)

animehair 05-02-2008 03:04 PM

Jack-Audio-Control-Kit will not display midi devices as regular user:
 
Hello,
Im attempting to build my DAW from Gentoo, and I have everything working fine untill I fire up Jack (using qjackctl) and notice that none of my midi devices show up as a regular user...when i start up jack as root, all the midi devices show up. I am using the freebob driver and all other inputs and outputs work (edirol fa-101)...I even have RT working as a regular user...just not the midi ports...all the modules are loaded correctly...

I believe its a simple permission thing perhaps on the device nodes?...but I cant figure this out...any suggestions will be appreciated.

comprookie2000 05-02-2008 10:04 PM

You can try to add;
options snd device_mode=0666
to /etc/modules.d/alsa
but that is just a guess
you may see something here;
http://www.gentoo.org/doc/en/alsa-guide.xml

animehair 05-03-2008 05:12 AM

i appreciate your reply...
I tried this but it didnt work...I also reviewed that alsa gentoo document but I still havnt resolved it...I even checked the udev rules and it should work because the user account is in the audio group...I really didnt want to record everything under the root account...it kind of defeats the purpose of setting up the RT kernel for the user.

Quote:

Originally Posted by comprookie2000 (Post 3140618)
You can try to add;
options snd device_mode=0666
to /etc/modules.d/alsa
but that is just a guess
you may see something here;
http://www.gentoo.org/doc/en/alsa-guide.xml


animehair 05-03-2008 03:17 PM

Resolved
 
I was actually able to resolve this by re-emergeing jack-audio-connection-kit, and enabling the oss use flag. Im not sure why this worked but it did...when I startup qjackctl as a regular user it adds all my midi i/o's into the connection bay like it should.

I have the following USE flags enabled: alsa dbus freebob jackmidi mmx oss sndfile sse

And im using the pro-audio overlay ebuilds.


All times are GMT -5. The time now is 05:52 AM.