LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-20-2005, 01:51 AM   #1
trey85stang
Senior Member
 
Registered: Sep 2003
Posts: 1,090

Rep: Reputation: 41
JACK, Ardour ALSA - Mandrake 10.1


Hello all, I have a mandrake 10.1 box I just setup and I am having a problem recording from the mic in... and it is quite weird to me.

Here is the deal the best I can explain. First I am recording guitar through ardour....

Anyways the problem, If I mute capture in alsamixer I get a a great sounding guitar through my speakers. Once I unmute capture, I get a good sounding guitar and a bunch of static... I've tweaked and tweaked the settings w/ capcpture and AC97 capture until I only have a little bit of static. But the static is still there.

Alsa 1.07 w/ emu10k1 - Using the default 2.6.8.1 kernel as well.

Now, Im satisfied even with the little bit of static I am getting, but when I hit record in ardour... its like the input on the mic/guitar is cut in half and it is not picking up the same signal it was... once I stop recording the level goes back to normal??

I cannot figure out what is causeing this or why it is happening. I previously had Slackware 10 on this machine but decided to go with mandrake since midi sound is much easier to get working in mandrake (I could never get it going with slackware)

So does anyone have any ideas?? Worst case, I will go back with slackware, but I plan on phasing out my slackware usage since it is no longer including gnome
 
Old 05-20-2005, 07:41 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
HI,

this is a hard one to think about long distance

once you hit record in ardour you are playing through the output levels in ardour that go through jack and then through your alsa mixer and you know you can output the track directly or have it go through the master so then in ardour you have two volume sliders working together.

as for the capture sound being distorted
if you can hear the guitar some capture device must be enabled yes ? like mix or something
(i'm not a guitar player)
but try only enable the mic capture (might need the capture capture)
there is a mic boost +20 becibells to turn on or off
*the mysterious controlls for alsa emu10k1 make me feel lke a retard ?*
anyway i think you have it correct when it sounds good
and if you can hear it capture is on has been my experience
i think also whatever mixer you are using most likely is not showing you what the possibilities are
try QAMix by Nathias Nagorni
it's a suse specific thing so you have to edit the paths in the Makefile (not hard) to get it to compile but it comes with a sample configuration for emu10k1 i like alot.
http://alsamodular.sourceforge.net/
and of course look at the strange output of amixer and read man amixer

Last edited by foo_bar_foo; 05-20-2005 at 07:45 PM.
 
Old 05-22-2005, 08:30 AM   #3
trey85stang
Senior Member
 
Registered: Sep 2003
Posts: 1,090

Original Poster
Rep: Reputation: 41
Quote:
Originally posted by foo_bar_foo
HI,

this is a hard one to think about long distance

once you hit record in ardour you are playing through the output levels in ardour that go through jack and then through your alsa mixer and you know you can output the track directly or have it go through the master so then in ardour you have two volume sliders working together.

as for the capture sound being distorted
if you can hear the guitar some capture device must be enabled yes ? like mix or something
(i'm not a guitar player)
but try only enable the mic capture (might need the capture capture)
there is a mic boost +20 becibells to turn on or off
*the mysterious controlls for alsa emu10k1 make me feel lke a retard ?*
anyway i think you have it correct when it sounds good
and if you can hear it capture is on has been my experience
i think also whatever mixer you are using most likely is not showing you what the possibilities are
try QAMix by Nathias Nagorni
it's a suse specific thing so you have to edit the paths in the Makefile (not hard) to get it to compile but it comes with a sample configuration for emu10k1 i like alot.
http://alsamodular.sourceforge.net/
and of course look at the strange output of amixer and read man amixer
Thanks for the reply, I am comparing my Mandrake exp with that of which I had on my previous slackware install. On my slackware install using audioslacks ardour, the recording level and my speaker level were exactly the same on slackware, (ardour recording level always set to 0)

In mandrake if I import some drum tracks froma wav file, After I record in the mix.. the drums have to be turned down all the way (-10 i think is as low as the mix will go) and the guitar must be turned all the way up to 6 to get a somewhat equal level between the two. In slackware I never had to go more then -1 to 1 to get a good mix.

Mic boost is turned off.. I record directly from my preamp to the line in (which is similar to mic'ing my amp.. but this setup requires no mic) As for the mysterious controls.. Im with you I have no clue what 90% of them do :lol:

Im working with this a little more.. and I know have a slackware install dual booting trying to figure out the difference between these setups.. but I have ran across a problem with slackware too.. So Im working through these issues
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
issues setting up rosegarden/JACK/ALSA jgams Linux - Software 7 04-20-2005 01:42 AM
jack, alsa and Terratec DMX 6fire s_siouris Linux - Software 3 04-11-2005 09:33 PM
alsa/jack/ardour foo_bar_foo Linux - Software 1 10-20-2004 04:43 AM
Need help configurating JACK & Ardour ... hollywoodb Linux - Software 1 12-16-2003 08:30 AM
JACK doesn't detect ALSA disciple061 Linux - Software 0 07-31-2003 07:52 PM


All times are GMT -5. The time now is 10:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration