LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 03-01-2004, 03:26 PM   #1
bureado
Member
 
Registered: Oct 2003
Location: Caracas
Distribution: Knoppix 3.3 (Debian sarge/sid)
Posts: 72

Rep: Reputation: 15
IPtables failing to load: unknown ruleset


Hello everybody,

I'm running Debian GNU/Linux sarge-sid (Knoppix) on a PIII box. I have been working in my iptables rules for accepting input packets and everytime I reboot, the system 'refuses' to recognize my ruleset and delete it. The exact message system gives at boot is:

Aborting iptables load: Unknown ruleset, 'active'

I don't know where these rules are stored or anything. I don't reboot my computer frequently but when I do it all my firewall settings go to the toilet.

I would really appreciate any kind of help. Greetings,
 
Old 03-01-2004, 04:15 PM   #2
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
Once you have made a set of rules, you need to save them into /usr/lib/iptables/active.

Do /etc/init.d/iptables save active and they will be placed there ready for reboot.
 
Old 03-01-2004, 04:52 PM   #3
bureado
Member
 
Registered: Oct 2003
Location: Caracas
Distribution: Knoppix 3.3 (Debian sarge/sid)
Posts: 72

Original Poster
Rep: Reputation: 15
Thank you for your first reply.

I 'remade' my ruleset and then typed the command, logged as root. Returned:

Saving iptables ruleset: save "active" with counters/etc/init.d/iptables: line 65: /var/lib/iptables/active: No existe el fichero o el directorio (File doesn't exists)

What might be happening?
 
Old 06-19-2008, 11:32 PM   #4
royce2020
Member
 
Registered: Jan 2003
Posts: 81

Rep: Reputation: 15
Cool

I had exactly the same problem with Knoppix (and stumbled onto your post when I googled the problem). I have since worked out that to make the command "/etc/init.d/iptables save active" work in a HDD install of knoppix, you need to create the folder "/var/lib/iptables" first:
Code:
mkdir /var/lib/iptables
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
iptables ruleset for nameserver DaveL Linux - Newbie 4 01-07-2003 01:11 AM
cannot load the accounting ruleset monsoon Linux - Newbie 1 12-14-2002 11:11 AM
Iptables ruleset Paul_assheton Linux - Networking 1 08-31-2002 08:01 AM
X failing to load; AddScreen/InitScreen failing for driver 0 weblion Linux - Software 1 08-01-2002 07:14 AM
Iptables ruleset Kinstonian Linux - Security 1 04-04-2002 03:58 AM


All times are GMT -5. The time now is 07:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration