LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   IP problem (http://www.linuxquestions.org/questions/linux-software-2/ip-problem-4175461223/)

Huamin 05-08-2013 09:44 PM

IP problem
 
Hi,
I see eth0 is currently "192.168.168.20" that is the static IP I configured previously. How can I ensure the Linux machine is with the dynamic IP assigned by my ISP, as I am getting a problem to go to the Internet in this Linux machine.

yancek 05-08-2013 10:35 PM

The ip you posted is used locally by other machines on the LAN (if any) and your router. Which distribution of Linux are you using and what is the specific problem you are having? Can you ping your router? What type of connection do you have?

Huamin 05-08-2013 10:41 PM

Thanks a lot. I am using Red hat enterprise. How to make the Dynamic IP from my ISP available, in this server? The server is directly connected to outside, with the IP assigned by my ISP.

What commands to check, per your advice?

Huamin 05-09-2013 01:10 AM

Any help?

jpollard 05-09-2013 07:08 AM

Usually the IP assigned by the ISP is given to their router, not your system. The only time that happens is if your machine is directly connected to the ISP cable.

ISP ----> router/modem ----> system.

The IP number that is given to your system is usually a dynamic local IP (such as 192.168.0.x or 192.168.1.x, it could be any 192.168.x.x).

Normally, the router is given a public IP, but some ISPs have started issuing even them a nonroutable IP as the available public IP numbers are now exhausted. And that requires them to be either a 10. network or to use (for instance) 192.168.0.xx, so the modem has to use 192.168.1.xx for internal use. This is a "double" NAT translation, and is a real pain-in-the-rear.

If you ARE directly connected to the ISP wiring, then using dhclient should get you the IP number you want. The only other way is to get the IP number from them (a static IP number), which usually costs more.

Huamin 05-09-2013 09:22 PM

I did ever do some change to the server as you can see eth0 is "192.168.168.20". How to correct this and ensure it is fine to connect to outside?

Huamin 05-10-2013 03:30 AM

Any help please?

Many Thanks & Best Regards,
HuaMin

iqbal51 05-10-2013 07:50 AM

IP address is not so important for a web browser. I think static IP is best then dynamic IP. If you want to change your IP address contact your IP provider.
Or follow this command:
1. Go to Start > Run and type into blank box “cmd” without quotations.
2. Type “ipconfig/release” (without the quotes).
3. Type “ipconfig/renew” (without the quotes).
Now restart your computer.

chrism01 05-10-2013 07:57 AM

WTF? That's the instructions for MSWin; OP has a Linux system.

schneidz 05-10-2013 08:06 AM

do you have anything like a wireless router or are you connected direclty to a cable/dsl transceiver ?

assuming you are using gnome desktop and that your router has dhcp enabled you would rite-clik on the network manager icon on the top of the screen and select:
edit connections -> system eth0 -> ipv4 settings -> automatic (dhcp)

Huamin 05-10-2013 09:11 PM

Yes, it is connected directly to a cable.

I am using Red hat enterprise and I don't see network manager icon in the desktop.

Here are what I've got in the server.

http://dl.dropbox.com/u/40211031/t348.png
http://dl.dropbox.com/u/40211031/t349.png

Do you have any ideas why I can't connect to the Internet?

Many Thanks & Best Regards,
HuaMin

schneidz 05-11-2013 07:40 AM

why are uploading pictures of commands instead of copy-and-pasting ?

not sure what interface vibr0 is (vpn bridge) ?

i dont know enough about your network connection/isp but this mite help:
Code:

sudo ifconfig eth0 up
sudo dhclient eth0

also, what gui are you using ?


All times are GMT -5. The time now is 07:19 PM.