LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 05-24-2010, 09:34 AM   #1
RAFAL
Member
 
Registered: Feb 2006
Location: Warsaw, Poland
Distribution: openSUSE 11.4, openSUSE 12.3, SLES 11, Archlinux
Posts: 129

Rep: Reputation: 16
ioctl(ATM_SETBACKEND) No such device - Speedtouch 330 problem


Hello

I have a problem with USB modem SpeedTouch 330 in SUSE
When I execute:
Code:
pppd call suseneo
I see this:
Code:
Plugin pppoatm.so loaded.
PPPoATM plugin_init
PPPoATM setdevname_pppoatm - SUCCESS:0.35
ioctl(ATM_SETBACKEND): No such device
I have checked command 'lsmod' and it returns
Code:
usbatm speedtch
In general I see speedtch is several times in the output of lsmod

When I check this:
Code:
cat /proc/net/atm/speedtch:0
I see
Code:
Spped Touch 330
....
Line Up
What then could be wrong?
Why I cannot establish a connection to the internet?

regards
Rafal
 
Old 05-25-2010, 03:21 AM   #2
RAFAL
Member
 
Registered: Feb 2006
Location: Warsaw, Poland
Distribution: openSUSE 11.4, openSUSE 12.3, SLES 11, Archlinux
Posts: 129

Original Poster
Rep: Reputation: 16
I figured out that apparently module pppoatm is not available in the system.
modprobe pppoatm
returns
FATAL: Module pppoatm not found.
I am using kernel 2.6.27.19-5-default
How can I simply add pppoatm ?
 
  


Reply

Tags
speedtouch, suse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
speedtouch 330 problem in Kubuntu DonaldUK Ubuntu 1 04-13-2006 03:46 PM
FC3 Speedtouch 330 problem DoddyUK Fedora 3 03-05-2005 02:50 PM
Speedtouch 330 (silver) problem on FC3 ctux Linux - Hardware 5 11-21-2004 08:43 PM
Problem with a SpeedTouch 330 HAPPYY Linux - Hardware 3 11-16-2004 01:04 PM
speedtouch 330 install problem again jimriley Linux - Newbie 0 01-08-2004 08:39 AM


All times are GMT -5. The time now is 01:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration