LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-30-2003, 04:16 PM   #1
EUtopian
LQ Newbie
 
Registered: Jan 2003
Location: Stockholm, Sweden
Distribution: Mandrake
Posts: 5

Rep: Reputation: 0
International characters over ssh


I have a bizarre problem with Red Hat 9.

Locally, using gnome-terminal, I can use my Swedish characters ("" and their capitalized siblings "") without any problems. It also works inside the irssi IRC client, as well as from a bash session launched from hte terminal.

However, when I connect via ssh strange things happen. In the terminal, Swedish characters appear to register only when an additional key is pressed. For example, when I press "", it's only shown after I press an additional character. If I launch irssi, two or three strange characters are shown in sequence instead of my Swedish characters. The prompt in irssi behaves very strangely as a result of this.

I've tried connecting both with SecureCRT and Putty (Windows based SSH clients) with the same result. I've also manipulated the keymap and terminal settings.

However, if I launch ssh locally from Red Hat and connect to my own machine, it all works nicely. I don't know where to place the blame -- whether it's a keymap or terminal issue in the ssh clients, or some setting somewhere I'm supposed to fiddle with.

I did not have this problem in FreeBSD. It is frustrating I would really appreciate any hints so that I can keep using my old box remotely again!

Best Regards,
Robert
 
Old 10-31-2003, 06:46 AM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
I do not have much experience with recent Redhat versions, but it sounds like it might be some weirdness with the LC_CTYPE or locale or something similar. If you type echo $LC_CTYPE $LANG, what do you get?

Hkan
 
Old 11-01-2003, 04:31 PM   #3
EUtopian
LQ Newbie
 
Registered: Jan 2003
Location: Stockholm, Sweden
Distribution: Mandrake
Posts: 5

Original Poster
Rep: Reputation: 0
My LC_CTYPE was not set. My LANG was set to "en_US.UTF-8". I had been trying different combinations of settings without success until finally the other day I set LANG to sv_SE in order to get ISO-8859-1 (Latin-1) system-wide. This solved all my problems, except one: Alt-Gr 2 won't produce the @ sign. All other keys work normally, including other characters produced by Alt-Gr. I guess the Swedish keymap is broken. Any ideas what I can do?
 
Old 11-02-2003, 12:41 AM   #4
toloban
Member
 
Registered: Sep 2003
Location: D.F.
Distribution: Fedora Core
Posts: 35

Rep: Reputation: 16
You can add any assigments to your keys with xmodmap (man xmodmap).
I have a file named $HOME/.Xmodmap with my own default nonstandard assigns using the windows MENU key as a modifier (I have a US keyboard, I speak spanish) which is automatically loaded by xmodmap on login, but I am not sure if this is true also for Mandrake.

Your .Xmodmap file might contain:

keysym q=q Q at
 
Old 11-02-2003, 06:17 AM   #5
EUtopian
LQ Newbie
 
Registered: Jan 2003
Location: Stockholm, Sweden
Distribution: Mandrake
Posts: 5

Original Poster
Rep: Reputation: 0
Hi toloban,

I guess that only works in X? My problem is actually in the bash shell over SSH.
 
Old 11-02-2003, 11:50 PM   #6
toloban
Member
 
Registered: Sep 2003
Location: D.F.
Distribution: Fedora Core
Posts: 35

Rep: Reputation: 16
No, it works for all keyboard input.

By the way, when some 'international' characters are displayed as an stange sequence of characters, that means that an application is not aware of utf-8, which is a new method for encoding all characters for all languages using 7-bit ASCII characters. For example, a file named "nias17.tif" saved under redhat 8 seems to become "niñas17.tif" if I list it under under mandrake 6. That causes me a lot of trouble too.

About UTF8: http://www.cl.cam.ac.uk/~mgk25/unicode.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
International characters in Linux dominique Linux - Newbie 2 08-09-2007 01:01 PM
International characters in tcsh on Slack 10.2 Yalla-One Slackware 2 10-18-2005 03:32 PM
xmms and international characters jrdioko Linux - Software 15 01-15-2005 02:13 AM
Typing International Characters jrdioko Linux - General 12 09-19-2004 08:21 PM
easy entry of international characters teacup LinuxQuestions.org Member Success Stories 1 07-02-2004 10:51 AM


All times are GMT -5. The time now is 11:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration