LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-03-2008, 10:26 PM   #1
saurabh.jain162
LQ Newbie
 
Registered: Nov 2008
Posts: 7

Rep: Reputation: 0
Interface eth0 doesn't exist [WARN]


Hi Friends

I am using VmWare 6.0.4 to build my LFS-6.3 . After completing all steps .I boot up my lfs and i got the following error :

Interface eth0 doesn't exist [WARN]


.On entering lspci i got output :

Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE]

It is requested to you to please suggest me the configuration i should make while compiling kernel Linux-2.6.22.5 to solve above problem .

Regards

SAURABH JAIN
 
Old 11-05-2008, 07:52 AM   #2
hopbyhop
Member
 
Registered: Aug 2008
Posts: 52

Rep: Reputation: 15
try
Code:
dmesg |grep eth
and
Code:
dmesg |grep AMD
to see if kernel has the required driver. If you have module support AND AMD driver compiled as module, you can load it with insmod or modprobe. If not you have to recompile the kernel chosing the AMD device among network device drivers in kernel config program (e.g. make menuconfig)
 
Old 11-05-2008, 10:22 AM   #3
beiller
LQ Newbie
 
Registered: Nov 2008
Posts: 22

Rep: Reputation: 15
You need to install kernel drivers for your network card (onboard I am assuming?)

AMD PCnet32 PCI support OR AMD 8111 (new PCI lance) support, using both may be the safe bet. Compile then insert the modules. lance or pcnet are thier names I believe.

After that, as root type "ifconfig -a" to list all ethernet devices and find if eth0 exists.

Good luck,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
After I complete the compiling of LFS,"Interface eth0 doesn't exist" occurs. riondavid Linux From Scratch 8 02-07-2010 10:38 AM
Getting problem while booting LFS-6.3: Interface eth0 doesn't exist [WARN] saurabh.jain162 Linux - Newbie 6 11-09-2008 11:34 PM
"Interface eth0 doesn't exist. [ WARN ]" on boot-up aleksanteri Linux From Scratch 10 11-07-2007 12:40 PM
Interface eth0 doesn't exist garbo73 Linux From Scratch 5 02-02-2006 07:45 AM
Reboot LFS6.1:Interface eth0 doesn't exist! ukyo Linux From Scratch 4 09-07-2005 06:04 AM


All times are GMT -5. The time now is 11:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration