LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-03-2006, 05:16 PM   #1
TomalakBORG
Member
 
Registered: Dec 2004
Location: Maryland
Distribution: SuSE / Gentoo
Posts: 245

Rep: Reputation: 30
intel i810fb boot params


Hey guys, I have the intel i810fb installed, and it works.... sort of

I can specify it in lilo with video=i810fb, and that works. The only issue is setting the console res above the lowly 640x480 can't-see-jack setting. I've tried a few things:

After looking at Documentation/fb/modedb.txt, I tried
append = "video=i810fb:1024x768"

Then I looked at http://i810fb.sourceforge.net/howto/x83.html, I tried
append="video=i810fb:xres=800:yres=600:hsync1=31.5:hsync2=64.3:vsync1=50:vsync2=90"

With every iteration of stuff, I get the same error when I 'grep fb' from dmesg
"i810fb: invalid video mode. Specifying vxyncN/hsyncN parameters may help" - it then boots into the same damn resolution. Well, it does work - boot logo and all.

I think I'm using the wrong syntax in my append line, so if you could suggest the way to do it, that would be best. Thanx in advance-

-Bill
 
Old 12-01-2006, 07:31 PM   #2
lakapaka
LQ Newbie
 
Registered: Dec 2006
Posts: 1

Rep: Reputation: 0
This is what works for me

I use grub, instead of lilo, but that doesn't matter. My grub line looks like this:
kernel /boot/bzImage root=/dev/hda3 video=i810fb:800x600

Translating to lilo, you just want the last part:
append="video=i810fb:800x600"

Now, it's not quite 1024x768, but this works for me.
 
Old 12-01-2006, 08:08 PM   #3
TomalakBORG
Member
 
Registered: Dec 2004
Location: Maryland
Distribution: SuSE / Gentoo
Posts: 245

Original Poster
Rep: Reputation: 30
Geez, man - you registered just to respond to this topic that's 6 months old? BRAVO!

Seriously - you're my hero. I ended up figuring out that you can append the res wither your way (:1024x768) or the long way (xres=blah,yres=blah)

Thanks for the post!
 
  


Reply

Tags
display, hardware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg and the i810fb issue Seanbox344 Linux - Software 1 08-18-2005 02:39 PM
Suse on Sun boot params ques. kcav Linux - Software 0 03-29-2004 03:38 PM
Boot stuck at 'Configuring kernel params...' linuxify Mandriva 0 02-16-2004 03:33 PM
boot stuck at 'Configuring kernel params...' linuxify Linux - Newbie 0 02-16-2004 12:39 PM
how to add nolapic to the boot params biotek1 Linux - Laptop and Netbook 6 12-13-2003 01:50 PM


All times are GMT -5. The time now is 10:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration