LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-28-2004, 07:43 PM   #1
Egan
LQ Newbie
 
Registered: Oct 2004
Posts: 1

Rep: Reputation: 0
Installing XMMS Error with glib


This is the message I get after running ./configure
How do I check if I have iglib installed properly? As you can see I did a gli then hit TAB and found those entriies. Let me know what or if more info is needed.

checking for glib-config... no
checking for GLIB - version >= 1.2.2... no
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***
[root@localhost xmms-1.2.10]# gli
glibcbug glib-genmarshal glib-mkenums
glibc-post-upgrade glib-gettextize
[root@localhost xmms-1.2.10]#
 
Old 11-14-2004, 09:30 PM   #2
rmartine
Member
 
Registered: Dec 2002
Location: San Luis Obispo, CA
Distribution: Fedora Core 3
Posts: 618

Rep: Reputation: 30
Try this: yum install glib*

Also, I installed xmms using yum install xmms

Good Luck!
 
Old 11-14-2004, 11:07 PM   #3
eelriver
Member
 
Registered: May 2004
Location: san francisco
Distribution: Slackware 10.2 kernel 2.6.13, Gentoo amd64, Some mish-mash of programs that started with slack 9.0
Posts: 165

Rep: Reputation: 30
You don't mention what distribution you are using but if it's one of those that uses a RPM type package system there is probably a precompiled rpm for xmms.
 
Old 12-05-2004, 02:09 PM   #4
kevpatts
LQ Newbie
 
Registered: May 2004
Posts: 20

Rep: Reputation: 0
I have glib 2.4.7 installed on Fedora core 3 and I get the same messege

any ideas?
 
Old 12-21-2004, 10:31 AM   #5
schmee
LQ Newbie
 
Registered: Jun 2004
Distribution: FC3/4, Debian, SuSE
Posts: 7

Rep: Reputation: 0
Quote:
Originally posted by kevpatts
I have glib 2.4.7 installed on Fedora core 3 and I get the same messege

any ideas?

You need glib-devel and gtk+-devel.
(found relevant info at http://bugs.xmms.org/show_bug.cgi?id=1894 )

[root@host xmms-1.2.10]# yum install glib-devel gtk+-devel
then ./configure again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
glib not found when installing xmms??????? help!!! nicdee Linux - Software 15 08-09-2005 11:13 PM
installing xmms (glib..atk...) nadroj Linux - Newbie 6 04-12-2005 02:41 PM
GLIB problems installing xmms 1.2.9 Dancingsalad Linux - Software 4 02-08-2004 06:04 PM
Installing XMMS, Problem with glib Inexactitude Linux - Software 3 10-18-2003 04:01 PM


All times are GMT -5. The time now is 09:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration