LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-26-2003, 02:12 PM   #1
Higgy3k
LQ Newbie
 
Registered: Jun 2003
Posts: 5

Rep: Reputation: 0
Installing Wine


I have Mandrake 9 and I updated GLIBC from 2.2 to 2.3 to run Wine.
I tested all my programs and they all run fine.

Then I went to install wine RPM

I get the folllowing error:

<ome/stephen/wine-20030508-mdk9.1.i586.rpm;echo RESULT=$?
Segmentation fault
RESULT=139



I then tried another WINE version and got the following:

cups-libs >= 1.1.12 is needed by wine-20030408-1rh8winehq

I assume I need the cups library but when I downloaded thaqt and tried installing it it asked for many other files

Can anyone tell me what I need, were to get it?
 
Old 06-26-2003, 03:02 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
well first and foremost, you need the mandrake rpm, or compile from source..
if you look at the file you were trying to install it has rh8 written in the name meaning its built for redhat 8

so for instance if you click the link below you will receive the rpm built for mandrake 9
mandrake 9 rpm

give that a try and see what happens
 
Old 06-26-2003, 07:42 PM   #3
zakl
Member
 
Registered: May 2003
Location: Texas
Distribution: Gentoo
Posts: 80

Rep: Reputation: 15
DrOzz:

He already tried a Mandrake rpm, if you looked at his first error post.

Higgy3k:

The first rpm with the seg fault error most likely means the rpm is corrupt, try downloading a newer/older version, or the same version from a different source.

The second error

cups-libs >= 1.1.12 is needed by wine-20030408-1rh8winehq

simply means you need to upgrade your cups-libs rpm to version 1.1.12 or newer. For future reference, you can get almost any rpm from rpmfind.net, or www.rpmfind.net. And those are NOT the same servers. They are different mirrors for rpmfind... I believe one is the speakeasy mirror and the other is the MIT mirror.

Anyway, if you choose to go with the RH8 rpm and upgrad cups-libs, you might find that upgrading cups-libs could require you to upgrade a few, or a lot of other packages which are dependencies.

Good luck,

Zak
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wine: installing win apps. using wine on mandrake10 dexmax Linux - Newbie 2 09-05-2005 05:40 PM
installing wine ashutosh_singh Linux - Newbie 1 09-08-2004 02:54 AM
installing wine davidfes Linux - General 2 08-03-2004 08:24 AM
Installing Wine fuelinjection Linux - Software 3 04-07-2004 02:31 PM
Installing WINE Trust Slackware 11 03-26-2004 04:55 AM


All times are GMT -5. The time now is 03:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration