LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Installing vim-gnome or vim-gtk dependency issues with apt, aptitude, synaptic (http://www.linuxquestions.org/questions/linux-software-2/installing-vim-gnome-or-vim-gtk-dependency-issues-with-apt-aptitude-synaptic-944919/)

alagenchev 05-14-2012 01:39 PM

Installing vim-gnome or vim-gtk dependency issues with apt, aptitude, synaptic
 
I am trying to install vim-gnome or vim-gtk and I when I try to install it through synaptic, apt tries to remove gnome-applets, gnome-session and a bunch of other stuff that I think it should have no business removing.
Package->Automatically installed is already unchecked for gnome-applets and using unmarkauto didn't do anything either.

Here is the output from aptitude

alagenchev@tangra:~$ sudo aptitude --simulate install vim-gnome
[sudo] password for alagenchev:
The following NEW packages will be installed:
libperl5.14{a} vim-gnome vim-gui-common{a}
The following packages will be upgraded:
libacl1 libattr1 perl-base{b} vim-common vim-runtime vim-tiny
6 packages upgraded, 3 newly installed, 0 to remove and 1195 not upgraded.
Need to get 9,814 kB of archives. After unpacking 4,199 kB will be freed.
The following packages have unmet dependencies:
libtext-charwidth-perl: Depends: perlapi-5.12.4 which is a virtual package.
libpurple0: Depends: perlapi-5.12.4 which is a virtual package.
libnet-ssleay-perl: Depends: perlapi-5.12.3 which is a virtual package.
libgnome2-vfs-perl: Depends: perlapi-5.12.4 which is a virtual package.
libnet-dbus-perl: Depends: perlapi-5.12.3 which is a virtual package.
libxml-parser-perl: Depends: perlapi-5.12.3 which is a virtual package.
libcairo-perl: Depends: perlapi-5.12.3 which is a virtual package.
libgtk2-perl: Depends: perlapi-5.12.3 which is a virtual package.
libhtml-parser-perl: Depends: perlapi-5.12.3 which is a virtual package.
perl: Depends: perl-base (= 5.12.4-4) but 5.14.2-9 is to be installed.
libgtk2-imageview-perl: Depends: perlapi-5.12.3 which is a virtual package.
libsub-name-perl: Depends: perlapi-5.12.3 which is a virtual package.
libuuid-perl: Depends: perlapi-5.12.3 which is a virtual package.
liblocale-gettext-perl: PreDepends: perlapi-5.12.4 which is a virtual package.
libalgorithm-diff-xs-perl: Depends: perlapi-5.12.4 which is a virtual package.
perl-base: Conflicts: update-inetd (< 4.41) but 4.39 is installed and it is kept back.
libpango-perl: Depends: perlapi-5.12.3 which is a virtual package.
libgnome2-gconf-perl: Depends: perlapi-5.12.3 which is a virtual package.
libgnome2-canvas-perl: Depends: perlapi-5.12.3 which is a virtual package.
libglib-perl: Depends: perlapi-5.12.4 which is a virtual package.
vim: Depends: vim-common (= 2:7.3.280-1) but 2:7.3.429-2 is to be installed.
Depends: vim-runtime (= 2:7.3.280-1) but 2:7.3.429-2 is to be installed.
libgnome2-wnck-perl: Depends: perlapi-5.12.3 which is a virtual package.
libperl5.12: Depends: perl-base (= 5.12.4-4) but 5.14.2-9 is to be installed.
libtext-iconv-perl: Depends: perlapi-5.12.4 which is a virtual package.
pidgin: Depends: perlapi-5.12.4 which is a virtual package.
libgnome2-perl: Depends: perlapi-5.12.3 which is a virtual package.
libapt-pkg-perl: Depends: perlapi-5.12.3 which is a virtual package.
liblist-moreutils-perl: Depends: perlapi-5.12.4 which is a virtual package.
perlmagick: Depends: perlapi-5.12.3 which is a virtual package.
The following actions will resolve these dependencies:

Remove the following packages:
1) anjuta-common
2) apt-file
3) aspell
4) aspell-en
5) banshee
6) build-essential
7) cli-common
8) command-not-found
9) compiz-gnome
10) compiz-gtk
11) cowsay
12) cups-driver-gutenprint
13) debconf-i18n
14) dictionaries-common
15) docbook-xml
16) docbook-xsl
17) dpkg-dev
18) foomatic-db-engine
19) foomatic-filters-ppds
20) giver
21) gnome-applets
22) gnome-control-center
23) gnome-session
24) gnome-system-tools
25) gnome-user-guide
26) gthumb
27) gthumb-data
28) gtkpod
29) hpijs
30) hunspell
31) hunspell-en-us
32) hunspell-tools
33) kate
34) kdbg
35) kdebase-runtime
36) kdebase-runtime-data
37) kdelibs5-data
38) kdelibs5-plugins
39) kdoctools
40) libalgorithm-diff-perl
41) libalgorithm-diff-xs-perl
42) libalgorithm-merge-perl
43) libanjuta-3-0
44) libapt-pkg-perl
45) libart2.0-cil
46) libavahi1.0-cil
47) libboo2.0.9-cil
48) libcairo-perl
49) libclass-accessor-perl
50) libconfig-file-perl
51) libdbus-glib1.0-cil
52) libdbus1.0-cil
53) libdpkg-perl
54) libencode-locale-perl
55) libfile-basedir-perl
56) libfile-copy-recursive-perl
57) libfile-desktopentry-perl
58) libfile-homedir-perl
59) libfile-listing-perl
60) libfile-mimeinfo-perl
61) libfile-which-perl
62) libflickrnet2.2-cil
63) libfont-afm-perl
64) libgconf2.0-cil
65) libgdata1.7-cil
66) libgdata1.8-cil
67) libgkeyfile1.0-cil
68) libglade2.0-cil
69) libglib-perl
70) libglib2.0-cil
71) libgmime2.4-cil
72) libgnome-keyring1.0-cil
73) libgnome-vfs2.0-cil
74) libgnome2-canvas-perl
75) libgnome2-gconf-perl
76) libgnome2-perl
77) libgnome2-vfs-perl
78) libgnome2-wnck-perl
79) libgnome2.24-cil
80) libgnomepanel2.24-cil
81) libgtk-sharp-beans-cil
82) libgtk2-imageview-perl
83) libgtk2-perl
84) libgtk2.0-cil
85) libgtkpod1
86) libgudev1.0-cil
87) libhpmud0
88) libhtml-form-perl
89) libhtml-format-perl
90) libhtml-parser-perl
91) libhtml-tagset-perl
92) libhtml-template-perl
93) libhtml-tree-perl
94) libhttp-cookies-perl
95) libhttp-daemon-perl
96) libhttp-date-perl
97) libhttp-message-perl
98) libhttp-negotiate-perl
99) libhttp-server-simple-perl
100) libio-socket-ssl-perl
101) libio-string-perl
102) liblist-moreutils-perl
103) liblocale-gettext-perl
104) liblwp-mediatypes-perl
105) liblwp-protocol-https-perl
106) libmailtools-perl
107) libmetacity-private0
108) libmono-addins-gui0.2-cil
109) libmono-addins0.2-cil
110) libmono-zeroconf1.0-cil
111) libndesk-dbus-glib1.0-cil
112) libndesk-dbus1.0-cil
113) libnet-dbus-perl
114) libnet-http-perl
115) libnet-ssleay-perl
116) libnotify0.4-cil
117) libnss-mdns
118) liboobs-1-4
119) libpango-perl
120) libparse-debianchangelog-perl
121) libperl5.12
122) libproc-simple-perl
123) libpurple-bin
124) libpurple0
125) libregexp-assemble-perl
126) libsnmp15
127) libsort-naturally-perl
128) libsub-name-perl
129) libtaglib2.0-cil
130) libtext-charwidth-perl
131) libtext-iconv-perl
132) libtext-wrapi18n-perl
133) libtie-ixhash-perl
134) libtimedate-perl
135) liburi-perl
136) libuuid-perl
137) libwww-mechanize-perl
138) libwww-perl
139) libwww-robotrules-perl
140) libx11-protocol-perl
141) libxml-namespacesupport-perl
142) libxml-parser-perl
143) libxml-sax-expat-perl
144) libxml-sax-perl
145) libxml-simple-perl
146) libxml-twig-perl
147) linux-base
148) linux-image-2.6-amd64
149) linux-image-2.6.39-2-amd64
150) linux-image-3.0.0-1-amd64
151) linux-image-amd64
152) lm-sensors
153) metacity
154) metacity-common
155) mint-meta-common
156) mint-meta-debian
157) mintsystem
158) myspell-en-gb
159) perl
160) perl-modules
161) perlmagick
162) pidgin
163) pidgin-facebookchat
164) rarian-compat
165) samba
166) sane-utils
167) sgml-base
168) sgml-data
169) shiki-colors-metacity-theme
170) shiki-wise-theme
171) shutter
172) system-tools-backends
173) tomboy
174) update-inetd
175) vim
176) xchat
177) xml-core
178) yelp

Leave the following dependencies unresolved:
179) apturl recommends libgnome2-perl
180) inxi recommends lm-sensors
181) libaspell15 recommends aspell-en | aspell-dictionary | aspell6a-diction
182) libalgorithm-diff-perl recommends libalgorithm-diff-xs-perl
183) libparse-debianchangelog-perl recommends libxml-simple-perl
184) xfce4-dict recommends aspell | ispell
185) xfce4-sensors-plugin recommends lm-sensors
186) mono-2.0-gac recommends cli-common (>= 0.4.0)
187) debconf recommends debconf-i18n
188) libsane recommends sane-utils (>= 1.0.22-6)
189) gnome-terminal recommends yelp
190) libxml2 recommends xml-core
191) libnet-http-perl recommends libio-socket-ssl-perl (>= 1.38)
192) libxml-sax-perl recommends libxml-sax-expat-perl
193) libkdeui5 recommends kdelibs5-data (>= 4:4.6.5-2)
194) capplets-data recommends gnome-control-center (>= 1:2.30.1-3)
195) dpkg-dev recommends libalgorithm-merge-perl
196) dkms recommends linux-image
197) gnome-panel recommends gnome-applets (>= 2.12.1-1)
198) gnome-panel recommends gnome-session (>= 2.26)
199) gnome-panel recommends gnome-control-center
200) gedit recommends yelp
201) libwww-mechanize-perl recommends libio-socket-ssl-perl
202) mousetweaks recommends gnome-control-center
203) libkio5 recommends kdelibs5-plugins (= 4:4.6.5-2)
204) libknewstuff2-4 recommends kdelibs5-data (= 4:4.6.5-2)
205) docbook-xsl recommends docbook-xml (>= 4.1.2-4)
206) gcalctool recommends yelp
207) synaptic recommends libgtk2-perl (>= 1:1.130)
208) synaptic recommends rarian-compat
209) libhunspell-1.2-0 recommends hunspell-en-us | hunspell-dictionary | mys
210) libknewstuff3-4 recommends kdelibs5-data (= 4:4.6.5-2)
211) ntp recommends perl
212) xdg-utils recommends libfile-mimeinfo-perl
213) xchat-common recommends xchat
214) foomatic-filters recommends foomatic-db-engine (>= 4.0)
215) gucharmap recommends yelp
216) libkhtml5 recommends kdelibs5-plugins (= 4:4.6.5-2)
217) gthumb-data recommends yelp
218) aptitude recommends libparse-debianchangelog-perl
219) gdebi recommends libgtk2-perl
220) libexo-1-0 recommends liburi-perl
221) xscreensaver recommends perl5
222) gnome-system-tools recommends gnome-control-center (>= 1:2.10.1-1)
223) sun-java6-bin recommends libnss-mdns
224) foomatic-db recommends foomatic-db-engine
225) foomatic-db recommends hpijs
226) libxml-twig-perl recommends libtext-iconv-perl
227) libxml-twig-perl recommends libtie-ixhash-perl
228) libxml-twig-perl recommends libwww-perl
229) libxml-twig-perl recommends libhtml-parser-perl
230) avahi-daemon recommends libnss-mdns
231) cups recommends cups-driver-gutenprint


Accept this solution? [Y/n/q/?]

This is on Mint Debian edition, so I am ok with so many unupgraded packages.
The question is, how can I install vim-gtk or vim-gnome without removing all packages that are clearly needed?

EricTRA 05-15-2012 12:58 AM

Hello,

Be careful with that choice. I encountered the same problem last Thursday and got lots of stuff uninstalled leaving my system crippled. That happens when you trust to much and press Y to fast. I've learned once again that output serves a purpose. The problem lies in the fact that some versions of packages are different in the Linux Mint repository and the Debian one(s). In my case, commenting out the Linux Mint repository (which pointed to an older version of several libraries) solved my problem and I was able to re-install the uninstalled packages.

In short, find out which packages are conflicting (apt-cache policy), comment out the conflicting repository (most likely older version in Linux Mint repo), install your software, uncomment the repo and be careful with upgrades.

Kind regards,

Eric

craigevil 05-15-2012 01:28 AM

Post your sources.list

if this is the same person that has a similar thread at the Mint LMDE forum, get rid of the Ubuntu and wine repos.

What your sources.list should look like more or less, also see the links:
# Incoming and latest info http://forums.linuxmint.com/viewtopic.php?f=187&t=76556
# For info see http://forum.linuxmint.com/viewtopic.php?f=197&t=79533
# Default LMDE repositories as of Update Pack 4
# deb http://packages.linuxmint.com/ debian main import backport romeo upstream
# deb http://debian.linuxmint.com/latest testing main contrib non-free
# deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
# deb http://debian.linuxmint.com/latest/multimedia testing main non-free

apt-get update; apt-get install vim -s and post any errors.

alagenchev 05-15-2012 10:33 AM

Quote:

Originally Posted by craigevil (Post 4678543)
Post your sources.list

if this is the same person that has a similar thread at the Mint LMDE forum, get rid of the Ubuntu and wine repos.

What your sources.list should look like more or less, also see the links:
# Incoming and latest info http://forums.linuxmint.com/viewtopic.php?f=187&t=76556
# For info see http://forum.linuxmint.com/viewtopic.php?f=197&t=79533
# Default LMDE repositories as of Update Pack 4
# deb http://packages.linuxmint.com/ debian main import backport romeo upstream
# deb http://debian.linuxmint.com/latest testing main contrib non-free
# deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
# deb http://debian.linuxmint.com/latest/multimedia testing main non-free

apt-get update; apt-get install vim -s and post any errors.

craigevil, I did post to the mint forums, but I don't know if you are referring to me or someone else. I don't have ubuntu repos in my sources.list and my sources.list appears pretty much like yours.
I did solve my problem though. I was pointed to by a moderator on the mint forums that apt would never be able to resolve my dependencies with so many packages out of date.
Essentially what happens is that vim-gtk needs some gtk library. Let's say that the example gtk library is at a high version in my repos. In order for apt to pull that library, it has to pull all its dependencies and so on. I essentially had to update my system using the update manager to the latest and greatest, which meant pulling gnome3 too. It took me an hour to update my system just to get the stupid gvim text editor working. The "joys" of having a rolling distro I guess.
I have to give kudos to the mint team though. I was very nervous about applying so many updates, but everything worked fine. If this was handled by canonical, i would probably be pulling my hair now.
Thanks for everyone's help


All times are GMT -5. The time now is 01:45 PM.