LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-16-2004, 01:09 PM   #1
phatboyz
Member
 
Registered: Feb 2004
Location: Mooresville NC
Distribution: CentOS 4,Free BSD,
Posts: 358

Rep: Reputation: 30
Installing Squid


Hey I downloaded the squid.tar.gz file from the net. I right clicked on it and extraced it to squid1. I noticed that in the install notes it has the directory of /usr/local/squid/etc/. I think that that was wrong so I put the directory in /usr/local/etc/squid. Now if I am in the squid directory I can not run this command to install.
Can you tell me what I have done wrong? Here is the install notes. How do I put the syntax of this command? This is the first script that I have created before. At the beggining of each line do I need to have the # and the % (not sure but this must be a variable or somthing). I ran the chmod 775 on the file that I made with VI and saved it as "proxy" and saved it in /sbin and the script runs but I do not see any files installed.



# % ./configure --prefix=/usr/local/squid
# % make all
# % make install

To run a Cache, you will need to:

1. customize the squid.conf configuration file:
% vi /usr/local/squid/etc/squid.conf

2. start the cache:
% /usr/local/squid/sbin/proxy
If you want to use the WWW interface to the Cache Manager, copy
the cachemgr.cgi program into your httpd server's cgi-bin
directory.
 
Old 02-16-2004, 02:48 PM   #2
phatboyz
Member
 
Registered: Feb 2004
Location: Mooresville NC
Distribution: CentOS 4,Free BSD,
Posts: 358

Original Poster
Rep: Reputation: 30
OK here is what happend when I tried to run the commant ./configure --prefix=/usr/local/squid1
What do I do to fix this?
[root@nixserver squid1]# ./configure --prefix=/usr/local/squid1
loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for mawk... no
checking for gawk... gawk
checking whether make sets ${MAKE}... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for gcc... no
checking for cc... no
configure: error: no acceptable cc found in $PATH
[root@nixserver squid1]#
 
Old 02-16-2004, 06:36 PM   #3
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 48
cc & gcc are two of the options for the compiler programme to use...
And it looks like neither are present, so you can't compile or build anything without them...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SQUID for blocking yahoo and msn [inc squid.conf] chrisfirestar Linux - Security 10 03-03-2008 09:33 AM
installing squid Faizan Linux - Networking 1 05-04-2005 01:38 PM
squid conf: squid failed when I type insert redirect_program /usr/bin/squidguard Niceman2005 Linux - Software 1 11-24-2004 03:29 PM
need help installing squid on rh8 tr3s Linux - Newbie 0 10-26-2004 10:10 PM
Installing & Configuring SQUID on Linux digimart Linux - Software 0 10-26-2003 08:48 AM


All times are GMT -5. The time now is 07:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration