LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-17-2002, 02:23 PM   #1
unixpirate
Member
 
Registered: Oct 2002
Location: Maryland
Distribution: RedHat 7.3
Posts: 44

Rep: Reputation: 15
Angry installing rpm's help


I am attemtping to install firestarter and keep getting a message that it is already installed. But when I do a verify it says not installed.

[root@mcbain /]# rpm -Uvh firestarter*rpm
Preparing... ########################################### [100%]
package firestarter-0.8.3-1 is already installed

then I do, and it says
[root@mcbain /]# rpm -V firestarter-0.8.3-1.i386.rpm
package firestarter-0.8.3-1.i386.rpm is not installed

I do a
[root@mcbain /]# find / -name firestarter*
/firestarter-0.8.3-1.i386.rpm. Nothing.

What am I doing wrong?
Running RH 7.3.

thanks,
Jay
 
Old 12-17-2002, 02:56 PM   #2
michael_hilliard
LQ Newbie
 
Registered: Apr 2001
Posts: 4

Rep: Reputation: 0
What do you get when you do an rpm -q firestarter?
 
Old 12-17-2002, 03:01 PM   #3
unixpirate
Member
 
Registered: Oct 2002
Location: Maryland
Distribution: RedHat 7.3
Posts: 44

Original Poster
Rep: Reputation: 15
[root@mcbain /tmp]# rpm -q firestarter*rpm
package firestarter-0.8.3-1.i386.rpm is not installed
 
Old 12-17-2002, 03:25 PM   #4
unixpirate
Member
 
Registered: Oct 2002
Location: Maryland
Distribution: RedHat 7.3
Posts: 44

Original Poster
Rep: Reputation: 15
I downloaded a newer v of firestarter and this is what I get when attempting to do the install

[root@mcbain /root]# rpm -Uvh firestarter*rpm
error: failed dependencies:
glib2 >= 2.0.1 is needed by firestarter-0.9.0-1
gtk2 >= 2.0.1 is needed by firestarter-0.9.0-1
libart_lgpl_2.so.2 is needed by firestarter-0.9.0-1
libatk-1.0.so.0 is needed by firestarter-0.9.0-1
libbonobo-2.so.0 is needed by firestarter-0.9.0-1
libbonobo-activation.so.4 is needed by firestarter-0.9.0-1
libbonoboui-2.so.0 is needed by firestarter-0.9.0-1
libcrypto.so.2 is needed by firestarter-0.9.0-1
libgconf-2.so.4 is needed by firestarter-0.9.0-1
libgdk_pixbuf-2.0.so.0 is needed by firestarter-0.9.0-1
libgdk-x11-2.0.so.0 is needed by firestarter-0.9.0-1
libglib-2.0.so.0 is needed by firestarter-0.9.0-1
libgmodule-2.0.so.0 is needed by firestarter-0.9.0-1
libgnome-2.so.0 is needed by firestarter-0.9.0-1
libgnomecanvas-2.so.0 is needed by firestarter-0.9.0-1
libgnomeui-2.so.0 is needed by firestarter-0.9.0-1
libgnomevfs-2.so.0 is needed by firestarter-0.9.0-1
libgobject-2.0.so.0 is needed by firestarter-0.9.0-1
libgthread-2.0.so.0 is needed by firestarter-0.9.0-1
libgtk-x11-2.0.so.0 is needed by firestarter-0.9.0-1
liblinc.so.1 is needed by firestarter-0.9.0-1
libORBit-2.so.0 is needed by firestarter-0.9.0-1
libORBitCosNaming-2.so.0 is needed by firestarter-0.9.0-1
libpango-1.0.so.0 is needed by firestarter-0.9.0-1
libpangoft2-1.0.so.0 is needed by firestarter-0.9.0-1
libpangox-1.0.so.0 is needed by firestarter-0.9.0-1
libpangoxft-1.0.so.0 is needed by firestarter-0.9.0-1
libssl.so.2 is needed by firestarter-0.9.0-1
libxml2.so.2 is needed by firestarter-0.9.0-1
 
Old 12-17-2002, 04:08 PM   #5
ubien
Member
 
Registered: Oct 2002
Distribution: RH 8.0 and fluxbox
Posts: 122

Rep: Reputation: 15
you'll need to install gtk 2.0 for the newer version of firestarter to work
 
Old 12-18-2002, 09:21 AM   #6
unixpirate
Member
 
Registered: Oct 2002
Location: Maryland
Distribution: RedHat 7.3
Posts: 44

Original Poster
Rep: Reputation: 15
That sounds easy.. Is this part of the RH install? If so, can I install it seperatley?
Thanks for your help
 
Old 12-18-2002, 03:17 PM   #7
ubien
Member
 
Registered: Oct 2002
Distribution: RH 8.0 and fluxbox
Posts: 122

Rep: Reputation: 15
It's not part of RH install. You have GTK 1.2 installed right now, you can goto www.gtk.org and get the tarballs / RPMs for GTK 2.0. You can have both 1.2 and 2.0 installed at the same time.
 
Old 12-18-2002, 03:20 PM   #8
unixpirate
Member
 
Registered: Oct 2002
Location: Maryland
Distribution: RedHat 7.3
Posts: 44

Original Poster
Rep: Reputation: 15
Well come to find out we don't have X windows installed and this requires it.
Correct?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RPM's not installing! =( Kane635 Linux - Software 2 09-14-2004 10:06 PM
installing rpm's joepesci Linux - Newbie 3 07-20-2004 04:10 PM
RPM's not installing.... kperrone Linux - Software 9 07-05-2004 07:51 PM
installing rpm's apoc013 Linux - Newbie 7 01-21-2004 10:55 AM
Installing RPM's drojek Linux - Software 6 05-08-2003 10:38 PM


All times are GMT -5. The time now is 09:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration