LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 02-23-2002, 12:31 PM   #1
Infinity
Member
 
Registered: Sep 2001
Location: USA
Distribution: Fedora 10, Nokia N800 OS2008
Posts: 56

Rep: Reputation: 15
Installing redhat to ata100 drive on a SIIG controller.


I've installed a SIIG Ultra ATA/133 controller and connected a new hard drive and existing ATAPI CD-ROM to it. There's nothing on the hard drive and I'm trying to install RedHat 7.2 on it.

I've retrieved the latest boot diskette, which will correctly probe the SIIG controller only if I tell it exactly where it is using the following boot prompt:

linux ide0=0xfcd8

It probes the controller, sees the hard drive, has some odd trouble trying to repeatedly reset the ATAPI CD-ROM drive, loads the floppy controller, then says:

Partition check
hda:

And stops there. I'm pretty sure it's hanging at this point.

If I tell it not to probe ide0 or omit that ide0=0xfcd8 parameter, it will not see the hard drive or cd-rom once the installer starts up.

Does anyone have any suggestions on how to get over the "Partition check" freeze?
 
Old 02-24-2002, 11:06 PM   #2
Infinity
Member
 
Registered: Sep 2001
Location: USA
Distribution: Fedora 10, Nokia N800 OS2008
Posts: 56

Original Poster
Rep: Reputation: 15
it's the cd-rom drive

Looks like it's the CD-ROM drive. When I pull it from the chain it finishes booting.

The darn thing is just a 16x drive. Don't tell me I have to go out and buy a new one! It won't pass the boot on the original IDE controller either. Hm somehow another boot parameter might be able to fix it.
 
Old 02-25-2002, 08:05 PM   #3
Infinity
Member
 
Registered: Sep 2001
Location: USA
Distribution: Fedora 10, Nokia N800 OS2008
Posts: 56

Original Poster
Rep: Reputation: 15
nope it's the card

Looks like the SIIG card is incompatible with Red Hat 7.2

I've installed a Promise-based Maxtor-branded card and it's working fine at the start of installation without requiring other kernel parameters. Back to the store goes the SIIG card, and for shame, they have Linux written on their box!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2.6.x compatible ide ata100 controller card radabasp Linux - Hardware 2 10-27-2004 11:27 AM
Please... help me install my driver for a Siig UltraATA 133 PCI IDE controller card. aweir14150 Linux - Software 2 06-02-2004 11:14 PM
Slack on an ATA100/RAID controller BrandonJG Slackware 4 09-07-2002 08:51 PM
ata100.i - self compiled kernel doesn't recognize ATA100 controller... wtf? keex Slackware 1 06-28-2002 04:57 AM
Damn you LILO... RedHat + Abit/HPT370 ATA100 controller = "LI " neeyo Linux - Software 24 02-14-2002 12:32 AM


All times are GMT -5. The time now is 01:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration