LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-08-2004, 06:05 PM   #1
drenal
Member
 
Registered: Dec 2003
Location: Poland
Distribution: slackware current
Posts: 53

Rep: Reputation: 15
installing quota


Hello, I have just installed quota and read howto.. But I have a problem with this tool..
Here is some errors while system boot:

Code:
Checking filesystem quotas:  /sbin/quotacheck -avugM
quotacheck: Scanning /dev/hda7 [/home] done
quotacheck: Checked 1504 directories and 18222 files
Activating filesystem quotas:  /sbin/quotaon -avug
quotaon: using /home/aquota.user on /dev/hda7 [/home]: No such process  
quotaon: Quota format not supported in kernel.
I have the lastest quota installed and it's compiled in my 2.4.24-ow and some settings for testing user:

[CODE}
# quota tester
Limity dyskowe dla user tester (uid 1011):
System plików bloki miękki twardy pobł. pliki miękki twardy pobł.
/dev/hda7 1928* 1024 1024 22 120 120

[/CODE]
(It's in polish)

but when I try to run 'quota' as user 'tester' there is permission denied to /home/aquota.user (root 600) and checking quota fails.
 
Old 02-08-2004, 06:14 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
What filesystem are you using and are you sure you enabled it in your kernel?

And I assume your running or starting it logged in as root?
 
Old 02-08-2004, 06:17 PM   #3
drenal
Member
 
Registered: Dec 2003
Location: Poland
Distribution: slackware current
Posts: 53

Original Poster
Rep: Reputation: 15
# cat /usr/src/linux/.config | grep EXT3
CONFIG_EXT3_FS=y

# mount | grep /home
/dev/hda7 on /home type ext3 (rw,usrquota)
 
Old 02-08-2004, 06:24 PM   #4
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
And your output of this: cat /usr/src/linux/.config | grep QUOTA
 
Old 02-08-2004, 06:26 PM   #5
drenal
Member
 
Registered: Dec 2003
Location: Poland
Distribution: slackware current
Posts: 53

Original Poster
Rep: Reputation: 15
# cat /usr/src/linux/.config | grep QUOTA
CONFIG_QUOTA=y
 
Old 02-08-2004, 06:53 PM   #6
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
did you run the quotacheck -c option to make the quota files?

quotacheck -acug /dir

just a shot in the dark, but from what you posted it didn't look like you ran that yet.
 
Old 02-08-2004, 07:32 PM   #7
drenal
Member
 
Registered: Dec 2003
Location: Poland
Distribution: slackware current
Posts: 53

Original Poster
Rep: Reputation: 15
I have just ran 'quotacheck -acug' manually and it did check my /home without errors, but after reboot there is the same output with errors while booting
Code:
quotaon: using /home/aquota.user on /dev/hda7 [/home]: No such process  
quotaon: Quota format not supported in kernel.
 
Old 02-08-2004, 07:40 PM   #8
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
Quote:
Originally posted by drenal
I have just ran 'quotacheck -acug' manually and it did check my /home without errors, but after reboot there is the same output with errors while booting
Code:
quotaon: using /home/aquota.user on /dev/hda7 [/home]: No such process  
quotaon: Quota format not supported in kernel.
How are you editing the quota file? And why do you have it named as aquota.user? In most cases it should be named just quota.user.

In your home directory since that is where you want quota's, you should have both quota.user and quota.group
 
Old 02-08-2004, 07:51 PM   #9
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
Can you post your quota.user file? Looking over and over, everything seems to be ok but yet the error your getting clearly states your format of the file is not supported.

Heres an example of one of mine I use on one of my Slackware servers:
Code:
Disk quotas for user tarts (uid 502):
  Filesystem                   blocks       soft       hard     inodes     soft     hard
  /dev/hdb5                      8024      50000      60000         45        0        0
After issuing the 'edquota -u <username>' command to edit the quota for a particular user.
 
Old 02-08-2004, 07:55 PM   #10
drenal
Member
 
Registered: Dec 2003
Location: Poland
Distribution: slackware current
Posts: 53

Original Poster
Rep: Reputation: 15
I user quota-3.09 installed from tgz pack. I use only usrquota on /home and I edit it in standard way:
#edquota -u tester
and I haven't created /home/aquota.user because edquota created this file (I think)


taken from man edquota:
Code:
FILES
       aquota.user or aquota.group
                           quota file at the filesystem root (version 2 quota, non-XFS filesystems)
       quota.user or quota.group
                           quota file at the filesystem root (version 1 quota, non-XFS filesystems)
I don't have /home/(a)quota.group but do I really need it?
 
Old 02-08-2004, 07:59 PM   #11
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
Quote:
Originally posted by drenal
I user quota-3.09 installed from tgz pack. I use only usrquota on /home and I edit it in standard way:
#edquota -u tester
and I haven't created /home/aquota.user because edquota created this file (I think)


taken from man edquota:
Code:
FILES
       aquota.user or aquota.group
                           quota file at the filesystem root (version 2 quota, non-XFS filesystems)
       quota.user or quota.group
                           quota file at the filesystem root (version 1 quota, non-XFS filesystems)
I don't have /home/(a)quota.group but do I really need it?
No shouldn't need it if your not going to use group quota's. If you created the quota file by edquota then it must be version 2 that your using.

Can you post the output of the file, I have a feeling its the format that its not reading correctly as that is why your getting that error.
 
Old 02-08-2004, 08:07 PM   #12
drenal
Member
 
Registered: Dec 2003
Location: Poland
Distribution: slackware current
Posts: 53

Original Poster
Rep: Reputation: 15
this is some settings in '#edquota -u tester'
Code:
Limity dla user tester (uid 1011):
  System plików                bloki        miękki     twardy   i-węzły    miękki   twardy
  /dev/hda7                      1928       2000       2100         22       25       26
 
Old 02-08-2004, 08:26 PM   #13
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
I think this might be a problem with your version. If its compiled in try this:

modprobe quota_v2

And then see if you can't manually start quota with the quotaon command. Saw this on a google mailing list but was geared towards Suse, not sure if its going to work with Slackware.
 
Old 02-08-2004, 08:30 PM   #14
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
And what version of the quota utilities do you have installed and or did you complie quota as a module or builtin?
 
Old 02-08-2004, 08:37 PM   #15
drenal
Member
 
Registered: Dec 2003
Location: Poland
Distribution: slackware current
Posts: 53

Original Poster
Rep: Reputation: 15
bingo! )

thx man that's why you are Moderator not me; ) I did search in google but I should trust more google:>

I always say 'if you are looking for somn, ask google" now you remember me this: )
thx again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
quota jsheffie SUSE / openSUSE 2 02-24-2005 08:00 AM
ftp quota probs - 0kb files at quota limit ph_xm Linux - Newbie 0 02-02-2005 11:13 AM
quota Ammad Linux - General 3 12-10-2004 07:05 AM
Quota on/off sharon Linux - Newbie 2 07-21-2003 05:17 AM
quota on RH 7.3 keevitaja Linux - Newbie 5 08-17-2002 09:53 AM


All times are GMT -5. The time now is 08:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration