LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-06-2003, 12:31 PM   #1
WorldBuilder
Member
 
Registered: Mar 2003
Location: Massachusetts, USA
Distribution: RH 8, Solaris, Windoze eXPunged
Posts: 520

Rep: Reputation: 30
Installing PHP help, please.


Hi all,

I am trying to install the following package ont my RH8 machine:

php-4.3.2-rbt.apache13.rh8.0.i386.rpm

When I run "rpm -ivh php-4.3.2-rbt.apache13.rh8.0.i386.rpm, I get an error message saying this:

zziplib >= 0.10.27 is needed by php-4.3.2-rbt.apache13.rh8.0.i386.rpm

libzzip-0.so.10 is needed by php-4.3.2-rbt.apache13.rh8.0.i386.rpm

What are those? Also, do I really NEED them to install this PHP package? How can I install this package without these two other packages? Thanks a million!

Chris
 
Old 06-06-2003, 12:34 PM   #2
iceman47
Senior Member
 
Registered: Oct 2002
Location: Belgium
Distribution: Debian, Free/OpenBSD
Posts: 1,123

Rep: Reputation: 47
yes, you really need those as they are depencies of that rpm appearantly. www.rpmfind.net or your RedHat install cd's will help you further
 
Old 06-06-2003, 01:23 PM   #3
WorldBuilder
Member
 
Registered: Mar 2003
Location: Massachusetts, USA
Distribution: RH 8, Solaris, Windoze eXPunged
Posts: 520

Original Poster
Rep: Reputation: 30
Ok, this is not working, and I don't know why. Apparently, I need zziplib-0.10.27 and libzzip-0.so.10 before I can install php-4.3.2-rbt.apache13.rh8.0.i386.rpm. So, I downloaded the following rpm:

zziplib-0.10.27-pc.i386.rpm

Now, when I try to install that with "rpm -ivh zziplib-0.10.27-pc.i386.rpm", it tells me this:

Error:
Failed Dependencies:
libz is needed by zziplib-0.10.27-pc

Isn't that exactly what I am trying to INSTALL?!?! I don't get this. Bottom line, I need to install php, and I apparently need to install zziplib-0.10.27 and libzzip-0.so.10 before I can do that. How do I do this? Thanks a million!

Chris
 
Old 06-06-2003, 02:36 PM   #4
iceman47
Senior Member
 
Registered: Oct 2002
Location: Belgium
Distribution: Debian, Free/OpenBSD
Posts: 1,123

Rep: Reputation: 47
ok, I'm not the RedHat guru here, but if you need php, then you just search php on rpmfind.net.
here you can find php for RH8:
http://www.rpmfind.net//linux/RPM/re....0.5.i386.html
again: be sure you have all the depencies installed.

If you wish to install that rpm you have know on the other hand, just install every depency it's asking for.
I don't think it's hard to see that zziplib != libz.

I have no idea what's the difference between the two php rpm's though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing PHP tntcoder Linux - Newbie 4 12-17-2005 04:53 AM
installing php 5.0.5 da_cat Linux - Software 1 11-19-2005 08:16 AM
installing php-5.0.1 mohtasham1983 Linux - Software 1 06-27-2005 08:40 PM
Installing PHP vinicius Linux - Newbie 5 09-18-2003 01:36 PM
installing php loadimmed Linux - General 2 07-22-2003 11:36 AM


All times are GMT -5. The time now is 12:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration