LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-01-2012, 05:24 AM   #1
nzny
LQ Newbie
 
Registered: Jan 2012
Posts: 22

Rep: Reputation: Disabled
Unhappy installing ns2.28 on ubuntu 10.04


Dear all,

I hope someone can write a complete guideline on how to install ns2.28 on ubuntu 10.04.

I've reviewed through the forums for that matter, unfortunately none of the threads discussing it. (there are many guidelines, but none matches my need, ns2.28 on ubuntu 10.04). I've tried some of the provided guidelines, but the installation was not successful.

Really appreciate your helps.

thank you.
 
Old 03-01-2012, 05:31 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
we are not here to write documentation for you. we are here to help you fix *specific* problems. There's no point telling us something doesn't work if you don't provide any more information to help you with.
 
Old 03-01-2012, 05:52 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,160

Rep: Reputation: 2643Reputation: 2643Reputation: 2643Reputation: 2643Reputation: 2643Reputation: 2643Reputation: 2643Reputation: 2643Reputation: 2643Reputation: 2643Reputation: 2643
Quote:
.. unfortunately none of the threads discussing it ..
LQ Search : Keyword = ns2.28 ( All versions : Keyword = ns-allinone.)
http://www.linuxquestions.org/questi...0-04-a-842773/
> ".. installing ns 2.28 on ubuntu 10.04"

LQ Search : Tag = ns228
http://www.linuxquestions.org/questi...led-732164/#10
→ → Use the "script_228.txt".

Generally for Ubuntu : sudo apt-get install \
g++ autoconf automake libtool \
libx11-dev libxmu-dev libxmu-headers libxt-dev

And for ns-2.28 : g++-3.4
→ → Tick the 3 Hardy lines in
Synaptic > Settings > Repositories : Other Software.

cd ns-allinone-2.28/ && export CC=gcc-3.4 CXX=g++-3.4 && ./install

.

Last edited by knudfl; 03-01-2012 at 05:54 AM.
 
Old 03-01-2012, 09:41 PM   #4
nzny
LQ Newbie
 
Registered: Jan 2012
Posts: 22

Original Poster
Rep: Reputation: Disabled
tq acid and knudfl for your helpful replies...
 
  


Reply

Tags
installation, ns2, ubuntu104


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing ns2.33 in Ubuntu 11.04 priyanka.moon14 Linux - Software 10 02-13-2013 08:49 AM
Problem installing ns2 on Ubuntu Aden09 Linux - Newbie 7 04-18-2011 07:01 PM
urgent -- error installing ns2 on ubuntu 7.04 king2k Linux - Newbie 8 02-02-2011 06:28 AM
[SOLVED] problem in installing ns2.33 in ubuntu 8.10 neeraj.dwivedi Linux - Newbie 18 09-12-2009 09:00 AM
Problem Installing NS2 in Ubuntu 7.10 smetya Linux - Software 5 04-27-2008 09:27 AM


All times are GMT -5. The time now is 08:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration