LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-24-2003, 08:28 PM   #31
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30

Sounds good, let me know.
 
Old 03-24-2003, 08:34 PM   #32
DiZASTiX
Member
 
Registered: Mar 2003
Location: Boston Area
Distribution: Ubuntu (Edgy)
Posts: 247

Original Poster
Rep: Reputation: 30
ok, when i made fluxbox i was logged in as root, ive been logged in as root while im trying all this stuff
(ya i know, its dangerous i shouldnt but its to late now )
so when im in /root and do ls -a i see a buch of hidden files but no .xinitrc so i cant really follow those instructions u gave me
(i also made the user dizastix, started up x but theres no xinitrc for that user either :/)
should i edit one of those xinitrc that i mentioned be4

( /etc/X11/xinit/.xinitrc and /usr/X11R6/X11/xinit/xinitrc )
 
Old 03-24-2003, 08:39 PM   #33
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Okay. It seems like your system doesn't automagically create .xinitrc files for the user profiles so you're going to have to use the system's .xinitrc file. When you don't login as root, what user name do you use?

Also, when you started up x for "dizastix" did you get any window manager at all?

Yes. /etc/X11/xinit/.xinitrc

Let me know.
 
Old 03-24-2003, 08:45 PM   #34
DiZASTiX
Member
 
Registered: Mar 2003
Location: Boston Area
Distribution: Ubuntu (Edgy)
Posts: 247

Original Poster
Rep: Reputation: 30
Quote:
When you don't login as root, what user name do you use?

dizastix
Quote:
when you started up x for "dizastix" did you get any window manager at all?

Yup the default, KDE I think.
Quote:
Let me know.

Ok
 
Old 03-24-2003, 08:48 PM   #35
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
LOL. Okay, now after you've edited /etc/X11/xinit/.xinitrc let me know.
 
Old 03-24-2003, 08:53 PM   #36
DiZASTiX
Member
 
Registered: Mar 2003
Location: Boston Area
Distribution: Ubuntu (Edgy)
Posts: 247

Original Poster
Rep: Reputation: 30
Ok...im not lazy, im just stupid Im not exactly sure what you meen by the windowmanager section. Please dont think im trying to make u do all the work, but here is my /etc/X11/xinit/xinitrc file, maybe u can help explain to me a bit better if u see it:


#!/bin/sh
# (c) 1999-2002 Red Hat, Inc.

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
userxkbmap=$HOME/.Xkbmap

sysresources=/etc/X11/Xresources
sysmodmap=/etc/X11/Xmodmap
sysxkbmap=/etc/X11/Xkbmap

# merge in defaults
if [ -f "$sysresources" ]; then
xrdb -merge "$sysresources"
fi

if [ -f "$userresources" ]; then
xrdb -merge "$userresources"
fi

# merge in keymaps
if [ -f "$sysxkbmap" ]; then
setxkbmap `cat "$sysxkbmap"`
XKB_IN_USE=yes
fi

if [ -f "$userxkbmap" ]; then
setxkbmap `cat "$userxkbmap"`
XKB_IN_USE=yes
fi

if [ -z "$XKB_IN_USE" -a ! -L /etc/X11/X ]; then
if grep '^exec.*/Xsun' /etc/X11/X > /dev/null 2>&1 && [ -f /etc/X11/XF86Config ]; then
xkbsymbols=`sed -n -e 's/^[ ]*XkbSymbols[ ]*"\(.*\)".*$/\1/p' /etc/X11/XF86Config`
if [ -n "$xkbsymbols" ]; then
setxkbmap -symbols "$xkbsymbols"
XKB_IN_USE=yes
fi
fi
fi

# xkb and xmodmap don't play nice together
if [ -z "$XKB_IN_USE" ]; then
if [ -f "$sysmodmap" ]; then
xmodmap "$sysmodmap"
fi

if [ -f "$usermodmap" ]; then
xmodmap "$usermodmap"
fi
fi

unset XKB_IN_USE

# run all system xinitrc shell scripts.
for i in /etc/X11/xinit/xinitrc.d/* ; do
if [ -x "$i" ]; then
. "$i"
fi
done

# The user may have their own clients they want to run. If they don't,
# fall back to system defaults.
# set up ssh agent environment if available.

if [ -f $HOME/.Xclients ]; then
[ -x /usr/bin/ssh-agent -a -z "$SSH_AGENT_PID" ] && \
exec ssh-agent $HOME/.Xclients || \
exec $HOME/.Xclients
elif [ -f /etc/X11/xinit/Xclients ]; then
[ -x /usr/bin/ssh-agent -a -z "$SSH_AGENT_PID" ] && \
exec ssh-agent /etc/X11/xinit/Xclients || \
exec /etc/X11/xinit/Xclients
else
# failsafe settings. Although we should never get here
# (we provide fallbacks in Xclients as well) it can't hurt.
xclock -geometry 100x100-5+5 &
xterm -geometry 80x50-50+150 &
if [ -x /usr/bin/netscape -a -f /usr/share/doc/HTML/index.html ]; then
netscape /usr/share/doc/HTML/index.html &
fi
if [ -x /usr/X11R6/bin/fvwm2 ]; then
exec fvwm2
else
exec twm
fi
fi
 
Old 03-24-2003, 09:05 PM   #37
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Okay, yours looks weird to me. LOL Seriously. Open up your other one /usr/X11R6/X11/xinit/.xinitrc and try to post it here as well. From here we should be able to see what's up.

Oh yeah, since you've successfully logged into X with dizastix, try to see if there's a .xinitrc file created or not. Who knows? We may get lucky:

cd /home/dizastix
ls -a


If we can't get this sorted right now, I get home in 4 hours from work and can post my /etc/X11/xinit/.xinitrc file up here for you. I'm on a WinNT box right now so I can't give you great details unfortunately--my memory is good, but not that good.

Last edited by Texicle; 03-24-2003 at 09:16 PM.
 
Old 03-24-2003, 09:25 PM   #38
DiZASTiX
Member
 
Registered: Mar 2003
Location: Boston Area
Distribution: Ubuntu (Edgy)
Posts: 247

Original Poster
Rep: Reputation: 30
hmm, both /etc/X11/xinit/.xinitrc and /usr/X11R6/lib/X11/xinit/xinitrc are identical so theres no point in me posting it and nope, logging in as dizastix did not create a .xinitrc in /home/dizastix
 
Old 03-24-2003, 09:29 PM   #39
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
When I get home tonight, I'll post mine up and we can compare them. There should be a whole host of window managers/desktop environments you can choose from other than fvwm as yours shows. Have you run redhat-config-xfree86 as root yet? Perhaps this will help out. I'm not sure though as I'm a Slacker. Like I said, tonight I'll post up my .xinitrc for both my system and my user profile. We'll get your fluxbox up and running yet.

Oh yeah, how do you like RedHat so far?
 
Old 03-24-2003, 09:49 PM   #40
DiZASTiX
Member
 
Registered: Mar 2003
Location: Boston Area
Distribution: Ubuntu (Edgy)
Posts: 247

Original Poster
Rep: Reputation: 30
i just did redhat-config-xfree86 and it just popped up a window on display settings, everything was set fine. So far Red Hat has been nice. It auto detected all my hardware and even setup my internet, where as in slack i had to manually set my internet settings, even netconfig didnt work for me, also, i kept getting a sound error in slackware, no problems in rh, sound works great!

BTW, thought this might help a bit from the fluxbox documentation:

2.1.3. Running Fluxbox

It's all nice and good if you have it installed, but what use is it if you can't run it?

There are two generally different ways to start X11 (and thus Fluxbox). The traditional way is using the command startx. The other way is using a graphical login manager (also called "display manager"). The most common display manager is xdm which is part of the XFree86 distribution. The display manager provided by Gnome is called gdm, the one from KDE is kdm.

If X11 is started the former way (via startx), the file that is important is called .xinitrc and resides in your home directory. In the case of starting via a display manager, the file is .xsession which resides at the same location.

The next step is to find the executable for Fluxbox. For most people, this is /usr/local/bin/fluxbox. Now you need to edit (or create) the file I just mentioned. Just put the following line at the bottom of the file:

exec /usr/local/bin/fluxbox

Change the /usr/local/bin/fluxbox to where ever your Fluxbox executable is, the above is the default location when compiling from source. Once that is done, save it and close whatever editor you used to edit it. Now you need to run the following command if you use startx:

$ chmod 700 .xinitrc

In the case of .xsession that is not needed. In both cases, you should create the directory in which Fluxbox stores its configuration:

$ mkdir .fluxbox

If you don't create it, when you exit Fluxbox and restart, you will lose all your settings (the directory is not auto-created unfortunately).

Last edited by DiZASTiX; 03-24-2003 at 09:56 PM.
 
Old 03-24-2003, 10:02 PM   #41
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
*L* Slackware forces you to get your hands dirty a bit--no automagical configurations or any GUI setup interface. The bonus to this is knowing how your box works. The downside is newbie frustration. I reinstalled Slack about 15 times. I'm glad you like RH. In Slack, you would've had to chmod 755 your /dev/dsp and your /dev/mixer files to get your sound to work. You would've also most likely had to install/configure your sound card module as well. In the end, you get a good, working, stable system but you know why your system is good, working, and stable. Netconfig might not have worked for you if your NIC wasn't installed and set up with the right module and alias at the time. There's lots of steps you'll see with Slack that you won't ever get to see in many other distros. When something doesn't go right, however, it's easier to figure out when you can see what it's trying to do. Anyway, I'm glad you're doing well with RH. But when you go back to Slack, let me know.
 
Old 03-24-2003, 10:05 PM   #42
DiZASTiX
Member
 
Registered: Mar 2003
Location: Boston Area
Distribution: Ubuntu (Edgy)
Posts: 247

Original Poster
Rep: Reputation: 30
Hehe, well, i am glad i figured out (mostly by myelf) how to fix my network and i did learn stuff, but still, slackware and red hat are in there own ways very good.
 
Old 03-24-2003, 10:25 PM   #43
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
I responded to that before I saw your edit. Sorry. Basically, it's telling you to look for /home/dizastix/.xsession and then add the line exec /usr/local/bin/fluxbox to it. You also need to type:

mkdir /home/dizastix/.fluxbox

If you have neither .xinitrc nor .xsession and want to create them, you can do so with vi or any other text editor of your choice. However, when you type "startx" you get into KDE so there's a file out there somewhere that is calling KDE into play. We need to find that file and add exec /usr/local/bin/fluxbox instead.

Judging by your previous post of your /etc/X11/xinit/.xinitrc I'd say that this file is called /home/dizastix/.XClients or possibly /etc/X11/xinit/Xclients.

Have a look for them both. If you have one in your home directory, post it up. If not, post up the other one. You should see a list of stuff like this:

# exec gnome-session
# exec fvwm2
startkde
# exec fluxbox
# exec blackbox

You should make it look more like this:

# exec gnome-session
# exec fvwm2
# startkde
exec fluxbox
# exec blackbox

This should hopefully do it.
 
Old 03-24-2003, 11:39 PM   #44
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
I agree that both are good in their own ways. I'm not in any way bashing RedHat--just trying to promote Slack.

Anyway, let me know what you find in your ~/.Xclients file and if it worked. Again, I'll be posting my /etc/X11/xinit/.xinitrc file when I get home so we can try and sort this thing out.
 
Old 03-25-2003, 02:01 AM   #45
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
As promised, here's my /etc/X11/xinit/xinitrc file:

Code:
#!/bin/sh
# $XConsortium: xinitrc.cpp,v 1.4 91/08/22 11:41:34 rws Exp $

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/usr/X11R6/lib/X11/xinit/.Xresources
sysmodmap=/usr/X11R6/lib/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
    xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
    xmodmap $usermodmap
fi

# Start the window manager:
xscreensaver -no-splash &
#exec enlightenment
#startkde
startxfce
#exec gnome-session
#exec sawfish
#exec blackbox
#exec fluxbox
#exec /usr/bin/wmaker $NOCPP
#exec fvwm95
It seems like all you have to do get your fluxbox running is add "exec /usr/bin/fluxbox" to your /etc/X11/xinit/xinitrc file. Yours looks really similar to mine just without the call for the window manager at the end. That should get you going. Try it out and let me know.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
installing a new window manager interndan Slackware 6 11-16-2005 01:50 PM
Installing a window manager with yum stevewillis Linux - Software 0 02-16-2005 10:04 PM
Installing slackware with a different window manager rustyz82 Linux - Software 11 05-17-2004 04:44 PM
installing and changing to a new window manager hamish Linux - Newbie 2 02-05-2004 05:22 PM
Installing a new window manager Travis86 Linux - Newbie 4 03-15-2003 09:01 AM


All times are GMT -5. The time now is 08:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration