LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-13-2003, 04:11 AM   #1
Y0jiMb0
Member
 
Registered: Jul 2003
Location: Valencia (Spain)
Distribution: slackware 11, FEDORA CORE 4, RHEL3, Gentoo...
Posts: 361

Rep: Reputation: 30
installing libquicktime: libGL.la not found


Hi!
I'd like to install libquicktime (ver: 0.9.2). I do './configure' -> OK
then I do 'make' and I get an error: it returns 2 and says:
Code:
...
libtool: link: cannot find the library `/usr/X11R6/lib/libGL.la'
make[3]: *** [lqtplay] Error 1
make[3]: Leaving directory `/usr/local/src/libquicktime-0.9.2/utils'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/local/src/libquicktime-0.9.2/utils'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/libquicktime-0.9.2'
make: *** [all] Error 2
when I do 'whereis libGL.la' I get
Code:
libGL: /usr/lib/libGL.so
I soft-linked using:
Code:
ln -s /usr/lib/libGL* /usr/X11R6/lib/
but still the same error. What more can I do?
It must be something stupid but I cannot figure it out; I'm too
Any help is appreciated.
Regards

Last edited by Y0jiMb0; 11-13-2003 at 04:13 AM.
 
Old 11-13-2003, 05:01 AM   #2
cdlen
Member
 
Registered: Oct 2003
Location: EU
Distribution: RH7.2 Mdk9.2
Posts: 39

Rep: Reputation: 15
if you try with :
locate libGL
you'll surely find that you got no libGL.la
libGL.la is provided by the Mesa-devel package.
You could check your packages using :
rpm -qa |grep -i mesa
and
rpm -ql Mesa-devel
(when installed !) to verify the list of files provided
 
Old 11-13-2003, 06:11 AM   #3
Y0jiMb0
Member
 
Registered: Jul 2003
Location: Valencia (Spain)
Distribution: slackware 11, FEDORA CORE 4, RHEL3, Gentoo...
Posts: 361

Original Poster
Rep: Reputation: 30
'locate libGL' gives
Code:
/usr/lib/libGL.so
/usr/lib/libGLcore.so.1.0.4363
/usr/lib/libGL.so.1.0.4363
/usr/lib/libGL.so.1
/usr/lib/libGLcore.so.1
/usr/X11R6/lib/libGLw.a
/usr/X11R6/lib/libGLU.so.1
/usr/X11R6/lib/libGLU.so.1.3.500
/usr/X11R6/lib/libGLU.la
/usr/X11R6/lib/libGLU.so
You're right: I don't have it.
I went to sourceforge to get it, but there are only three packages:
mesademos
mesalib
miscellaneous
I downloaded mesalib and compiled it, but it returns error 2 and says something like (I translate to english)
Code:
/usr/bin/ld: cannot be found -lstdc++
What happens? I already have installed the libstdc++...
Regards
 
Old 11-13-2003, 07:58 AM   #4
cdlen
Member
 
Registered: Oct 2003
Location: EU
Distribution: RH7.2 Mdk9.2
Posts: 39

Rep: Reputation: 15
I meant rpm packages . You can find them for example at http://rpms.mandrakeclub.com/. Mandrake is built on rpm's so it is better at first at least(!) to work with them
Check out there the
NVIDIA_GLX-4363-3mdk.i586.html
libMesaGLU1-devel-5.0-3mdk.i586.html
pages. They've got all you need
The second one provides libGL.la you're missing. But what's funny the libGLU.la you already got. Perhaps i'm missing something here (perhaps you installed things without rpm's)
What do say
rpm -qa |grep -i mesa
and
rpm -qa |grep -i nvidia
?
 
Old 11-13-2003, 10:06 AM   #5
Y0jiMb0
Member
 
Registered: Jul 2003
Location: Valencia (Spain)
Distribution: slackware 11, FEDORA CORE 4, RHEL3, Gentoo...
Posts: 361

Original Poster
Rep: Reputation: 30
Ok thank you for the link
I installed the libmesa-devel package.
Quote:
But what's funny the libGLU.la you already got. Perhaps i'm missing something here (perhaps you installed things without rpm's)
Yes, I use to install (at least lastly) everything, if possible, using sources.
'rpm -qa |grep -i mesa' gives
Code:
Mesa-5.0-3mdk
Mesa-demos-5.0-3mdk
xmms-mesa-1.2.7-18mdk
libMesaGLU1-5.0-3mdk
libMesaglut3-devel-5.0-3mdk
libMesaGL1-5.0-3mdk
libMesaGLU1-devel-5.0-3mdk
libMesaglut3-5.0-3mdk
and 'rpm -qa |grep -i nvidia' gives nothing.

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing libquicktime - libraw1394 Ross Clement Fedora 2 11-29-2005 02:15 PM
Problem installing - libtool: link: cannot find the library `__LIBGL_PATH__/libGL.la' sparX CG Linux - Software 4 11-14-2005 06:45 PM
libGL.so.1(LIBGL) for SuSE 9.1? darkmatter333 SUSE / openSUSE 1 12-17-2004 11:23 PM
libgl.la not found rdoucet Mandriva 10 03-25-2004 08:39 PM
Conficts with XFree86-Mesa-libGL-4.3.0-2 while installing ati driver inward_eye Linux - Software 2 08-24-2003 06:10 PM


All times are GMT -5. The time now is 02:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration