LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-10-2003, 07:20 PM   #1
Stan the caddy
Member
 
Registered: Dec 2003
Location: Victoria, B.C
Distribution: Slackware
Posts: 61

Rep: Reputation: 15
Installing kopete


Hi, i'm new to linux and I just installed Mandrake 9.2 (with KDE 3.1), but cannot seem to install ANY software. I'm currently attempting to install Kopete, but am uncessful with either the rpm or the scource code. When I try to run the rpm it says :

Some package requested cannot be installed:
kopete-0.6.1a-3akc.i586 (due to unsatisfied libcrypto.so.0)
do you agree ?

When I try to install the source I can run the configure fine (I think..), but when I type "make install" I get like a million and two errors. Can someone please HELP!
 
Old 12-10-2003, 07:29 PM   #2
timdsmith
Member
 
Registered: Nov 2003
Location: The Colony, TX
Distribution: Slackware, Debian Etch, FreeBSD, MicroSh*t free.
Posts: 209

Rep: Reputation: 30
before you do make install you have to do:
make
That will build the package and get it ready to install
 
Old 12-10-2003, 07:53 PM   #3
Stan the caddy
Member
 
Registered: Dec 2003
Location: Victoria, B.C
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
Oh yeah, sorry thats where all the errors were. Heres the last little bit:
make[3]: *** [index.cache.bz2] Error 1
make[3]: Leaving directory `/home/jeff/programs/kopete-0.8beta1/doc/kopete'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/jeff/programs/kopete-0.8beta1/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/jeff/programs/kopete-0.8beta1'
make: *** [all] Error 2
[jeff@localhost kopete-0.8beta1]$
 
Old 12-11-2003, 09:02 AM   #4
BrianNJ
Member
 
Registered: Jul 2003
Distribution: Gentoo 2004.0
Posts: 157

Rep: Reputation: 30
sounds like you didn't switch to root user to do the 'make install' command.

you should ./configure and 'make' as a normal user.

my layman's understanding of ./configure is that it reads your system environment and sets system variables for the install you are about to do. 'make' creates the files that will be used in the install. these are all saved in the same directory as the ./configure (which presumably you already have access to). you need to switch to root (type 'su' at the command line) to do the 'make install' becuase to acctually install the program, you will be copying files over into directories (such as /usr ) that only root has permissions to write to.

and p.s. if you don't like kopete, check out gaim.
 
Old 12-11-2003, 03:41 PM   #5
Stan the caddy
Member
 
Registered: Dec 2003
Location: Victoria, B.C
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
That isn't the problem, I've tryed running make both as the root and a normal user and either way i get a huge list of errors. Heres a random piece of it:

index.docbook:361: validity error: No declaration for element keycap
<entry><keycombo action="simul">&Alt;<keycap>Left Arrow</keycap></keycombo></ent
^
index.docbook:361: validity error: No declaration for element keycombo
<entry><keycombo action="simul">&Alt;<keycap>Left Arrow</keycap></keycombo></ent
^
index.docbook:361: validity error: No declaration for element entry
ntry><keycombo action="simul">&Alt;<keycap>Left Arrow</keycap></keycombo></entry
^
index.docbook:362: validity error: No declaration for element entry
<entry>Change to the previous tab.</entry>
^
 
Old 12-23-2003, 02:35 AM   #6
raysr
Member
 
Registered: Nov 2003
Location: WA State
Distribution: Ubuntu 13.04
Posts: 727

Rep: Reputation: 31
Kopete came as an RPM with MDK 9.2, is it complete or is there something else it needs? Is it tied to KMail someway? I've got it set up but I don't think it works. Could not see a contact that I know was online. I tried "Gaim" but couldn't get that to work either. It also is in RPMs. Does it need additional software to work? I downloaded .74 but a file conflicted with the other version. I uninstalled and deleted the file in root but no go.

Last edited by raysr; 12-23-2003 at 02:36 AM.
 
Old 12-24-2003, 08:29 PM   #7
raysr
Member
 
Registered: Nov 2003
Location: WA State
Distribution: Ubuntu 13.04
Posts: 727

Rep: Reputation: 31
Thumbs up

I tried Kopete and Gaim and was unsuccessful with both. Here is the one that worked for me:http://kmess.sourceforge.net/index.p...e=screenshots. Hooked right up to MSN Messenger and imported contacts, ready to go.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing Kopete kopete-0.10.1 on suse 9.2 prestoj8 Linux - Software 3 07-11-2005 03:14 AM
Kopete 0.7.3, Help installing on RH 9 Syst3m_Snip3r Linux - Software 0 11-16-2003 03:40 AM
Help Installing Kopete wh33t Mandriva 1 11-07-2003 02:11 AM
Installing Kopete csosa Linux - Software 0 09-19-2003 09:43 AM
Installing Kopete csosa Linux - Software 3 09-18-2003 08:34 PM


All times are GMT -5. The time now is 04:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration