LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 08-20-2007, 02:10 PM   #1
Kirmonkey
Member
 
Registered: Jan 2004
Location: UK
Distribution: Debian
Posts: 194

Rep: Reputation: 30
Installing kipi-plugins AND digikam


Hi,

I am having a problem installing Kipi-plugins (0.1.2-3)to use with Digikam (0.9.2-4). Using either Synaptic or apt-get to install the plugins requires that digikam is removed. Reversing this process and installing Digikam after the plugins has the same result.

I am currently running Debian Lenny kernel 2.6.21-2-k7 and KDE 3.5.7

This has been a problem for the last 10 days as I hoped it was a transitory problem.

Thanks in advance
 
Old 08-20-2007, 02:16 PM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 62
Quote:
Originally Posted by Kirmonkey View Post
Hi,

I am having a problem installing Kipi-plugins (0.1.2-3)to use with Digikam (0.9.2-4). Using either Synaptic or apt-get to install the plugins requires that digikam is removed. Reversing this process and installing Digikam after the plugins has the same result.

I am currently running Debian Lenny kernel 2.6.21-2-k7 and KDE 3.5.7

This has been a problem for the last 10 days as I hoped it was a transitory problem.

Thanks in advance

You need to get the kipi-plugins package from unstable for both of them to be installed ...

Code:
>$ apt-cache policy kipi-plugins
kipi-plugins:
  Installed: 0.1.4-1+b1
  Candidate: 0.1.4-1+b1
  Version table:
 *** 0.1.4-1+b1 0
        600 http://ftp2.de.debian.org sid/main Packages
        100 /var/lib/dpkg/status
     0.1.2-3 0
        990 http://ftp2.de.debian.org testing/main Packages

>$ apt-cache policy digikam
digikam:
  Installed: 2:0.9.2-4
  Candidate: 2:0.9.2-4
  Version table:
 *** 2:0.9.2-4 0
        990 http://ftp2.de.debian.org testing/main Packages
        600 http://ftp2.de.debian.org sid/main Packages
        100 /var/lib/dpkg/status

HappyTux:/home/stephen# apt-get -s install kipi-plugins/testing
Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version 0.1.2-3 (Debian:testing) for kipi-plugins
Suggested packages:
   gimp (2.2.17-1)
   gallery (1.5.5-pl1-1.1)
Recommended packages:
   sane-utils (1.0.19~cvs20070730-1)
The following packages will be REMOVED:
   digikam (0.9.2-4)
The following packages will be DOWNGRADED:
   kipi-plugins (0.1.4-1+b1 => 0.1.2-3)
0 upgraded, 0 newly installed, 1 downgraded, 1 to remove and 1 not upgraded.
Remv digikam [2:0.9.2-4]
Inst kipi-plugins [0.1.4-1+b1] (0.1.2-3 Debian:testing)
Conf kipi-plugins (0.1.2-3 Debian:testing)
Edit: Which I should add will probably require getting the KDE packages that are in unstable as well that are at version higher than the ones that are in testing.

Last edited by HappyTux; 08-20-2007 at 02:18 PM.
 
Old 08-21-2007, 10:18 PM   #3
dahveed3
Member
 
Registered: Mar 2007
Posts: 191

Rep: Reputation: 31
Yes, I noticed this too. I dealt with just having Digikam for now on Lenny. I'm sure the other stuff will make its way in.

If you're not happy with that and you also have Gnome installed you can use GPhoto2 and F-Spot. Just a nice alternative to hold you over.

I'd rather wait for stuff to trickle down to Lenny than start installing stuff from unstable, but it depends how important immediate availability of that stuff is to you.

Check out rickh's how-to in the Debian forum's how-to section for a pretty safe way to install some stuff from unstable and have aptitude not mix in unnecessary unstable packages. No Apt-Pinning required. But from then on you will have a mixed system and will need to keep both repos active. Aptitude will just pull generally from the one you set as default in apt.conf.
 
Old 08-28-2007, 02:36 PM   #4
Kirmonkey
Member
 
Registered: Jan 2004
Location: UK
Distribution: Debian
Posts: 194

Original Poster
Rep: Reputation: 30
Thanks,

That worked fine!

Did forget to subscribe to the thread though, hence the tardy reply.
 
Old 10-08-2007, 02:51 PM   #5
Kirmonkey
Member
 
Registered: Jan 2004
Location: UK
Distribution: Debian
Posts: 194

Original Poster
Rep: Reputation: 30
Kipi-plugins and Digikam are now co-existing happily in Lenny
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Gwenview Plugins Mark Anderson Ubuntu 2 05-19-2012 03:32 PM
[SOLVED] digiKam Install Problem - Missing Plugins? BeerIsGood Slackware 7 10-12-2006 06:11 AM
sarge dependencies problem - installing digikam divukman Debian 6 11-30-2005 05:36 PM
X problem when installing Digikam SuperRunt Linux - Software 3 06-13-2005 12:43 AM
Installing aMSN plugins Ytsejammer Linux - Software 1 12-26-2004 11:58 AM


All times are GMT -5. The time now is 08:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration