LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Installing kipi-plugins AND digikam (http://www.linuxquestions.org/questions/linux-software-2/installing-kipi-plugins-and-digikam-578481/)

Kirmonkey 08-20-2007 02:10 PM

Installing kipi-plugins AND digikam
 
Hi,

I am having a problem installing Kipi-plugins (0.1.2-3)to use with Digikam (0.9.2-4). Using either Synaptic or apt-get to install the plugins requires that digikam is removed. Reversing this process and installing Digikam after the plugins has the same result.

I am currently running Debian Lenny kernel 2.6.21-2-k7 and KDE 3.5.7

This has been a problem for the last 10 days as I hoped it was a transitory problem.

Thanks in advance

HappyTux 08-20-2007 02:16 PM

Quote:

Originally Posted by Kirmonkey (Post 2864861)
Hi,

I am having a problem installing Kipi-plugins (0.1.2-3)to use with Digikam (0.9.2-4). Using either Synaptic or apt-get to install the plugins requires that digikam is removed. Reversing this process and installing Digikam after the plugins has the same result.

I am currently running Debian Lenny kernel 2.6.21-2-k7 and KDE 3.5.7

This has been a problem for the last 10 days as I hoped it was a transitory problem.

Thanks in advance


You need to get the kipi-plugins package from unstable for both of them to be installed ...

Code:

>$ apt-cache policy kipi-plugins
kipi-plugins:
  Installed: 0.1.4-1+b1
  Candidate: 0.1.4-1+b1
  Version table:
 *** 0.1.4-1+b1 0
        600 http://ftp2.de.debian.org sid/main Packages
        100 /var/lib/dpkg/status
    0.1.2-3 0
        990 http://ftp2.de.debian.org testing/main Packages

>$ apt-cache policy digikam
digikam:
  Installed: 2:0.9.2-4
  Candidate: 2:0.9.2-4
  Version table:
 *** 2:0.9.2-4 0
        990 http://ftp2.de.debian.org testing/main Packages
        600 http://ftp2.de.debian.org sid/main Packages
        100 /var/lib/dpkg/status

HappyTux:/home/stephen# apt-get -s install kipi-plugins/testing
Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version 0.1.2-3 (Debian:testing) for kipi-plugins
Suggested packages:
  gimp (2.2.17-1)
  gallery (1.5.5-pl1-1.1)
Recommended packages:
  sane-utils (1.0.19~cvs20070730-1)
The following packages will be REMOVED:
  digikam (0.9.2-4)
The following packages will be DOWNGRADED:
  kipi-plugins (0.1.4-1+b1 => 0.1.2-3)
0 upgraded, 0 newly installed, 1 downgraded, 1 to remove and 1 not upgraded.
Remv digikam [2:0.9.2-4]
Inst kipi-plugins [0.1.4-1+b1] (0.1.2-3 Debian:testing)
Conf kipi-plugins (0.1.2-3 Debian:testing)

Edit: Which I should add will probably require getting the KDE packages that are in unstable as well that are at version higher than the ones that are in testing.

dahveed3 08-21-2007 10:18 PM

Yes, I noticed this too. I dealt with just having Digikam for now on Lenny. I'm sure the other stuff will make its way in.

If you're not happy with that and you also have Gnome installed you can use GPhoto2 and F-Spot. Just a nice alternative to hold you over.

I'd rather wait for stuff to trickle down to Lenny than start installing stuff from unstable, but it depends how important immediate availability of that stuff is to you.

Check out rickh's how-to in the Debian forum's how-to section for a pretty safe way to install some stuff from unstable and have aptitude not mix in unnecessary unstable packages. No Apt-Pinning required. But from then on you will have a mixed system and will need to keep both repos active. Aptitude will just pull generally from the one you set as default in apt.conf.

Kirmonkey 08-28-2007 02:36 PM

Thanks,

That worked fine!

Did forget to subscribe to the thread though, hence the tardy reply.

Kirmonkey 10-08-2007 02:51 PM

Kipi-plugins and Digikam are now co-existing happily in Lenny


All times are GMT -5. The time now is 04:56 AM.