Linux - SoftwareThis forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.
Welcome to LinuxQuestions.org, a friendly and active Linux Community.
You are currently viewing LQ as a guest. By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features. Registration is quick, simple and absolutely free. Join our community today!
Note that registered members see fewer ads, and ContentLink is completely disabled once you log in.
So, getting on a bit it with my Linux experience...
Time to install GFTP.
./configure brings up an error saying it needs GTK+ 2, otherwise it can only do commandline.
So I go to install GTK... anyways, long story short it seems I needed to install GLIB, Pango and ATK as well. I did those, all the same way:
they went without a hitch.
So I go back to do GTK, but I get an error at the end of configure:
configure: error: Library requirements (glib-2.0 >=2.6.0 atk >=1.0.1 pango >=1.8.0 not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
you've not filled in your profile, and not provided as much information in your post, so i don't know what distro you are on, but i'd assume that you're on mandrake, suse or another RPM based distro. assuming this, i'd bet money that GTK is already installed just fine, what is not installed however will be the matching gtk-devel package that is required to actually compile source code that uses that library. this is the same for a good proportional of rpm based libraries and programs. if you install GTK from source then you run the risk of breaking your system, as you can end up with two versions of GTK in different locations on your system, which will hit trouble eventually.
so for things like GTK, i's strongly advise you stick with RPM's even if you wish to compile other apps from source.
Knoppix is debian-based. But you have to install those packages or possibly the dev packages as I don't know what's installed by default in knoppix.
You can use apt to install those packages named above. Run "apt-get update" to update your packages list with the newest packages on the server. Then you can "apt-get install packagename" which will install the package.
I thought I would re-do it all as you have written so...
That went OK.
at the end of that it said:
'pkg-config --modversion glib-2.0' returned 2.6.0 but GLIB 2.6.2 was found! If pkg-config was correct, then it is best to remove the old version of glib. You may also fix the error by modifying your LD_LIBRARY_PATH environment variable, or by editing /etc/ld.so.conf. Make sure you have run ldconfig if that is required by your system. If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH to point to the correct configuration files
Glib 2.5.7 or better is required. The Latest version of Glib is always available from ftp://ftp.gtk.org/.
good advice, but that won't help him here with the --prefix=/usr option. If you install a library, you have to remove the old one first. pretty much all distro's come with glib-2.x ( but rpm/deb distro's split them).
Make sure you remove the original package first then go back to the glib source directory and redo make install ( you really should make a package of it for easier removal/upgrade later on).