LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-18-2003, 10:20 PM   #1
hyperriven
Member
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 61

Rep: Reputation: 15
Installing Gaim 0.71


I am trying to install Gaim 0.71 but I get this error:

checking for GLIB - version >= 2.0.0... no
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at (the gtk web-page)

I have installed newer versions of GLIB, uninstalled and reinstalled GLIB, but the error message doesn't go away. I am new to Linux and have no idea what to do next. Any ideas? Please give specific instructions.

Thanks,
Tom
 
Old 10-19-2003, 01:03 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Try running ldconfig to update your lib database.

If that doesn't work, make sure that its in your path.
 
Old 10-19-2003, 05:34 AM   #3
Cimmerian
Member
 
Registered: Sep 2003
Location: Trondheim, Norway
Distribution: Slackware10 + Dropline Gnome
Posts: 47

Rep: Reputation: 15
Isn't it typical for rpm distros to have devel rpm's if you want to compile against libraries? Like glib-devel-2.x.x**.rpm or glib2-devel....
 
Old 10-19-2003, 11:21 AM   #4
hyperriven
Member
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 61

Original Poster
Rep: Reputation: 15
I have ran ldconfig, and it didn't seem to help. The files all seem to be in the right path also. By the way I have Mandrake 9.1, so I don't know what to do with rpm's.

Last edited by hyperriven; 10-19-2003 at 11:22 AM.
 
Old 10-19-2003, 04:51 PM   #5
Cimmerian
Member
 
Registered: Sep 2003
Location: Trondheim, Norway
Distribution: Slackware10 + Dropline Gnome
Posts: 47

Rep: Reputation: 15
I haven't used mdk in a long time, but if I'm not mistaken, there was some app that let me search for packages on the disks and even online. Rpmdrake? Some mdk package manager anyways. I would believe glib2-devel can be found there. You need stuff like devel-headers to compile, and they are not always installed by default, as you don't need them to simply run the distro. I assume when you say you install/reinstall glib and newer versions, that you only install the glib(2) rpm?
 
Old 10-24-2003, 09:24 PM   #6
hyperriven
Member
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 61

Original Poster
Rep: Reputation: 15
When I say I install and reinstall glib I mean I unzip(or whatever you call it in Linux) glib-2.2.3.tar.gz and then change to the glib-2.2.3 directory and do
./configure
make
make install

If I am not root I get this error:

checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/.
 
Old 10-24-2003, 10:03 PM   #7
hyperriven
Member
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 61

Original Poster
Rep: Reputation: 15
I found out that there was a gaim rpm package for Mandrake 9.1(and how to install it(I'm still a new to Linux)) and now I have Gaim .71 installed and running on my computer!!! I still don't understand why I couldn't install it using the gaim-0.71.tar.gz file they had on the website. Isn't that supposed to work for all Linux distributions? What if I want to install something that requires glib and there are no Mandrake rpm file for it?
 
Old 10-24-2003, 10:06 PM   #8
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Quote:
Originally posted by hyperriven
I found out that there was a gaim rpm package for Mandrake 9.1(and how to install it(I'm still a new to Linux)) and now I have Gaim .71 installed and running on my computer!!! I still don't understand why I couldn't install it using the gaim-0.71.tar.gz file they had on the website. Isn't that supposed to work for all Linux distributions? What if I want to install something that requires glib and there are no Mandrake rpm file for it?
Welcome to the world of Linux. My advice: if there's an RPM file, grab it! Avoid *.tar files cause you run into problems like what you did. Others will disagree with me, but you're a newb, I'm a newb, and we just want it to work - simple, fast, and easy! RPM's Rules!!

By the way, if it ever says you need some kind of file, go to your Mandrake Control Center. Then go to Softwares and click on Add RPM and search for whatever it is missing. It may already be on the Mandrake 3 CD's.
 
Old 10-24-2003, 10:11 PM   #9
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
As that message from your attempt to isntall glib shows, you already have glib installed. The problem is that the configure script can't find it. Usually, what needs to be done is some edting of some config files or passing some parameters to the configure scripts. As Micro420 says, it's much more painless to use an rpm if there is one
 
Old 10-25-2003, 03:15 AM   #10
uglydot
Member
 
Registered: Mar 2003
Distribution: Gentoo
Posts: 232

Rep: Reputation: 30
I have compiled this version of GAIM under slackware 9.1. When I load it up, it says that it cannot load the MSN plugin. The program works fine, but this is kind of annoying, I do I get rid of the error.
 
Old 10-25-2003, 05:33 AM   #11
Jefklak
LQ Newbie
 
Registered: Oct 2003
Distribution: Currently Fedora B3, Will try Gentoo 1.4
Posts: 26

Rep: Reputation: 15
Ugly, try starting another thread about your problem, you'll get more answers that way. I honestly don't know, donwload a plugin or recompile and try again?
 
Old 10-25-2003, 05:49 AM   #12
Pecunia
LQ Newbie
 
Registered: May 2003
Location: The Netherlands
Distribution: LFS
Posts: 28

Rep: Reputation: 15
Uglydot, the Gaim FAQ has the answer: you need SSL to load the MSN plugin, either GnuTLS or the combination of NSS and NSPR from the Mozilla project.
I haven't found out yet how to completely disable the MSN plugin since I don't need it ...
 
Old 10-25-2003, 09:31 AM   #13
namespace
LQ Newbie
 
Registered: Oct 2003
Location: China
Distribution: LFS
Posts: 21

Rep: Reputation: 15
Quote:
checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
As the cript said you should uninstall your old glib2(2.2.1) first before you install the new one(2.2.3)...In my opinion,if you have time,compiling the source code is the best way in Linux ,as it's fast speed and transparent to you.
 
Old 10-25-2003, 10:14 AM   #14
Jefklak
LQ Newbie
 
Registered: Oct 2003
Distribution: Currently Fedora B3, Will try Gentoo 1.4
Posts: 26

Rep: Reputation: 15
Especially if you're using Gentoo
 
Old 10-25-2003, 12:12 PM   #15
hyperriven
Member
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 61

Original Poster
Rep: Reputation: 15
How do you uninstall glib2(2.2.1). I looked in RPMDrake, but I only saw glibc-devel-2.3.1-10mdk.

And if I were to compile the source code, how would I do that? I am new to linux. Complete instructions would be great!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing GAIM vital_101 Mandriva 3 10-22-2005 07:27 AM
Installing GAIM vwal_13 Slackware 3 04-19-2004 08:53 AM
Problem Installing/Upgrading Gaim 0.60 or Gaim 0.71 AskMe Linux - Newbie 1 10-25-2003 09:00 PM
Installing Gaim Niellus Linux - Newbie 8 08-05-2003 05:42 PM
Installing Gaim rgarg Linux - Software 3 07-02-2003 05:44 AM


All times are GMT -5. The time now is 12:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration