LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-23-2003, 05:46 PM   #1
stodgel
LQ Newbie
 
Registered: May 2003
Posts: 27

Rep: Reputation: 15
Question Installing Evolution


I am trying to install Evolution 1.4. I went to the Ximian web site and it said to run this as root in the command line:
"wget -q -O - http://go.ximian.com |sh"
When I do that I get this:

==> Autodetecting system type...
==> Checking $DISPLAY and X permissions...

The Ximian Desktop Installer is a graphical application, and
either you have no DISPLAY variable set or the root user does not
have permission to access your X server. Run 'xhost +localhost'
before becoming root, and make sure that the DISPLAY variable is
set correctly before running the go-ximian script.

Cleaning up temporary files... done.

This is supposed to download and install Evolution 1.4. I should have known it just couldn't be that easy.
I am running SuSE 8.2. Does anyone know what this means and if I will be able to install this?
 
Old 06-23-2003, 06:23 PM   #2
contrasutra
LQ Guru
 
Registered: Mar 2003
Location: New Jersey
Distribution: Arch Linux
Posts: 1,445

Rep: Reputation: 46
Have you ran "xhost +localhost" before becoming root? If you do that and it still doesnt work, report back.
 
Old 06-23-2003, 07:04 PM   #3
stodgel
LQ Newbie
 
Registered: May 2003
Posts: 27

Original Poster
Rep: Reputation: 15
I actually did do that before but it didn't seem to do anything. However I did go back and try to run thr download/installation again, and it worked perfectly.
When xhost+localhost is run before becoming root, what exactly does that do? I don't quite understand this.
 
Old 07-07-2003, 03:00 AM   #4
VoyagerDL
Member
 
Registered: Nov 2002
Distribution: RedHat 9, SuSe 8.2
Posts: 33

Rep: Reputation: 15
I know this seems taboo but I log in as root (GUI) and run from a terminal window and things work just fine.

I haven't figured out yet how to change the permissions to allow root to run this program from a terminial without being root.

Post back and let me know if you find 1.4 slow compared to 1.2
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Evolution and missing packages OmnipotentOscar Linux - Newbie 7 01-22-2005 01:22 PM
[help] problem installing evolution brain79 Slackware 8 05-20-2004 08:56 PM
Installing Evolution on suse 9.0 Vago Linux - Software 0 02-24-2004 12:32 PM
Installing Ximian Evolution jeramy Slackware 32 11-24-2003 12:31 PM
trouble installing evolution stevenhasty Slackware 5 07-25-2003 12:17 AM


All times are GMT -5. The time now is 06:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration