LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-15-2003, 08:51 AM   #1
Fermat
LQ Newbie
 
Registered: Mar 2003
Location: North East of England
Distribution: Fedora (FC5)
Posts: 13

Rep: Reputation: 0
Installing DevHelp


Can anyone help me with this error?
I've been trying to install devhelp for Anjuta. I cd'd to the source directory
and typed in ./configure. Lots of messages get printed to the screen then I get
this error:

Checking for pkg-config.
Could not run GLIB program.
GLIB may not be correctly installed.
Package gtk+-2.0 not found.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable.

First, my PKG_CONFIG_PATH was empty. I don't have any file called
'gtk+-2.0.pc', but I do have one called 'gtk+.pc' in 'usr/lib/pkgconfig/'. I set
PKG_CONFIG_PATH="usr/lib/pkgconfig" and renamed 'gtk+.pc' to 'gtk+-2.0.pc', but
it still gave the same error. I checked to see if I had the gtk+ package and
found that "The package 'gtk+2.-2.0.6-8mdk' is installed".

How can I get past this error?
 
Old 03-15-2003, 09:17 AM   #2
niknah
Member
 
Registered: Dec 2002
Location: In front of a computer
Distribution: UPS, DHL, FedEx
Posts: 466

Rep: Reputation: 38
look at your config.log and check for the bit where it trys to run the glib program. It looks like it gets past pkg-config and trys to compile & run a glib program which doesn't work for whatever reason.
 
Old 03-15-2003, 12:25 PM   #3
Fermat
LQ Newbie
 
Registered: Mar 2003
Location: North East of England
Distribution: Fedora (FC5)
Posts: 13

Original Poster
Rep: Reputation: 0
CONFIG.LOG extract

I think this is the relevent part of config.log.
There is a check for 'GLIB - version >= 2.0.0' with 'result: no'. So I checked my packages and found I had 'glibc-devel-2.2.5-16mdk'. Does that mean that my glib version is 2.2.5? If so, then why did I get a fail result? Am I short of a path to the glib library? Any other comments? I'm not too sure how to use this config.log info.

configure:7672: checking for pkg-config
configure:7690: found /usr/local/bin/pkg-config
configure:7703: result: /usr/local/bin/pkg-config
configure:7726: checking for GLIB - version >= 2.0.0
configure:7876: result: no
configure:7910: gcc -o conftest -g -O2 conftest.c >&5
configure:7912:18: glib.h: No such file or directory
configure: In function `main':
configure:7918: `glib_major_version' undeclared (first use in this function)
configure:7918: (Each undeclared identifier is reported only once
configure:7918: for each function it appears in.)
configure:7918: `glib_minor_version' undeclared (first use in this function)
configure:7918: `glib_micro_version' undeclared (first use in this function)
configure:7913: $? = 1
configure: failed program was:
| #line 7890 "configure"
| /* confdefs.h. */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE "devhelp"
| #define VERSION "0.5.0"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| /* end confdefs.h. */
|
| #include <glib.h>
| #include <stdio.h>
|
| int
| main ()
| {
| return ((glib_major_version) || (glib_minor_version) || (glib_micro_version));
| ;
| return 0;
| }
configure:8027: checking for
gtk+-2.0 >= 2.2.0
configure:8072: error: Library requirements (
gtk+-2.0 >= 2.2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
 
Old 03-15-2003, 12:31 PM   #4
niknah
Member
 
Registered: Dec 2002
Location: In front of a computer
Distribution: UPS, DHL, FedEx
Posts: 466

Rep: Reputation: 38
"glib" is different from "glibc"

look for glib-devel
 
Old 03-15-2003, 02:16 PM   #5
Fermat
LQ Newbie
 
Registered: Mar 2003
Location: North East of England
Distribution: Fedora (FC5)
Posts: 13

Original Poster
Rep: Reputation: 0
>>"glib" is different from "glibc"
Is that why it's not working?

The 'glib' packages I have installed are;
glibc-devel-2.2.5-16mdk
glibc-i18ndata-2.2.5-16mdk
libglib1.2-devel-1.2.10-16mdk

The packages I can install are;
glib-gettextize-2.0.6-2mdk
glibc-doc-2.2.5-16mdk
glibc-doc-pdf-2.2.5-16mdk
glibc-static-devel-2.2.5-16mdk
glibc-utils-2.2.5-16mdk
libglib2.0_0-devel-2.0.6-2mdk
libglibwww1-0.2-3mdk
libglibwww1-devel-0.2-3mdk

I don't have any glib-devel packages though. What do I install?

Ive just downloaded 'glib-1.2.10-8.src.rpm'. Should I install that? What switches/options should I use?

Last edited by Fermat; 03-15-2003 at 02:40 PM.
 
Old 03-15-2003, 02:53 PM   #6
niknah
Member
 
Registered: Dec 2002
Location: In front of a computer
Distribution: UPS, DHL, FedEx
Posts: 466

Rep: Reputation: 38
it's checking for...
configure:7726: checking for GLIB - version >= 2.0.0

so install these 2...

glib-gettextize-2.0.6-2mdk
libglib2.0_0-devel-2.0.6-2mdk
 
Old 03-15-2003, 04:31 PM   #7
Fermat
LQ Newbie
 
Registered: Mar 2003
Location: North East of England
Distribution: Fedora (FC5)
Posts: 13

Original Poster
Rep: Reputation: 0
I installed them both. libglib2.0***** needed 'pkgconfig-0.12.0-2mdk' as a dependency and had to be installed first. However, after installing the packages, plus dependency, I ran ./configure again, but I got the exact same error messages at the exact same point!
Should I install something else? I don't need to reboot do I?
 
Old 03-15-2003, 04:44 PM   #8
niknah
Member
 
Registered: Dec 2002
Location: In front of a computer
Distribution: UPS, DHL, FedEx
Posts: 466

Rep: Reputation: 38
if in your config.log, if you see that it can't find glib.h again, search for glib.h, rpm -q -l libglib2.0-devel
./configure --help may give you some options to tell it where to look for glib include files and set it to where you found the glib.h or there may even be a --disable-glib-test option.

basically you got to be able to compile a simple glib program to get rid of the message.
 
Old 03-15-2003, 06:03 PM   #9
Fermat
LQ Newbie
 
Registered: Mar 2003
Location: North East of England
Distribution: Fedora (FC5)
Posts: 13

Original Poster
Rep: Reputation: 0
Sorry, I missed off a bit in my earlier post - glib compiled, thanks - I simply didn't notice it - but I was still getting gtk+ error messages. Here is the same part of config.log.

configure:7672: checking for pkg-config
configure:7690: found /usr/bin/pkg-config
configure:7703: result: /usr/bin/pkg-config
configure:7726: checking for GLIB - version >= 2.0.0
configure:7846: gcc -o conftest -g -O2 -I/usr/include/glib-2.0 -I/usr/lib/glib-
2.0/include conftest.c -lglib-2.0 >&5
configure:7849: $? = 0
configure:7851: ./conftest
configure:7854: $? = 0
configure:7872: result: yes (version 2.0.6)
configure:8027: checking for gtk+-2.0 >= 2.2.0
configure:8072: error: Library requirements (gtk+-2.0 >= 2.2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

Now the configure script is lookling for a file called gtk+-2.0.pc (see my first post). But I don't have that file. I have gtk+.pc only. I renamed gtk+.pc to gtk+-2.0.pc and set PKG_CONFIG_PATH to point to it, but still the same error (can't find gtk+-2.0 package) came up.

Last edited by Fermat; 03-15-2003 at 06:04 PM.
 
Old 03-16-2003, 09:05 AM   #10
niknah
Member
 
Registered: Dec 2002
Location: In front of a computer
Distribution: UPS, DHL, FedEx
Posts: 466

Rep: Reputation: 38
look for a package similar to... gtk+2-devel.-2.0.6-8mdk

don't rename gtk+.pc, that's the pkgconfig for gtk1 I think.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GTK+ DevHelp crashes on SuSE Lniux paulsm4 Linux - Software 1 04-11-2005 12:26 PM
Installing Mono-got stuck while installing gtk-sharp chutsu Linux - Software 11 01-18-2005 09:25 PM
installing from iso9660 - restarts installation without installing anything scuzzman Slackware 1 10-24-2004 08:46 PM
devhelp : configuration abrb220 Programming 0 06-01-2004 09:00 AM
Installing Windows XP after installing Red Hat 9 BluePyre Linux - General 7 03-09-2004 04:37 PM


All times are GMT -5. The time now is 09:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration