LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Installing Conky -- strange lua problem? (http://www.linuxquestions.org/questions/linux-software-2/installing-conky-strange-lua-problem-832346/)

benav 09-15-2010 11:16 AM

Installing Conky -- strange lua problem?
 
Hi all,

I'm trying to install Conky, but when I run the configure script I get this:

Code:

...
checking for LUA51... no
checking for LUA51... configure: error: Package requirements (lua5.1 >= 5.1) were not met:

No package 'lua5.1' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LUA51_CFLAGS
and LUA51_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

However, I do have Lua 5.1 installed. 5.1.4-10.4, to be precise. I've even tried
Code:

export PKG_CONFIG_PATH=/usr/bin
, which contains the file lua5.1 but I get the same error message.

If I were to set LUA51_CFLAGS and LUA51_LIBS, what would I set them to?

Running KDE 4.4.4 "release 2" on OpenSUSE 11.3 (x86_64), Linux 2.6.34-12-desktop x86_64.

If anyone has any suggestions for what else to try, I'd appreciate it.

Thanks!

lostzinzthought 09-15-2010 11:41 AM

I had a similar problem trying to install the newest version of conky on slackware 13.1 on my acer aspire one D260.
I just grabbed an older version off sourceforge and it works fine, though I don't know why it couldn't find the lua dependency - I had it installed.
sorry I couldn't be of much help.

benav 09-15-2010 04:33 PM

Actually, that was helpful. I got an older version to install just fine. Thanks!

lostzinzthought 09-15-2010 04:51 PM

Quote:

Originally Posted by benav (Post 4098688)
Actually, that was helpful. I got an older version to install just fine. Thanks!

Oh, you're welcome then :D happy I could help!

Daedra 09-16-2010 04:10 AM

Quote:

Originally Posted by lostzinzthought (Post 4098417)
I had a similar problem trying to install the newest version of conky on slackware 13.1 on my acer aspire one D260.
I just grabbed an older version off sourceforge and it works fine, though I don't know why it couldn't find the lua dependency - I had it installed.
sorry I couldn't be of much help.

I maintain conky over at slackbuilds and I have conky running with lua support right now. try following the instructions of my README at http://slackbuilds.org/repository/13.1/system/conky/ and everything should work.

lostzinzthought 09-16-2010 07:37 AM

Quote:

Originally Posted by Daedra (Post 4099190)
I maintain conky over at slackbuilds and I have conky running with lua support right now. try following the instructions of my README at http://slackbuilds.org/repository/13.1/system/conky/ and everything should work.

to be honest, I didn't even look for a slackbuild, I just grabbed the source. next time I try to install it i'll check the slackbuild though, haha.

i92guboj 09-16-2010 08:16 AM

To compile the package you will probably need some lua-devel, lua-dev, lua-libs or something like that. I am not a SuSE user so can't be sure.

No wonder that older conky versions work, since the lua features are relatively new. Older conky versions do not have lua scripting support so they don't require lua for anything.

zrdc28 09-24-2010 06:47 AM

This is what works for me, if you read the slackbuild you will find this.

To enable lua scripting engine support run the build with
LUA=yes ./conky.SlackBuild.

I just changed the second line to

LUA=no ./conky.SlackBuild.

gaby 09-27-2011 12:06 PM

I tried installing the latest version on a centos 5.7 and had the same problem related to lua.
I just installed lua-devel and it worked fine


All times are GMT -5. The time now is 01:39 PM.