LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-24-2012, 12:21 AM   #1
aquasimjunior
LQ Newbie
 
Registered: Jul 2012
Posts: 4

Rep: Reputation: Disabled
Installing Aquasim in Ubuntu 10.10: Error in installation. Please help


Hi, i'm have a problem to install aquasim in ubuntu 10.10. currently i'm trying to install ns-2.30 allinone package. But i get this error:


Pending10taskStatusEh' of wpan/p802_15_4mac.o
collect2: ld returned 1 exit status
make: *** [ns] Error 1
Ns make failed!
See http://www.isi.edu/nsnam/ns/ns-problems.html for problems

Can you help me to fix it. Thank in advance
 
Old 07-24-2012, 04:52 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,262

Rep: Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660
Welcome to LQ.

Installing Aquasim, post #8 here ..
http://www.linuxquestions.org/questi...asim-855532/#8

Ubuntu 10.10 :
cd ns-allinone-2.30/ && export CC=gcc-4.1 CXX=g++-4.1 && ./install

Or with "gcc41-compat" : export CC=gcc41 CXX=g++41 && ./install
32bits gcc41-compat, g++41-compat : post #181 here ..
http://www.linuxquestions.org/questi...68/page13.html

.
 
1 members found this post helpful.
Old 07-24-2012, 09:50 PM   #3
aquasimjunior
LQ Newbie
 
Registered: Jul 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
Re: Installing Aquasim in Ubuntu 10.10: Error in installation

Thank you for your support.. It's work fine now..
 
Old 07-24-2012, 11:48 PM   #4
aquasimjunior
LQ Newbie
 
Registered: Jul 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
Re: Installing Aquasim in Ubuntu 10.10: Error in installation

I have another question, when i running example tcl file the network animator does not appear and when i type nam at command prompt, it will display this error

nam:
[code omitted because of length]
: no event type or button # or keysym
while executing
"bind Listbox <MouseWheel> {
%W yview scroll [expr {- (%D / 120) * 4}] units
}"
invoked from within
"if {[tk windowingsystem] eq "classic" || [tk windowingsystem] eq "aqua"} {
bind Listbox <MouseWheel> {
%W yview scroll [expr {- (%D)}] units
}
bind Li..."
dr-hafiz@ubuntu:~/aqua-sim/ns-allinone-2.30/ns-2.30/underwatersensor/uw_tcl$ nam
nam:
[code omitted because of length]
: no event type or button # or keysym
while executing
"bind Listbox <MouseWheel> {
%W yview scroll [expr {- (%D / 120) * 4}] units
}"
invoked from within
"if {[tk windowingsystem] eq "classic" || [tk windowingsystem] eq "aqua"} {
bind Listbox <MouseWheel> {
%W yview scroll [expr {- (%D)}] units
}
bind Li..."


Can you help me?
 
Old 07-25-2012, 04:32 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,262

Rep: Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660Reputation: 2660
Nam is a separate application. Any nam can be used.

Fixing nam : cd ns-allinone-2.30/tk8* &&
wget ftp://ftp.swin.edu.au/gentoo-portage...astevent.patch
&& patch -p0 < tk-8.4-lastevent.patch
Now you can run install again. (Recompile tk8* and nam-*)

Easier : Use a binary nam. Post # 4 here :
http://www.linuxquestions.org/questi...04-a-842109/#4
Unpack nam-1.14.<arch>.tar.gz, and copy 'nam' to /usr/local/bin/
... Then you have nam in a system PATH.
And : Version 1.14 is 1) Probably the best version.
2) nam-1.14 has no ns2 related dependencies : Is partly statically compiled.

.
 
  


Reply

Tags
aquasim, lastevent, nam-bin, ns2


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless ns/aquasim varshitha Linux - Wireless Networking 158 10-05-2014 07:56 AM
NS2 and Aquasim Preeti1910 Linux - Software 47 04-12-2014 04:29 AM
aquasim question MonaJalili Linux - Wireless Networking 6 05-12-2013 07:59 AM
Error in installing Lidia -2.3.0 in Ubuntu 11.04. show error in precondition_error.cc Anamika Paul Linux - Software 9 05-23-2012 06:24 AM
aquasim varshitha Linux - Wireless Networking 0 01-29-2011 10:42 AM


All times are GMT -5. The time now is 10:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration