LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-17-2008, 07:22 AM   #1
saurabhgupta1403
LQ Newbie
 
Registered: Jan 2008
Posts: 28

Rep: Reputation: 15
Installing a particular version of a package


Hello all,

In one of my application, I got the message:
**************************
NOTE: preferred version 7.16.4 of curl-native not available (for item curl-native)
NOTE: preferred version 2.6.1 of glibc not available (for item virtual/arm-angstrom-linux-gnueabi-libc-for-gcc)
NOTE: preferred version 7.16.4 of curl not available (for item curl)
NOTE: preferred version 0.16.999.041 of e-wm not available (for item e-wm)
NOTE: preferred version 7.16.4 of curl not available (for item curl)
NOTE: preferred version 7.16.4 of curl not available (for item curl-certs)
NOTE: preferred version 1.0.3 of libx11-native not available (for item virtual/libx11)
NOTE: preferred version 0.16.999.041 of e-wm not available (for item e-wm)
NOTE: preferred version 1.0.2 of kbproto-native not available (for item kbproto-native)
NOTE: preferred version 1.4.1 of inputproto-native not available (for item inputproto-native)
****************************

Now, i want to remove these warnings by installing the required version of the packages. But i am unable to get it. Like I have version 7.18.0 of curl but I need 7.16.4. I tried the command: sudo apt-get install curl-7.16.4, but it fails to get the package. Can someone tell me how to install these required packages.

Thanks in advance...
 
Old 09-17-2008, 07:51 AM   #2
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Rep: Reputation: Disabled
Synaptic installs curl from repos. You should be trying apt-get install curl. If this is not the version you need, best way is to get the source and compile it.
 
Old 09-18-2008, 04:17 AM   #3
saurabhgupta1403
LQ Newbie
 
Registered: Jan 2008
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by linuxlover.chaitanya View Post
Synaptic installs curl from repos. You should be trying apt-get install curl. If this is not the version you need, best way is to get the source and compile it.
Isn;t there any other method to get the previous version of curl installed in my ubuntu by some utitily.
 
Old 09-18-2008, 05:14 AM   #4
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Rep: Reputation: Disabled
You can either compile it from source or get it from synaptic. What other way do you need? You can get a .deb package but this still leaves you with dependency issues.
You can get zipped tar ball from launchpad.net for your version of Ubuntu that you failed to mention.
 
Old 09-18-2008, 05:18 AM   #5
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Synaptic and apt-get are two different interfaces to the same utility (more or less package management). The package manager installs software from the given reposity/reposities, and they usually hold only one (newest one put there) version of each package; however if an older package is present, apt-get should be able to downgrade to it (remove newer and install older package). At least that's what the man page claims:
Code:
man apt-get
Quote:
---
install
install is followed by one or more packages desired for installation. Each package is a package name, not a fully qualified filename (for instance, in a Debian GNU/Linux system, libc6 would be the argument provided, not libc6_1.9.6-2.deb). All packages required by the package(s) specified for installation will also be retrieved and installed. The /etc/apt/sources.list file is used to locate the desired packages. If a hyphen is appended to the package name (with no intervening space), the identified package will be removed if it is installed. Similarly a plus sign can be used to designate a package to install. These latter features may be used to override decisions made by apt-get's conflict resolution system.

A specific version of a package can be selected for installation by following the package name with an equals and the version of the package to select. This will cause that version to be located and selected for install. Alternatively a specific distribution can be selected by following the package name with a slash and the version of the distribution or the Archive name (stable, testing, unstable).

Both of the version selection mechanisms can downgrade packages and must be used with care.

Finally, the apt_preferences(5) mechanism allows you to create an alternative installation policy for individual packages.

If no package matches the given expression and the expression contains one of '.', '?' or '*' then it is assumed to be a POSIX regular expression, and it is applied to all package names in the database. Any matches are then installed (or removed). Note that matching is done by substring so 'lo.*' matches 'how-lo' and 'lowest'. If this is undesired, anchor the regular expression with a '^' or '$' character, or create a more specific regular expression.
The thing is then to find the package version you need -- of course it is possible that it is in the reposity, but because packages consume disk space and most people don't often need old packages, the reposities might not contain anything but the newest packages. Some sites on the internet, on the other hand, may well contain the package version you need. You may also use dpkg to manually install packages; there's also the graphical gdebi tool that does the same job when you double-click on a .deb file.

Note that the messages you got were *notes*, nothing serious. A "preferred" package version is not the same as "needed" -- newer ones should well do. If I were you, I wouldn't downgrade packages unless you have some serious trouble with the newer ones (because downgrading might also mean regaining bugs, security holes and whatnot).
 
Old 09-19-2008, 07:31 AM   #6
saurabhgupta1403
LQ Newbie
 
Registered: Jan 2008
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by b0uncer View Post
Synaptic and apt-get are two different interfaces to the same utility (more or less package management). The package manager installs software from the given reposity/reposities, and they usually hold only one (newest one put there) version of each package; however if an older package is present, apt-get should be able to downgrade to it (remove newer and install older package). At least that's what the man page claims:
Code:
man apt-get

Note that the messages you got were *notes*, nothing serious. A "preferred" package version is not the same as "needed" -- newer ones should well do. If I were you, I wouldn't downgrade packages unless you have some serious trouble with the newer ones (because downgrading might also mean regaining bugs, security holes and whatnot).
I think that you are right. This is the preferred version and not the needed one. Still, I am getting error in building a package which depends on the above said packages. I am not getting if it is due to the version mismatching or due to some other reason.
 
Old 09-20-2008, 12:15 AM   #7
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Rep: Reputation: Disabled
By the way, what is the application that is giving you the problems? If that application is available through synaptic, then you should give re-installation a try but through apt. This will install and manage the package and all the dependencies.
 
Old 09-21-2008, 05:43 AM   #8
saurabhgupta1403
LQ Newbie
 
Registered: Jan 2008
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by linuxlover.chaitanya View Post
By the way, what is the application that is giving you the problems? If that application is available through synaptic, then you should give re-installation a try but through apt. This will install and manage the package and all the dependencies.
The application is not available through synaptic. This is a distribution for working on the openmoko platform.
 
  


Reply

Tags
install, package, versions


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Verify Package Version in APT (Before Installing) carlosinfl Debian 3 12-17-2007 07:43 PM
Package version twk Linux - Security 2 11-11-2005 09:00 AM
installing an unstable package from debian's online package archive ganninu Debian 13 11-07-2003 03:00 PM
Package Version erva Linux - Newbie 1 09-28-2003 11:10 PM


All times are GMT -5. The time now is 03:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration