LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Installed VLC have sound but no visuals (http://www.linuxquestions.org/questions/linux-software-2/installed-vlc-have-sound-but-no-visuals-4175427721/)

Ztcoracat 09-17-2012 06:04 PM

Installed VLC have sound but no visuals
 
Hi:

I used the software center to install VLC Media Player today.
After re-booting VLC had sound but the screen was black.

Before posting I went to this Debian website to help myself.
http://forums.debian.net/viewtopic.php?f=6&t=81302

I followed the instructions and used the commands in the terminal.

For some reason I still do not have visuals; the screen is black and I only have sound.

Here's what I tried in the terminal:
Code:

ffmpeg:
  Installed: (none)
  Candidate: 5:0.7.13-dmo2
  Version table:
    6:0.8.3-1~bpo60+1 0
        100 http://backports.debian.org/debian-backports/ squeeze-backports/main amd64 Packages
    5:0.7.13-dmo2 0
        500 http://www.deb-multimedia.org/ squeeze/main amd64 Packages
    4:0.5.9-1 0
        500 http://security.debian.org/ squeeze/updates/main amd64 Packages
        500 http://ftp.us.debian.org/debian/ squeeze-proposed-updates/main amd64 Packages
    4:0.5.6-3 0
        500 http://http.us.debian.org/debian/ squeeze/main amd64 Packages
        500 http://ftp.us.debian.org/debian/ squeeze/main amd64 Packages
vlc:
  Installed: 1.1.3-1squeeze6
  Candidate: 1.1.3-1squeeze6
  Version table:
    2.0.3-1~bpo60+1 0
        100 http://backports.debian.org/debian-backports/ squeeze-backports/main amd64 Packages
 *** 1.1.3-1squeeze6 0
        500 http://http.us.debian.org/debian/ squeeze/main amd64 Packages
        500 http://ftp.us.debian.org/debian/ squeeze/main amd64 Packages
        500 http://security.debian.org/ squeeze/updates/main amd64 Packages
        100 /var/lib/dpkg/status
ztcoracat@:~$ apt-get install ffmpeg -t "o=Unofficial Multimedia Packages"
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
ztcoracat:~$ Y
bash: Y: command not found
ztcoracat@:~$ su
Password:
ztcoracat# apt-get install ffmpeg -t "o=Unofficial Multimedia Packages"
Reading package lists... Done
Building dependency tree     
Reading state information... Done
The following package was automatically installed and is no longer required:
  libxcb-render-util0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libavdevice52 libavfilter1
Suggested packages:
  nvidia-libvdpau1
The following NEW packages will be installed:
  ffmpeg libavdevice52 libavfilter1
0 upgraded, 3 newly installed, 0 to remove and 3 not upgraded.
Need to get 620 kB of archives.
After this operation, 1,995 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://www.deb-multimedia.org/ squeeze/main libavdevice52 amd64 5:0.7.13-dmo2 [40.6 kB]
Get:2 http://www.deb-multimedia.org/ squeeze/main libavfilter1 amd64 5:0.7.13-dmo2 [214 kB]
Get:3 http://www.deb-multimedia.org/ squeeze/main ffmpeg amd64 5:0.7.13-dmo2 [365 kB]
Fetched 620 kB in 3s (166 kB/s)
Selecting previously deselected package libavdevice52.
(Reading database ... 123734 files and directories currently installed.)
Unpacking libavdevice52 (from .../libavdevice52_5%3a0.7.13-dmo2_amd64.deb) ...
Selecting previously deselected package libavfilter1.
Unpacking libavfilter1 (from .../libavfilter1_5%3a0.7.13-dmo2_amd64.deb) ...
Selecting previously deselected package ffmpeg.
Unpacking ffmpeg (from .../ffmpeg_5%3a0.7.13-dmo2_amd64.deb) ...
Processing triggers for man-db ...
Setting up libavdevice52 (5:0.7.13-dmo2) ...
Setting up libavfilter1 (5:0.7.13-dmo2) ...
Setting up ffmpeg (5:0.7.13-dmo2) ...
[ Rootkit Hunter version 1.3.6 ]
File updated: searched for 162 files, found 130

ztcoracat# apt-get install vlc -t "o=Unofficial Multimedia Packages"
Reading package lists... Done
Building dependency tree     
Reading state information... Done
vlc is already the newest version.
The following package was automatically installed and is no longer required:
  libxcb-render-util0
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

I'm puzzled why VLC is not working-

What else can I try?

Thanks in advance

jefro 09-17-2012 08:07 PM

I remember that on one of my installs. I can't find the exact post to confirm this but a windows forum has this. It was some vlc setting.

"You might also want to try changing 'Overlay video output' in 'Video>General video settings'. The wrong overlay setting Will usually give you a black video screen with the audio working properly. "
http://forum.videohelp.com/threads/2...age-only-sound

frankbell 09-17-2012 08:45 PM

Are you playing audio and looking for "visualizations" or playing video and getting no picture?

If the former, start the audio, then, while it is playing, open the VLC menu and go to Audio-->Visualizations and select the visualization you wish. If the latter, please provide more information, such as what media you are trying to play.

Ztcoracat 09-18-2012 12:00 AM

Frankbell:
I'm playing video ( aerobic workout video's/music video's) and getting no picture.:)

Ztcoracat 09-18-2012 12:08 AM

I went to Audio> Visualization> and my options are:
-Disable
-spectrometer
-Scope
-Spectrum and
-Vumeter

I noticed that I haver version 1.1.3 Shouldn't I have 2.2 or something like that?

Not sure here which is the right choice-
But I'm trying-

Ztcoracat 09-18-2012 12:19 AM

Quote:

Originally Posted by jefro (Post 4782804)
I remember that on one of my installs. I can't find the exact post to confirm this but a windows forum has this. It was some vlc setting.

"You might also want to try changing 'Overlay video output' in 'Video>General video settings'. The wrong overlay setting Will usually give you a black video screen with the audio working properly. "
http://forum.videohelp.com/threads/2...age-only-sound

I tried that thread eailer in the day and couldn't complete it because I don't have General Video Setttings under 'Video'

Ztcoracat 09-18-2012 12:55 AM

I opened the terminal and tried:
Code:

vlc --reset -config
That didn't help than I figured just <vlc>
Code:

ztcoracat@mock:~$ vlc
VLC media player 1.1.3 The Luggage (revision exported)
Warning: call to srand(1347947611)
Warning: call to rand()
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
Warning: call to signal(13, 0x1)
Blocked: call to setlocale(6, "")
Blocked: call to sigaction(17, 0x7fc105604b50, 0x7fc105604ab0)
Warning: call to srand(1347947611)
Warning: call to rand()
Warning: call to srand(1347947611)
Warning: call to rand()
Warning: call to srand(1347947611)
Warning: call to rand()
Warning: call to srand(1347947611)
Warning: call to rand()
Warning: call to signal(13, 0x1)
Blocked: call to setlocale(6, "")

(process:17617): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.
Warning: call to signal(13, 0x1)

Not sure if this output helps but I'm trying to help you to help me-

frankbell 09-18-2012 09:40 PM

What format is the video in? Is there somewhere it can be accessed and tested over the web?

Ztcoracat 09-19-2012 12:40 PM

The format for the video is 192.3 MB and is a (video/x-.flv)

It should be able to be tested on the web because I was able to download it from the web. (You-Tube)

jefro 09-19-2012 03:11 PM

It was some setting in VLC like overlay or something. I still can't find what I am looking for either.

frankbell 09-19-2012 08:23 PM

Quote:

It should be able to be tested on the web because I was able to download it from the web. (You-Tube)
Link?

Does VLC work with other video formats, such as *.mp4 and *.avi?

JaseP 09-19-2012 08:57 PM

I really don't think it's the video format (of the file). I believe you have to look for the menu item for the rendering method (like XV, etc.). You may have to experiment and find the right one... I don't have a machine with VLC readily available, but you want to enable the advanced settings to be able to drill down to that sort of thing...

Ztcoracat 09-19-2012 09:13 PM

Jefro:
I know how frustrating it can be when you can't find what your looking for.
I'll look for a function called 'overlay'.....


Frankbell:
Here's the link to the video I told you about. It's a Billy Blanks Taebo-Video
http://www.youtube.com/watch?v=W0VjI...eature=related


JaseP:
I'll try going through all of the menus items again and try each one.


I'll keep trying and between all of us looking and thinking it(VLC) will eventually; work.:study:

Ztcoracat 09-19-2012 10:22 PM

Ok; I found the "Accelerated Video output: Overlay"
So I clicked on the litlle box and than clicked save. Checking that box didn't provide any results-

I went in Media> Advanced Open File> that drop down menu opened into a window of options:
Files, Disc, Network and Capture Device; didn't see anything to solve the problem so I moved on to the next section.

I went to Video> the drop down menu opened. But all of the options in the drop down menu are all greyed out and not even an option for me to click on. Why; I wondered?

Is it possible that this is a "codec" issue?

Ztcoracat 09-19-2012 10:40 PM

Anyhow folks I found the new VLC Media Player for Linux-2.0.3
http://www.videolan.org/vlc/index.html

At this point I don't know weather to persue fixing the VLC Player I already have (or) just un-install/remove the current VLC 1.1.3 using my Software Manger and install the new Vlc Media Player-

Here's the page for the command that VLC gave:
http://www.videolan.org/vlc/download-debian.html

What do you guys think?


All times are GMT -5. The time now is 02:26 PM.