LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-13-2007, 04:31 PM   #1
CrewXp
Member
 
Registered: Jan 2004
Posts: 82

Rep: Reputation: 15
Installed TightVNC. Fails. Can't find fonts when ran. Running CentOS.


Hey, I'm trying to run freenx and tightvnc. I can't get freenx working, so I moved on to try to install tightvnc. I installed the Fedora rpm on my CentOs box. Everything installed.

When I tried to run it, it failed and exited. It says I'm missing fonts. I had the technicians install GNOME when it was being installed, but I don't think its configured.

Can anyone help me out?
-Thx

Quote:
[root@10 share]# vncserver
Couldn't start Xvnc; trying default font path.
Please set correct fontPath in the vncserver script.
Couldn't start Xvnc process.

Couldn't open RGB_DB '/usr/X11R6/lib/X11/rgb'
13/08/07 16:14:39 Xvnc version TightVNC-1.3.9
13/08/07 16:14:39 Copyright (C) 2000-2007 TightVNC Group
13/08/07 16:14:39 Copyright (C) 1999 AT&T Laboratories Cambridge
13/08/07 16:14:39 All Rights Reserved.
13/08/07 16:14:39 See http://www.tightvnc.com/ for information on TightVNC
13/08/07 16:14:39 Desktop name 'X' (10.40.223.72.static.reverse.ltdomains.com:1)
13/08/07 16:14:39 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
13/08/07 16:14:39 Listening for VNC connections on TCP port 5901
13/08/07 16:14:39 Listening for HTTP connections on TCP port 5801
13/08/07 16:14:39 URL http://10.40.223.72.static.reverse.ltdomains.com:5801
_FontTransSocketUNIXConnect: Can't connect: errno = 2
failed to set default font path 'unix/:7100'
Fatal server error:
could not open default font 'fixed'
Couldn't open RGB_DB '/usr/X11R6/lib/X11/rgb'
13/08/07 16:14:40 Xvnc version TightVNC-1.3.9
13/08/07 16:14:40 Copyright (C) 2000-2007 TightVNC Group
13/08/07 16:14:40 Copyright (C) 1999 AT&T Laboratories Cambridge
13/08/07 16:14:40 All Rights Reserved.
13/08/07 16:14:40 See http://www.tightvnc.com/ for information on TightVNC
13/08/07 16:14:40 Desktop name 'X' (10.40.233.72.static.reverse.ltdomains.com:1)
13/08/07 16:14:40 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
13/08/07 16:14:40 Listening for VNC connections on TCP port 5901
13/08/07 16:14:40 Listening for HTTP connections on TCP port 5801
13/08/07 16:14:40 URL http://10.40.223.72.static.reverse.ltdomains.com:5801
Font directory '/usr/X11R6/lib/X11/fonts/misc/' not found - ignoring
Font directory '/usr/X11R6/lib/X11/fonts/Speedo/' not found - ignoring
Font directory '/usr/X11R6/lib/X11/fonts/Type1/' not found - ignoring
Font directory '/usr/X11R6/lib/X11/fonts/75dpi/' not found - ignoring
Font directory '/usr/X11R6/lib/X11/fonts/100dpi/' not found - ignoring

Fatal server error:
could not open default font 'fixed'

ps: I also have another issue with my freenx server. Maybe they're related?
 
Old 08-13-2007, 06:03 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,132
Blog Entries: 54

Rep: Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791
The clue is in the first lines:
Quote:
Couldn't start Xvnc; trying default font path.
Please set correct fontPath in the vncserver script.
Couldn't start Xvnc process.
'vncserver' lives in /usr/bin, IIRC.
 
Old 08-13-2007, 06:18 PM   #3
CrewXp
Member
 
Registered: Jan 2004
Posts: 82

Original Poster
Rep: Reputation: 15
this may sound stupid, but i tried editing the vncserver script and using

$fontsPath="/usr/share/X11/fonts/"
and also
$fontsPath="/usr/share/X11/fonts/misc/"

But same message. I'm pretty sure those are where my fonts are installed. Or if they're even installed...
 
Old 08-13-2007, 06:24 PM   #4
CrewXp
Member
 
Registered: Jan 2004
Posts: 82

Original Poster
Rep: Reputation: 15
I've also tried setting it to /usr/share/fonts/default/


If I gave you root access, do you think you would be able to do it? Thx.
 
Old 08-14-2007, 12:19 PM   #5
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,132
Blog Entries: 54

Rep: Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791
If you have /usr/X11R6/lib/X11/fonts/misc/, try
Code:
$fontPath = "/usr/X11R6/lib/X11/fonts/misc/";
else try "rpm -qg 'User Interface/X'" to see that packages contain fonts, then list them ("rpm -ql packagename") to see where they're installed.


Quote:
If I gave you root access, do you think you would be able to do it?
Sure, but NO. NEVER EVER give somebody root account access unless there is no other alternative and you completely trust them (if you want to rate somebody on your trust scale use marks like honesty, integrity, responsability, confidence and professionalism). Killfile people who will tell you they can fix things if you "just" give them root: they're just looking for an easy prey.
 
Old 08-14-2007, 04:14 PM   #6
CrewXp
Member
 
Registered: Jan 2004
Posts: 82

Original Poster
Rep: Reputation: 15
well i trust you. as many times as I visit these forums, reading, you're always helping out.

It okay if i pm ya the info?

hehe, thx.
 
Old 08-15-2007, 01:29 AM   #7
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,132
Blog Entries: 54

Rep: Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791
But you don't need to? I mean, I gave you something to try?
 
Old 08-15-2007, 03:27 AM   #8
CrewXp
Member
 
Registered: Jan 2004
Posts: 82

Original Poster
Rep: Reputation: 15
Yeah sorry, I was on my phone earlier and didn't have putty on there to try it. Just txt.

I tried just now and i got this, all i have in my X11R6 directory is bin.

Quote:
[root@10 init.d]# rpm -qg "User Interface/X"
xorg-x11-font-utils-7.1-2
xorg-x11-xauth-1.0.1-2.1
xorg-x11-server-utils-7.1-4.fc6
imake-1.0.2-3
xorg-x11-xinit-1.0.2-13.el5
xorg-x11-fonts-base-7.1-2.1.el5
dogtail-0.6.1-2.el5
xorg-x11-server-Xvfb-1.1.1-48.13.0.1.el5
urw-fonts-2.3-6.1.1
xorg-x11-apps-7.1-4.0.1.el5
xorg-x11-xkb-utils-1.0.2-2.1
xorg-x11-utils-7.1-2.fc6
xkeyboard-config-0.8-7.fc6
xorg-x11-server-Xorg-1.1.1-48.13.0.1.el5
tightvnc-server-1.3.9-1
gdm-2.16.0-31.0.1.el5.centos
xterm-215-4.el5
gthumb-2.7.8-5.el5
Gnome is what i have installed and is up and running
 
Old 08-15-2007, 11:49 AM   #9
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,132
Blog Entries: 54

Rep: Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791
"rpm -ql xorg-x11-fonts-base" should show you the path to use.
 
Old 08-15-2007, 02:39 PM   #10
CrewXp
Member
 
Registered: Jan 2004
Posts: 82

Original Poster
Rep: Reputation: 15
When I did that, I got a HUGE list of locations, all of which seem like they're in

/usr/share/X11/fonts/encodings
/usr/share/X11/fonts/misc


but i can't see the whole list, is that enough info? I don't know how to purge the listing in putty so I can see one page at a time.

And where do i put post locations in tightvnc?
 
Old 08-15-2007, 03:43 PM   #11
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,132
Blog Entries: 54

Rep: Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791
is that enough info?
Indeed. Try "/usr/share/X11/fonts/misc". Make sure you use the right notation.


I don't know how to purge the listing in putty so I can see one page at a time.
Pipe it through a pager, like 'rpm -ql xorg-x11-fonts-base | less' or 'rpm -ql xorg-x11-fonts-base | more'. In most cases I think less really is more because 'less' allows you to scroll back, search for stuff and save output...

Last edited by unSpawn; 08-15-2007 at 03:45 PM.
 
Old 08-15-2007, 05:16 PM   #12
CrewXp
Member
 
Registered: Jan 2004
Posts: 82

Original Poster
Rep: Reputation: 15
I edited /etc/bin/vncserver and put in

$fontPath="usr/share/X11/fonts/misc";

but im stillg etting the same msg.
 
Old 08-16-2007, 02:06 PM   #13
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,132
Blog Entries: 54

Rep: Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791
Did a diff to see what I changed. Apparently it's two "fontPath" ones:
Code:
--- usr/bin/vncserver     0000-00-00 00:00:00.000000000 +0000
+++ /usr/bin/vncserver  0000-00-00 00:00:00.000000000 +0000
@@ -38,11 +38,14 @@
 $desktopName = "X";
 $vncClasses = "/usr/share/vnc/classes";
 $vncUserDir = "$ENV{HOME}/.vnc";
-$fontPath = "unix/:-1";
+#$fontPath = "unix/:-1";
 $authType = "-rfbauth $vncUserDir/passwd";
 
 # Here is another example of setting the font path:
 # $fontPath = "/usr/lib/X11/fonts/misc/,/usr/lib/X11/fonts/75dpi/";
+$fontPath = "/usr/X11R6/lib/X11/fonts/misc/";
+
+
 
 # X colors database path is optional, uncomment and edit to use:
 # $colorPath = "/usr/lib/X11/rgb";
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Where can I find the available fonts installed on apache 1.3 FredFreedom Linux - Newbie 2 01-29-2006 01:18 PM
TightVNC and Fonts on SimplyMepis 3.4r1 Maskkkk MEPIS 0 12-05-2005 06:40 AM
Installed suse...ran Yast Update...now a kernel panic? RoaCh Of DisCor Suse/Novell 1 12-24-2004 10:32 PM
Running Tightvnc twantrd Linux - General 14 06-24-2003 01:18 AM
i cant ran 'mysql' while 'safe_mysqld &' is running thep Linux - Newbie 1 04-13-2001 10:14 AM


All times are GMT -5. The time now is 06:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration