LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-27-2004, 02:25 PM   #1
LinuxOff
LQ Newbie
 
Registered: Aug 2004
Posts: 1

Rep: Reputation: 0
Unhappy Installed file conflicts with file from package XFree86-4.1.0-26


I would like to install gv-3.5.8.tar in order to view .ps file on my Redhat7.2 alpha based machine. However, to install gv, I have to install Xaw3d-1.3.tar.gz. To install Xaw3d, I have to use xmkmf, but my computer doesn't have it. I copied xmkmf from the other machine and placed it on /usr/X11R6/bin/ (Can I do that?) . Once I run it, it showed

imake -DUseInstalled -I/usr/X11R6/lib/X11/config
/usr/X11R6/bin/xmkmf: imake: command not found

I think I need imake file, so I'm trying to install the package imake-4.2.1-9.alpha.rpm (I downloaded from rpmfind.net.) When I try to install this file, I got the following message:

rpm -ihv imake-4.2.1-9.alpha.rpm
Preparing... ########################################### [100%]
file /usr/X11R6/man/man1/makedepend.1x.gz from install of imake-4.2.1-9 conflicts with file from package XFree86-4.1.0-26

I searched from the web and someone suggested for this kind of problem to check first if the computer has the previous version of imake, if so I can use

rpm -Uhv packagename.rpm

I'm pretty sure that my computer doesn't have imake but I tried the above command and got this message:

rpm -Uhv imake-4.2.1-9.alpha.rpm
Preparing... ########################################### [100%]
file /usr/X11R6/man/man1/makedepend.1x.gz from install of imake-4.2.1-9 conflicts with file from package XFree86-4.1.0-26

The same source further suggested to force install with the command --nodeps.
I tried and got this :

rpm -i --nodeps imake-4.2.1-9.alpha.rpm
file /usr/X11R6/man/man1/makedepend.1x.gz from install of imake-4.2.1-9 conflicts with file from package XFree86-4.1.0-26

I don't know what to do next Can anyone help me?
 
Old 09-06-2004, 12:51 AM   #2
stevie_velvet
Member
 
Registered: Aug 2004
Location: Italia + UK
Distribution: RHEL 4 + Fedora FC5
Posts: 118

Rep: Reputation: 15
i'm on the same issue trying to upgrade my xfree86 | there must be something more straight forward than this to eliminate the old version
 
Old 09-06-2004, 02:00 AM   #3
jev-bird
Member
 
Registered: Jul 2004
Location: USofA
Distribution: Whatever runs accordingly.
Posts: 200

Rep: Reputation: 30
Re: Installed file conflicts with file from package XFree86-4.1.0-26

Quote:
Originally posted by LinuxOff
I would like to install gv-3.5.8.tar in order to view .ps file on my Redhat7.2 alpha based machine. However, to install gv, I have to install Xaw3d-1.3.tar.gz. To install Xaw3d, I have to use xmkmf, but my computer doesn't have it. I copied xmkmf from the other machine and placed it on /usr/X11R6/bin/ (Can I do that?) . Once I run it, it showed

imake -DUseInstalled -I/usr/X11R6/lib/X11/config
/usr/X11R6/bin/xmkmf: imake: command not found

I think I need imake file, so I'm trying to install the package imake-4.2.1-9.alpha.rpm (I downloaded from rpmfind.net.) When I try to install this file, I got the following message:

rpm -ihv imake-4.2.1-9.alpha.rpm
Preparing... ########################################### [100%]
file /usr/X11R6/man/man1/makedepend.1x.gz from install of imake-4.2.1-9 conflicts with file from package XFree86-4.1.0-26

I searched from the web and someone suggested for this kind of problem to check first if the computer has the previous version of imake, if so I can use

rpm -Uhv packagename.rpm

I'm pretty sure that my computer doesn't have imake but I tried the above command and got this message:

rpm -Uhv imake-4.2.1-9.alpha.rpm
Preparing... ########################################### [100%]
file /usr/X11R6/man/man1/makedepend.1x.gz from install of imake-4.2.1-9 conflicts with file from package XFree86-4.1.0-26

The same source further suggested to force install with the command --nodeps.
I tried and got this :

rpm -i --nodeps imake-4.2.1-9.alpha.rpm
file /usr/X11R6/man/man1/makedepend.1x.gz from install of imake-4.2.1-9 conflicts with file from package XFree86-4.1.0-26

I don't know what to do next Can anyone help me?

rpm -i --nodeps imake-4.2.1-9.alpha.rpm is not going force it.

Try rpm -ivh --force --nodeps imake-4.2.1-9.alpha.rpm

And see if that works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Package Conflicts RodimusProblem Linux - Newbie 3 01-10-2005 08:11 PM
XFree86 and GPM conflicts? cuco76 Linux From Scratch 7 07-16-2004 08:52 PM
snmpd installed, see file, but get error file not found PCHelper Slackware 0 11-06-2003 12:44 PM
file conflicts issue mla Linux - Software 1 10-11-2003 07:55 AM
ncurses-5.2-28 conflicts with file from package ncurses-5.2-12 tubby Linux - Software 4 06-16-2002 12:00 AM


All times are GMT -5. The time now is 08:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration