LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-11-2004, 04:52 AM   #1
pgrimes
LQ Newbie
 
Registered: Jun 2004
Location: Folsom, CA
Distribution: RHEL
Posts: 27

Rep: Reputation: 15
installed dropline, root loads kde3.2, user loads drop


Ok... I'm new with linux. I'm running slackware 9.1 and I've updated it to current using swaret.
I've got a few questions here.

1.)I just installed Dropline and, the root user is loading into KDE 3.2 and my user account loads Dropline when x is started.

What's going on? I'm wanting all accounts to load Dropline unless I specify KDE (or something else). I'm assuming that I've got a file somewhere that's saying to load KDE and it isn't being updated for my user account.

2.) My soundcard isn't being recognized all of a sudden. I run alsaconf (or is it alsaconfig) and, it says that no devices are found. The sound used to work before all the updates and the dropline install.

I'm running on a Toshiba M35-S359

3.) I'm about to upgrade from kernel 2.4.22 to kernel 2.6.6. This won't be my first try at it. Previously, when I load into 2.6.6, my network card isn't recognized and, I can't get onlne at all (it's an intel card Pro 100, off the top of my head, the driver it's using is epro100 or something like that). Is there anyway I can back up the driver that's currently installed so I can reinstall it after the kernel upgrade? Or is it likely that this driver won't work with the new kernel?


Thanks a ton for any help!

Paul
 
Old 06-11-2004, 09:30 AM   #2
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
You can try

xwmconfig

on the command line to change the users desktop


Normally after an upgrade I've found I have to re-install the alsa packages, but this is usually only when some kernel related stuff has been upgraded. Using pkgtool you could uninstall all the alsa packages you have on your system and then reinstall them in, they should be in /var/swaret/ Do ls /var/swaret/alsa* to see if they are in there. Dropline installs it's own alsa-lib and alsa-utils packages, so after you've removed them the alsa via pkgtool run the dropline-installer -> view updates and reinstalling them if it says they are available. Reboot and hope


If you card doesn't work after upgrading all I can really suggest really, is recompile the kernel with that card support in it as that's the way I've always done it - you'll be updrading via source anyway ?
 
Old 06-11-2004, 11:21 AM   #3
Nis
Member
 
Registered: Jul 2003
Location: Virginia
Distribution: Ubuntu Hoary (5.04)
Posts: 550

Rep: Reputation: 31
Looking_lost is right for changing your WM as root. For the ALSA problem, the -driver package is for a certain kernel version, 2.4.26 for the latest package 1.0.5a. You'll need to upgrade your kernel to that and then run alsaconf to get sound working. If you plan on upgrading to 2.6.6 you could go with the kernel-2.6.6 packages in testing/ on Slackware-current (I do). It's not too difficult and I haven't run into any problems yet. You will need to use the ALSA -driver package in testing/ as well.

The only issue with this testing kernel is that the only filesystem support built-in is ext2. For anything else you'll need to install the mkinitrd package and make a RAM disk image to load the right filesystem module at boot. The docs in the mkinitrd package are for the wrong thing though, so this was a little tricky. Here is what I did:

1) cd to /boot and run mkinitrd. It will setup the mkinitrd tree for you.
2) cd into that tree down to a modules directory named after the kernel version you were running when you ran mkinitrd. Rename that directory to 2.6.6.
3) Move the right filesystem module (in my case reiserfs) from the 2.6.6 modules directory into that directory.
4) cd to /boot and run mkinitrd again. It should create initrd.gz.
5) Edit your lilo.conf and add the line 'initrd=/boot/initrd.gz'

It's a good idea to keep the other kernel packages installed and add another boot option to lilo.conf to boot up the old kernel if things go wrong.
 
Old 06-11-2004, 01:52 PM   #4
pgrimes
LQ Newbie
 
Registered: Jun 2004
Location: Folsom, CA
Distribution: RHEL
Posts: 27

Original Poster
Rep: Reputation: 15
Thanks for the replies...

Ok, I forgot to mention in my post that, earlier, I tried running xwmconfig and it was telling me the command was not found (this was as root or anyone else). Regardless... I woke up today and, my user account couldn't load x at all.... it shuts back down when I try to login (oh noooo more xorg.conf probs). So, I switched to root and started x. KDE loaded, I opened up a terminal, ran xwmconfig, chose gnome and, wa-la. I'm in dropline.... I've been scared to log out and test the user account though... I don't wanna be trapped in command line (I do have plenty of backups of XF86Config and xorg.conf though).

In the past when I've run into a problem like this (x can't start for user), I've deleted and re-added the user account and that fixes it. Is there something better I could do? I imagine there's a profile file or config file that contains the user startup settings.

I'll worry about my sound/kernel once I've got my x situation all cleared up.
 
Old 06-11-2004, 08:19 PM   #5
pgrimes
LQ Newbie
 
Registered: Jun 2004
Location: Folsom, CA
Distribution: RHEL
Posts: 27

Original Poster
Rep: Reputation: 15
So, I still can't get x to start with the user account. It gives some timeout messages saying something about

xaut: timeout while locking .Xauthority

That's not the exact message.

Root loads x fine... any ideas?
 
Old 06-11-2004, 08:34 PM   #6
pgrimes
LQ Newbie
 
Registered: Jun 2004
Location: Folsom, CA
Distribution: RHEL
Posts: 27

Original Poster
Rep: Reputation: 15
I solved the .Xauthority thing. I guess root had ownership of the user directory.

chown user /home/user

solved that.

But, x still won't load... so, i'm back to the question... why aren't the settings for x, that root has, being applied to my user account? I've deleted/recreated the user account but, it hasn't helped. I don't wanna mess with the xorg.conf because, I seem to have a knack for ruining it and, I figure it must be ok if root is able to startx.
 
Old 06-12-2004, 01:19 PM   #7
pgrimes
LQ Newbie
 
Registered: Jun 2004
Location: Folsom, CA
Distribution: RHEL
Posts: 27

Original Poster
Rep: Reputation: 15
bump
 
Old 06-28-2004, 06:11 PM   #8
vanhout_p
LQ Newbie
 
Registered: Dec 2003
Location: Oregon, USA
Distribution: Slackware 10.0
Posts: 7

Rep: Reputation: 0
i had a similar prob...

try comparing the .xinitrc files in the home directory of both user and root.
specificly the bottom line in both should say gnome-session or something of that sort.
if the don't , you can just open /etc/X11/xinit/xinitrc.gnome and save it over whatever one is wrong.
you also might want to check the xinitrc file in /etc/X11/xinit/ to see what it points to.

hope that helps
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
diskette loads but can't see the CD bobby_hawk VectorLinux 3 07-02-2005 11:38 AM
Everything Loads Slowly mandymo Mandriva 5 12-12-2004 11:36 AM
X only loads for root user; Hangs when other users log in (Fedora Core 3) stupidloser Linux - General 1 11-29-2004 05:13 AM
X loads fine as root, but not as a general user IanS Linux - Newbie 0 10-05-2003 06:46 AM
TV out - Works up until X loads bkeating Linux - Hardware 3 11-21-2002 02:06 AM


All times are GMT -5. The time now is 05:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration