LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-23-2003, 10:18 PM   #1
SDSkyle
LQ Newbie
 
Registered: Apr 2003
Posts: 12

Rep: Reputation: 0
Install of Metacity theme causes GNOME 2.2 to hang at start-up and errors with Gaim


Okay, I installed the Metacity theme 2.4.55 for GNOME 2.2 today, and the compilation seemed to go well. I couldn't figure out how to set it up, so I reboot to see if I had to restart x in order to get it to work. However, upon starting GNOME, it just hangs at the starting xwindows icon on the greeter, then the screen turns black and I have to reboot.

Metacity doesn't even look very good, and I don't want to go through the trouble of trying to get it to work, so I'll stick with Fluxbox and the occasional KDE for my glam fix. I want to remove Metacity and hope it fixes the problems. Do I simply delete its directory or do I have to edit gnome's configuration as well?

P.S. I doubt it matters, but I use Slackware 9 with kernel 2.4.21.

Last edited by SDSkyle; 08-23-2003 at 10:38 PM.
 
Old 08-23-2003, 10:24 PM   #2
SDSkyle
LQ Newbie
 
Registered: Apr 2003
Posts: 12

Original Poster
Rep: Reputation: 0
Edit: I've discovered that I have no problems with GAIM when I run it under su. This is a bit insecure, though. I think I need to allow permissions to the the files to regular users.

I still can't start up GNOME, though.

Last edited by SDSkyle; 08-23-2003 at 10:25 PM.
 
Old 08-23-2003, 10:58 PM   #3
SDSkyle
LQ Newbie
 
Registered: Apr 2003
Posts: 12

Original Poster
Rep: Reputation: 0
Okay, I've figured it out. I simply ran make uninstall and removed the newer metacity. However, I removed the older packages of metacity with the package manager because I thought they were the ones I installed that were causing problems. Now, it has trouble when I start GNOME, but it still works. Nothing seriously wrong. I think I'm just going to remove GNOME for now anyways. This way, I can compile a later version from source later.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kde and gnome: how to start both without errors punt Linux - Software 7 07-31-2005 10:22 PM
How to install new Gnome theme?? TruongAn Linux - Newbie 3 04-10-2005 05:32 AM
garnome 2.8 install gnome-icon-theme error XsuX Linux - Software 1 10-26-2004 12:16 AM
FC2 hang at start of install. TomF Fedora - Installation 6 05-28-2004 05:54 PM
SuSE 9.0 Metacity Theme SlCKB0Y Linux - Distributions 9 12-04-2003 12:04 PM


All times are GMT -5. The time now is 04:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration