LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-17-2012, 05:09 AM   #16
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,170

Rep: Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645

# 15

http://www.tkn.tu-berlin.de/fileadmi...eadme_EDCA.txt
Quote : "This model only works with ns-2.28.
Several changes might be needed to use it in combination with other ns versions."
 
Old 12-17-2012, 04:31 PM   #17
torjemen
Member
 
Registered: Dec 2012
Posts: 37

Original Poster
Rep: Reputation: Disabled
I have see this comment in Readme file but how can I do to install this patch in ns 2.33 ?
I haven't get any information in the internet about it.
however, all command is OK . Just the last one when I type make return an error
 
Old 12-17-2012, 05:56 PM   #18
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,170

Rep: Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645
# 17

Please try with the new ( experimental ) patch "EDCA_ns233-all-v1-0-2.tar.gz" :
EDIT : changed to EDCA_ns233-v1-0-2-18Dec2012.tar.gz
providing : common/ mac/ tcl/ Makefile.in,
all as close as possible to the 'README.txt' in EDCA_ns-2_28-v1-0-2.tgz.

cd ns-allinone-2.33/ns-2.33/ && tar xvf EDCA_ns233-v1-0-2-18Dec2012.tar.gz
https://docs.google.com/open?id=0B7S...jNfUDR4OGV6eXM

Compiles OK with an unpatched ns-allinone-2.33 .


.

Last edited by knudfl; 12-18-2012 at 10:14 AM.
 
Old 12-18-2012, 02:45 AM   #19
torjemen
Member
 
Registered: Dec 2012
Posts: 37

Original Poster
Rep: Reputation: Disabled
I have donwload again ns2.33 unzip it and EDCA_ns233-all-v1-0-2.tar.gz and type the command below:
cd ns-allinone-2.33/ns-2.33/ && tar xvf EDCA_ns233-all-v1-0-2.tar.gz
then I type $ cd ns-allinone-2.33/ && export CC=gcc34 CXX=g++34 && ./install
it is OK and ns is installed
but when I type make install I get the following error:
Quote:
[root@localhost ns-2.33]# make install
for d in /usr/local/man/man1; do \
if [ ! -d $d ]; then \
mkdir -p $d ;\
fi;\
done
/usr/bin/install -c -m 755 ns /usr/local/bin
/usr/bin/install -c -m 644 ns.1 /usr/local/man/man1
[root@localhost ns-2.33]# ns
ns:
[code omitted because of length]
: invalid command name "..."
while executing
"..."
invoked from within
"if [TclObject is-class Mac/802_11e] {
...
copy settings of MAC/802.11
(which are contained in this file) into this section
and at an "e" at the end o..."
what is the matter ?
 
Old 12-18-2012, 08:27 AM   #20
torjemen
Member
 
Registered: Dec 2012
Posts: 37

Original Poster
Rep: Reputation: Disabled
I have fix the problem, I add the setting of MAC/802.11e into file tcl/lan/ns-mac.tcl.
now, i will try to add also WLANpatch-ns2.28-v1_0
, HWMP patch and MultiInterface patch

Last edited by torjemen; 12-18-2012 at 08:48 AM.
 
1 members found this post helpful.
Old 12-18-2012, 08:59 AM   #21
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,170

Rep: Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645
# 20
Quote:
I have fix the problem, I add the setting of MAC/802.11e into file tcl/lan/ns-mac.tcl
Interesting. Can you attach the new file ? As ns-mac.tcl.txt.
Attaching : It's the paper clip tool in the 'Advanced Editor'.
 
Old 12-18-2012, 10:00 AM   #22
torjemen
Member
 
Registered: Dec 2012
Posts: 37

Original Poster
Rep: Reputation: Disabled
I have juts update the file according to EDCA patch file:
Quote:
6. add to tcl/lan/ns-mac.tcl:
if [TclObject is-class Mac/802_11e] {
...
copy settings of MAC/802.11
(which are contained in this file) into this section
and at an "e" at the end of the "Mac/802_11" terms
...

Mac/802_11e set cfb_ 0 ;# disables CFB
}
Now i'm trying to install CMU-WLAN Patch but it also for 2.28 . Have you any idea how to do it for ns 2.33
Best regards.
Attached Files
File Type: txt ns-mac-updated.txt (4.3 KB, 17 views)
 
Old 12-18-2012, 10:09 AM   #23
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,170

Rep: Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645
# 22 . OK, I must have forgotten that edit.
The updated package, EDCA_ns233-v1-0-2-18Dec2012.tar.gz : I will edit post #18.


"CMU-WLAN Patch" : Please provide a link to the patch.


.
 
Old 12-18-2012, 10:34 AM   #24
torjemen
Member
 
Registered: Dec 2012
Posts: 37

Original Poster
Rep: Reputation: Disabled
Please find enclosed the patch (format txt)
Attached Files
File Type: txt CMU_WLAN_patch.txt (6.8 KB, 12 views)
File Type: txt README.txt (671 Bytes, 12 views)
 
Old 12-19-2012, 08:10 AM   #25
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,170

Rep: Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645
# 24

The patch CMU_WLAN_patch is meant to be installed together with "EDCA" :
In ns-2.28 . If I read the sparse information right.
* It would be nice, if you can provide a link to the site,
where you got the CMU_WLAN information and the files.

The patch CMU_WLAN_patch fits badly into
ns-2.33/mac/ mac-802_11.cc mac-802_11.h mac-timers.cc mac-timers.h .
When you apply the patch, the rejected code will be saved to :
mac-802_11.cc.rej mac-802_11.h.rej mac-timers.cc.rej mac-timers.h.rej .
Then you can see which code it is about.

The easy solution : Use ns-allinone-2.28 for EDCA and CMU_WLAN.
.
 
Old 12-19-2012, 09:23 AM   #26
torjemen
Member
 
Registered: Dec 2012
Posts: 37

Original Poster
Rep: Reputation: Disabled
I need to install all patches on ns2.33
for the link the patch can be found: http://www2.tkn.tu-berlin.de/research/802.11e_ns2/
Best regards.
 
Old 12-24-2012, 03:30 PM   #27
torjemen
Member
 
Registered: Dec 2012
Posts: 37

Original Poster
Rep: Reputation: Disabled
No reply untill now

Last edited by torjemen; 12-24-2012 at 04:20 PM.
 
Old 12-26-2012, 10:45 AM   #28
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,170

Rep: Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645
# 26.
Quote:
I need to install all patches on ns2.33
Why ? ? If it is your own decision, it may be a wrong decision ?
Please see post #11 :
You can have as many versions of ns-allinone-2.xx as you want ..

# 27
Quote:
No reply untill now
You have yet to confirm that you have read all the patches,
and to confirm that you understand the "may be conflicting
changes" that are made to the ns-2.xx/* files.

.
 
Old 12-28-2012, 07:18 PM   #29
torjemen
Member
 
Registered: Dec 2012
Posts: 37

Original Poster
Rep: Reputation: Disabled
Dear Sir,
the need of use all patches on the same ns is not my decision.
Indeed, I try now to use some tcl script written by one student during his master degree project and he has already use this all patches on the some ns with some amendement.
He don't spoke about amendment and how we can do it but he just tell that he has adjast some patches.
Best regards.
 
Old 06-22-2013, 05:25 AM   #30
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,170

Rep: Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645Reputation: 2645
HWMP, Hybrid Wireless Mesh Protocol :
New links for the patches / the patched ns-2.33, posts #7, #8 here
http://www.linuxquestions.org/questi...-4175465910/#7

( The original link is down.)

-
 
  


Reply

Tags
edca, hwmp, ns2


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] how to install NS2 in Fedora 9 ? sange Linux - Software 2 01-23-2012 05:00 AM
how to install NS2.34 in fedora 14 naren123.k Linux - Software 9 03-12-2011 04:20 AM
How to install NS2 on fedora 11????? liban779 Linux - Software 5 03-04-2011 07:46 AM
how to install ns2 on fedora ? vaibhav_soham Linux - Software 1 01-02-2010 02:05 AM
how to install ns2 in fedora-5? salady86 Linux - Newbie 3 03-14-2008 09:55 AM


All times are GMT -5. The time now is 02:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration