LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Install kopete (http://www.linuxquestions.org/questions/linux-software-2/install-kopete-264507/)

thegamegraal 12-09-2004 12:44 PM

Install kopete
 
i have mandrake9.1, Im pretty new at this stuff. Im trying to install kopete a messanger. I type ./configure in console like it tells me to and i get this error

checking for pthread_create in -lpthread... yes
checking for extra includes... no
checking for extra libs... no
checking for libz... -lz
checking for libpng... no
checking for libjpeg6b... no
checking for libjpeg... no
configure: WARNING: libjpeg not found. disable JPEG support.
checking for perl... /usr/bin/perl
checking for Qt... configure: error: Qt (>= Qt 3.2) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
[thegamegraal@localhost kopete-0.9.0]$

when i look at the end of configure.log it says this

#define PACKAGE_BUGREPORT ""
#define PACKAGE_NAME ""
#define PACKAGE_STRING ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define SIZEOF_CHAR_P 4
#define SIZEOF_INT 4
#define SIZEOF_LONG 4
#define SIZEOF_SHORT 2
#define SIZEOF_SIZE_T 4
#define SIZEOF_UNSIGNED_LONG 4
#define STDC_HEADERS 1
#define VERSION "3.3.0"
#define kde_socklen_t socklen_t
#define ksize_t socklen_t
#endif
#ifdef __cplusplus
extern "C" void std::exit (int) throw (); using std::exit;

configure: exit 1

what do i do? :confused:

thegamegraal 12-09-2004 12:47 PM

maybe Qt (>= Qt 3.2) means i have version 3.2 of kde? it says i need 3.5 to install...no clue just a random guess..:(

thegamegraal 12-09-2004 02:20 PM

anyone....?

mjjzf 12-09-2004 02:27 PM

No, QT is a coding framework. Have you tried
Code:

urpmi qt
- that should give you a view of the installation. The error message suggests that you need version 3.2 or later. If there is no go with URPMI, see if you can dig it up at RPMFind.

thegamegraal 12-09-2004 03:49 PM

tried to get urpmi and it said i needed like 12 perl files....i hate this..i think im switching back to windows. Everytime i try to download something it tells me i need something else and that file tells me i need something else then that other file tells me i need something else. And it never ends..god if i had 56k my computer would be out the window.

thegamegraal 12-09-2004 09:07 PM

anyone know where i can just get a package of shit so i dont have to worry about getting a billion files..

daihard 12-10-2004 12:34 AM

Quote:

Originally posted by thegamegraal
anyone know where i can just get a package of shit so i dont have to worry about getting a billion files..
The reason there's no package that meets everyone's need is because there are so many different varieties of UNIX/Linux flavours out there, creating one would be just plain impossible. Do you want to see one particular version of Linux taking up 90+ percent of the desktop market? I don't.

Qt is the set of application development tools. Kopete is build with it, so you naturally need Qt in order to run Kopete. And the version of Kopete that you're trying to install requires the version of Qt that's 3.2 or newer.

I don't have Mandrake 9.1, but you can check the version of Qt installed on your machine this way (via command-line):
Code:

# rpm -qa | grep qt3
It will produce a list that looks like this:
Code:

qt3-3.2.3-8
qt3-tools-3.2.3-8
qt3-devel-3.2.3-8

This means you've got Qt 3.2.3 installed. You say you cannot "configure" Kopete because you don't have Qt 3.2 or newer. I am pretty sure it's because you don't have the "qt3-devel" package installed. If the above command proves it's the case, all you have to do is grab your Mandrake CDs, find the "qt3-devel" package and install it.

Good luck!
Dai

thegamegraal 12-10-2004 12:50 AM

Quote:

Originally posted by daihard
The reason there's no package that meets everyone's need is because there are so many different varieties of UNIX/Linux flavours out there, creating one would be just plain impossible. Do you want to see one particular version of Linux taking up 90+ percent of the desktop market? I don't.

Qt is the set of application development tools. Kopete is build with it, so you naturally need Qt in order to run Kopete. And the version of Kopete that you're trying to install requires the version of Qt that's 3.2 or newer.

I don't have Mandrake 9.1, but you can check the version of Qt installed on your machine this way (via command-line):
Code:

# rpm -qa | grep qt3
It will produce a list that looks like this:
Code:

qt3-3.2.3-8
qt3-tools-3.2.3-8
qt3-devel-3.2.3-8

This means you've got Qt 3.2.3 installed. You say you cannot "configure" Kopete because you don't have Qt 3.2 or newer. I am pretty sure it's because you don't have the "qt3-devel" package installed. If the above command proves it's the case, all you have to do is grab your Mandrake CDs, find the "qt3-devel" package and install it.

Good luck!
Dai

i know this..then i get qt...it says i need something else...then i get that says i need 6 other things and so on..never ending cycle that is not worth it for every program i try to install

daihard 12-10-2004 12:54 AM

Quote:

Originally posted by thegamegraal
i know this..then i get qt...it says i need something else...then i get that says i need 6 other things and so on..never ending cycle that is not worth it for every program i try to install
That's starting to sound suspicious. You do have KDE installed on your machine, don't you? Which version?

To do your own compilation, you need lots of *-devel packages. If you didn't have them installed to begin with, then you've got to do that before starting to build stuff yourself.

FF103 12-13-2004 07:19 PM

kopete is included in the Mandrake 9.1 CD's, just go to the Mandrake Control Center and search "kopete" Also Yahoo Messenger is available in RPM for 9.1

BruceCadieux 12-13-2004 07:23 PM

Quote:

Originally posted by thegamegraal
anyone know where i can just get a package of shit
Yes go back to windows. It's the biggest package of shit I know of.


All times are GMT -5. The time now is 01:42 AM.