LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-20-2004, 03:06 PM   #1
monc
LQ Newbie
 
Registered: Oct 2003
Posts: 17

Rep: Reputation: 0
Unhappy install ide-scsi emulation


We had a scsi card installed with our cdwriter. But we bought dvdwriter this drive is ide.
so we removed the scsi card because we didn't need it anymore.
now dvdrecord -scanbus can't find any devices.

we tryed to add the ide-scsi emulation to lilo.conf.anaconda but the server crashed.

can someone help me with this problem?

thanks monc
 
Old 01-20-2004, 03:17 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
post the contents of lilo.conf please. remember that any changes you make to lilo will require you to run "lilo" to update the boot sector.
 
Old 01-21-2004, 01:23 AM   #3
monc
LQ Newbie
 
Registered: Oct 2003
Posts: 17

Original Poster
Rep: Reputation: 0
this is the lilo.conf.anaconda:

prompt
timeout=50
default=linux
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
message=/boot/message
lba32

image=/boot/vmlinuz-2.4.20-8
label=linux
initrd=/boot/initrd-2.4.20-8.img
read-only
append="root=LABEL=/"

How can i see which drive is used?
hde, hda etc

gr monc
 
Old 01-21-2004, 03:34 AM   #4
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
If your DVD writer is /dev/hdc (if you are unsure you can use dmesg | grep DVD to figure it out) just edit the append= line from the one you already have - append="root=LABEL=/" to append="root=LABEL=/ hdc=ide-scsi"
Rerun /sbin/lilo when you have changed /etc/lilo.conf.

Also make sure the ide-scsi module is loaded on boot. This is done differently on different distributions - on Gentoo you specify what modules to load in /etc/modules.autoload.d/* and in Debian you would use /etc/modules.

When the device is using SCSI emulation you would most probably access it as /dev/scd0 or /dev/sg0 instead of /dev/hdc (or whatever IDE device you have it installed as).

Håkan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ide-scsi emulation RestInPieces Linux - Newbie 3 10-31-2004 04:45 PM
No ide SCSI emulation on 2.6? moger Linux - General 1 01-17-2004 09:42 PM
ide-scsi emulation vabaliukas Linux - Hardware 0 07-09-2003 09:14 AM
ide-scsi emulation vabaliukas Linux - Hardware 2 07-07-2003 08:39 PM
IDE-SCSI emulation problem rdoucet Linux - Newbie 7 03-26-2003 08:30 AM


All times are GMT -5. The time now is 10:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration