LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-30-2003, 04:58 PM   #1
aroneous54
LQ Newbie
 
Registered: Jan 2003
Posts: 5

Rep: Reputation: 0
Install drivers. How to stop x-server?


Hi, I'm trying to install the NVIDIA drivers for my video card on Linux 7.3. It says I need to nothave X-server running to do this. Can somebody tell me how to stop x-server and get in with just a prompt so I can load this file? Thanks!!!
 
Old 04-30-2003, 05:04 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 65
Try:
1) Ctrl + Alt + F1
2) Login as root
3) init 3
4) Install your drivers
5) init 5

Step 5 should start X again.
 
Old 04-30-2003, 05:04 PM   #3
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Boot into runlevel 3. Either pass the argument at boot time or after booting up, pass it from a terminal like this: init 3
 
Old 05-03-2003, 05:50 AM   #4
camelrider
Member
 
Registered: Apr 2003
Location: Juneau, Alaska
Posts: 245

Rep: Reputation: 31
Or..

If you are in X and want out <ctl+alt+bkspace> does it in a lot of distro's.
 
Old 05-03-2003, 06:02 AM   #5
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 65
That just restarts it. (or should do)
 
Old 05-03-2003, 09:04 AM   #6
Nukes
Member
 
Registered: Apr 2003
Location: Scotland UK
Distribution: Gentoo
Posts: 92

Rep: Reputation: 15
Yeah, if you're in runlevel 5, ctrl atl backspace will either put you to standby or restart X11. No good. Just boot up in runlevel 3. Either type Linux 3 in lilo or add a 3 to te end of your append line in grub and boot.
 
Old 05-03-2003, 11:29 AM   #7
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 65
Or like I said in my first post - you can do it without rebooting at all.

Quote:
Originally posted by david_ross
Try:
1) Ctrl + Alt + F1
2) Login as root
3) init 3
4) Install your drivers
5) init 5

Step 5 should start X again.
 
Old 05-06-2003, 08:44 PM   #8
mjolnir
Member
 
Registered: Apr 2003
Posts: 696

Rep: Reputation: 72
David_ross, for some reason on my sys(xp/mdk9.1) ctrl + shift +
f1 stops x but I don't have a prompt. I end up doing a re-boot.
I wonder why?
 
Old 05-07-2003, 11:09 AM   #9
aherm
Member
 
Registered: Jan 2003
Location: upNorth
Distribution: openSuSE/uBuntu
Posts: 410

Rep: Reputation: 30
It's Ctrl+Alt+F1/F2/F3..F6 not Shift.


Have fun :-)
 
Old 05-07-2003, 01:03 PM   #10
mjolnir
Member
 
Registered: Apr 2003
Posts: 696

Rep: Reputation: 72
Sorry folks I mistyped in my post above.
Ctrl+Alt+F1/F2/F3..F6 stops X but still doesn,t
give me a prompt.
 
Old 05-07-2003, 01:15 PM   #11
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 65
Quote:
Originally posted by mjolnir
Sorry folks I mistyped in my post above.
Ctrl+Alt+F1/F2/F3..F6 stops X but still doesn,t
give me a prompt.
That's odd - what do you get?
 
Old 05-07-2003, 02:28 PM   #12
mjolnir
Member
 
Registered: Apr 2003
Posts: 696

Rep: Reputation: 72
I just get a blank screen, no prompt, cursor,etc. I end up having
to crtl+alt+del. It,s no big deal since I changed mdk9.1 default so
that I log in to the cmd line. This also happens if I log off as user.
It,s only irritating since I feel I will learn more if I use cmd as much
as possible. Thanks for your time!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do i disable X server to install the newest Nvidia drivers? linuxbullet Linux - Hardware 4 02-05-2004 12:16 AM
How do I stop the X server in RedHat 9 in order to load VGA drivers?? gammad Linux - Newbie 1 01-22-2004 10:04 AM
How do i restart the X server ? in order to install my Graphic drivers waheedrafiq Linux - Software 3 01-01-2004 05:02 PM
suse 8.2 how to startx and stop x and install nvidias video drivers rthatchjr Linux - Newbie 1 12-13-2003 04:46 AM
how to install printer drivers on samba server RH 8.0 clk777 Linux - Software 0 07-15-2003 03:11 PM


All times are GMT -5. The time now is 04:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration