LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-08-2003, 06:03 AM   #16
Knuffel
LQ Newbie
 
Registered: Jan 2003
Posts: 21

Original Poster
Rep: Reputation: 15

Welcom back MasterC ;-)
which doesn't mean that I don't appreciate the input from acid_kewpie

ok, when installing that package (i already downloaded it before) i get failed dependencies:

libstdc++-devel
gcc=3.2-44

so i downloaded libstdc++-devel and tried to install it, it asks for libstdc++=3.2-44
so i downloaded that again and tried but....

file /usr/lib/libstdc++.so.5.0.0 from install of libstdc++-3.2-44 conflicts with file from package libstdc++-3.2-36

and than I'm done again as a newbie :-(
So, i'm starting to get the hang of it, i keep needing packages ;-) it's just that i need to right versions I guess :-(

any suggestions on how to get this conflict out of the way?
 
Old 01-08-2003, 06:51 AM   #17
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Yeah, there's what Chris was talking about, this is where it gets rough (and why it would have been easier to do it during the install). You have X.5.22-24 and need X.5.22-30 ( a mere 6 revision difference!). That was always a huge problem I ran into with RPM's.

Anyway, to address the problem... You'll need to either (Answers differ on which way is better, I'll tell you both and you can decide):
A. Replace the installed libstdc++ with the older one (probably not the better option) and then go from there;
B. find the matching libstdc-devel to the installed version (better idea, but might be really hard to do) OR a 3rd, probably not great idea:
C. Force the install and hope it works. This really really really shouldn't be done on something like GCC dependencies as it's a very important program and you don't want it to be shifty (unstable).

I'd probably do something along the lines of searching out each version equaling the version of gcc. So if you need libstdc++-devel = libstdc++-3.2-44 then hunt it down:
http://gd.tuwien.ac.at/opsys/linux/s....2-44.i586.rpm (devel)
http://gd.tuwien.ac.at/opsys/linux/s....2-44.i586.rpm (libstdc++-3.2-44)

Good Luck, and since it's late/early and I'm feeling really geeky:
May the Source be with You

Cool
 
Old 01-08-2003, 07:04 AM   #18
Knuffel
LQ Newbie
 
Registered: Jan 2003
Posts: 21

Original Poster
Rep: Reputation: 15
Ok, I finally got the libstdc++ installed and the devel version too...
now I needed the gcc-c++-3.2-44 installed but it needs gcc=3.2-44 and I have installed the version 46 :-(
how comes i'ts conflicting? Can I uninstall version 46 and reinstal version 44? Or is there a version 46 from gcc-c++? so they have the same version?
I hope there is a way to do this ;-)
 
Old 01-08-2003, 07:07 AM   #19
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Here's the link to gcc-c++-3.2-44:
http://gd.tuwien.ac.at/opsys/linux/s....2-44.i586.rpm

And to gcc-3.2-44:
http://gd.tuwien.ac.at/opsys/linux/s....2-44.i586.rpm

Cool
 
Old 01-08-2003, 07:10 AM   #20
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
As long as all of these are of the same version, they should go in fine. Also, if you install them all at the same time, it might work out better (to save you from redundent/cyclic dependencies like gcc depends on gcc-c++ and gcc-c++ depends on gcc).

Cool
 
Old 01-08-2003, 07:15 AM   #21
Knuffel
LQ Newbie
 
Registered: Jan 2003
Posts: 21

Original Poster
Rep: Reputation: 15
ok, i foudn how to uninstaal:

rpm -e gcc-3.2-46.i586.rpm
--> error: package gcc-3.2-46.i586.rpm is not installed

but when i do -i i get the error that the package is already installed. Now which one is correct? is it or not installed? When triing to install an older version of cpp (needed by gcc) i get the error that gcc needs cpp so i guess it's installed, than why can't i unintall it?
any ideas on uninstalling gcc?
 
Old 01-08-2003, 07:22 AM   #22
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
You can use the --force option, or I tend to update my databases when I get some kind of obviously wrong error like that:
rpm --rebuilddb &&
updatdb

Then I try again. If I still get the error, I will force the removal (--force)

Cool
 
Old 01-08-2003, 07:26 AM   #23
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Reading through the RPM manpage, you might try instead to simply:
rpm --replacefiles OR
rpm --replacepkgs
(but these options are same as --force)

Good Luck
 
Old 01-08-2003, 07:42 AM   #24
Knuffel
LQ Newbie
 
Registered: Jan 2003
Posts: 21

Original Poster
Rep: Reputation: 15
ok, I tried the -e --force from gcc but it doesn't work since you can only force a installation, upgrade, rmsouce and rmspec

so, i figured, i'l intall version 44 from cpp and force it but nope, beceause of the dependencie with gcc

So I figured, i'll try replacefiles for gcc version 44 but nope, beceause it also needs version 44 of cpp.

So as for me, the only way to get version 44 from both cpp and gcc is to remove gcc first but since force doesn't work :-( i have no idea how to get it unistalled or removed.

I also rebuild my db to see if i could uninstall it than but it gives an error on the updatdb command
it does the rebuilddb but not the updatedb.

I think after i have finally installed blackbox, I'll start learning and using linux a lot more, it seems a very nice playground for me ;-) and at least people or helping eachother out if you need help.

Just wish i could delete/uninstall gcc or adapt version 46 to 44 for cpp ang gcc
 
Old 01-08-2003, 07:50 AM   #25
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Try putting them all on the same line:
rpm -Ivh filename.rpm filename.rpm filename.rpm

All of the depended files. Try without the --force option first, then with.

Cool
 
Old 01-08-2003, 07:57 AM   #26
Knuffel
LQ Newbie
 
Registered: Jan 2003
Posts: 21

Original Poster
Rep: Reputation: 15
Can you tell me what the -lvh should do? I tried it but get the error:

rpm: --hash (-h) may only be specified during package installation

so i tried the -e option but i get the error that the packages are not installed.

Aren't I getting on your nerves? I'm sorry if I am, I just want it to work ;-)
 
Old 01-08-2003, 07:59 AM   #27
Knuffel
LQ Newbie
 
Registered: Jan 2003
Posts: 21

Original Poster
Rep: Reputation: 15
and the force option also can't be used (see eason above)
 
Old 01-08-2003, 08:00 AM   #28
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
All of this is probably going to really be good for you, however, I don't know if you knew you could install BB via RPM:
http://gd.tuwien.ac.at/opsys/linux/s...a6-24.i586.rpm

Just something you might wanna consider until you can get your GCC issues worked out

Cool
 
Old 01-08-2003, 08:03 AM   #29
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
The -h option is unnecessary and is just for "cosmetic" needs, a simple:
-i (no cap, sorry on that) should suffice.

Cool
 
Old 01-08-2003, 08:18 AM   #30
Knuffel
LQ Newbie
 
Registered: Jan 2003
Posts: 21

Original Poster
Rep: Reputation: 15
Ok, with a small letter i only, it worked
so it's installed, and gcc-c++ is also installed
i installed bb again and it goes really well but still it ends in an error:

blackbox requires the X Window System libraries and headers.

Is this an error beceause I'm running the ./configure from KDE in a terminal window?
should i try it when not in graphical mode?
If it doesn't work in textmode, i'll try the .rpm ;-)

Thanks for all the touble you are going thru to help me!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
BlackBox install problem!! chutsu Linux - Software 2 09-04-2004 06:21 AM
BlackBox Install issue Doug.Gentry Linux - Software 3 03-05-2004 07:33 PM
blackbox install question TomGerman Linux - Software 7 08-09-2003 07:35 PM
blackbox install problems yg17 Linux - Software 5 10-03-2002 05:56 AM
blackbox install umpa Linux - Software 6 01-04-2002 12:44 PM


All times are GMT -5. The time now is 01:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration