LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-14-2008, 09:28 AM   #1
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 632

Rep: Reputation: 36
input output error while running 'diff' on a ntfs disk


hello everyone,
i am running slackware 11. with the aid of a ntfs-3g driver i am able to mount an ntfs external hard disk..
the problem is somewhat more general than just with the diff command, ie it has happened to me also while trying to copy data FROM as well as TO this ntfs disk...

i have recently installed the latest ntfs-3g driver but the problem existed from before....
now here the latest occurence of the problem

Quote:
nass@stargaze:~$ diff winmx/ nass_book/winmx/ | grep -i only
Only in winmx/: 03 Gary Moore - Over The Hills And Far Away.mp3
Only in winmx/: 14 Sonata Arctica - Unia - Out In The Fields (Gary Moore & Phil Lynott).mp3
Only in winmx/: 371. Gary Moore - Out In The Fields.mp3
Only in winmx/: Batman The Dark Knight KLAXXON
diff: nass_book/winmx/Blockhead.-.Music.By.Cavelight.+.Ltd.Ed.Bonus.Disc.rar: Input/output error
folder winmx is in a reiserfs RAIDed partition, and nass_WDbook/winmx is in the external ntfs disk...

after this happens, i can no longer access the drive..
Quote:
nass@stargaze:~$ diff winmx/ nass_book/winmx/ | grep -i only
diff: nass_book/winmx/: No such file or directory
but i can still umount it...!
dmesg gives:

Quote:
ata8: exception Emask 0x10 SAct 0x0 SErr 0x990000 action 0xa frozen
ata8: irq_stat 0x00400000, PHY RDY changed
ata8: SError: { PHYRdyChg 10B8B Dispar LinkSeq }
ata8: hard resetting link
ata8: SATA link down (SStatus 0 SControl 300)
ata8: failed to recover some devices, retrying in 5 secs
ata8: hard resetting link
ata8: SATA link down (SStatus 0 SControl 300)
ata8: failed to recover some devices, retrying in 5 secs
ata8: hard resetting link
ata8: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata8.00: configured for UDMA/133
ata8: EH complete
sd 7:0:0:0: [sdf] 976773168 512-byte hardware sectors (500108 MB)
sd 7:0:0:0: [sdf] Write Protect is off
sd 7:0:0:0: [sdf] Mode Sense: 00 3a 00 00
sd 7:0:0:0: [sdf] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
ata8.00: exception Emask 0x10 SAct 0x1 SErr 0x780100 action 0x2
ata8.00: irq_stat 0x08000000
ata8: SError: { UnrecovData 10B8B Dispar BadCRC Handshk }
ata8.00: cmd 60/00:00:df:6f:4a/01:00:25:00:00/40 tag 0 ncq 131072 in
res 40/00:04:df:6f:4a/00:00:25:00:00/40 Emask 0x10 (ATA bus error)
ata8.00: status: { DRDY }
ata8: hard resetting link
ata8: SATA link down (SStatus 0 SControl 300)
ata8: failed to recover some devices, retrying in 5 secs
ata8: hard resetting link
ata8: SATA link down (SStatus 0 SControl 300)
ata8: failed to recover some devices, retrying in 5 secs
ata8: hard resetting link
ata8: SATA link down (SStatus 0 SControl 300)
ata8.00: disabled
sd 7:0:0:0: [sdf] Result: hostbyte=0x00 driverbyte=0x08
sd 7:0:0:0: [sdf] Sense Key : 0xb [current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
72 0b 00 00 00 00 00 0c 00 0a 80 00 00 00 00 00
25 4a 6f df
sd 7:0:0:0: [sdf] ASC=0x0 ASCQ=0x0
end_request: I/O error, dev sdf, sector 625635295
printk: 88 messages suppressed.
Buffer I/O error on device sdf1, logical block 78204404
Buffer I/O error on device sdf1, logical block 78204405
Buffer I/O error on device sdf1, logical block 78204406
Buffer I/O error on device sdf1, logical block 78204407
Buffer I/O error on device sdf1, logical block 78204408
Buffer I/O error on device sdf1, logical block 78204409
Buffer I/O error on device sdf1, logical block 78204410
Buffer I/O error on device sdf1, logical block 78204411
Buffer I/O error on device sdf1, logical block 78204412
Buffer I/O error on device sdf1, logical block 78204413
ata8: EH complete
ata8.00: detaching (SCSI 7:0:0:0)
sd 7:0:0:0: [sdf] Synchronizing SCSI cache
sd 7:0:0:0: [sdf] Result: hostbyte=0x04 driverbyte=0x00
sd 7:0:0:0: [sdf] Stopping disk
sd 7:0:0:0: [sdf] START_STOP FAILED
sd 7:0:0:0: [sdf] Result: hostbyte=0x04 driverbyte=0x00
then, if i try to mount it again, it fails
i have to BOTH switch off the drive, unplug the eSATA cable, switching it ON and plug the cable again in... and it will still not be able to provide a file descriptor for the file (i wont get the /dev/sdf1 that is)

i repeat the step of switching off and unpluging and finally im able to get the /dev/sdf1 again and mount it...

if i do repeat the 'diff' i am sure to get the same input/output error but certainly NOT while accessing the same file...

so it is probably not smth wrong with a specific file...

any clues as to what might be happening?
thank you in advance for your help
nass
 
Old 12-14-2008, 09:56 AM   #2
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 632

Original Poster
Rep: Reputation: 36
here is a little irony...
as i said the problem occurs even when i write to or from the disk...
so i did try to copy some files from the external disk to the internal RAIDed storage array... as expected it failed... note that i tried to do that through the command like

so i did reconnect the external disk and tried to do the same copy from a windows machine, to which i had shared (with samba) BOTH the external disk and a directory in the RAIDed storage array....
funny thing it actually worked.... obviously im extremely confused about how samba managed to get the copy working and i from the command like could not ...

so here is something interesting to elaborate on...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
aplay: pcm_write:1029: write error: Input/output error mimithebrain Linux - Software 2 12-04-2007 12:51 PM
RPM iinstallation [error: failed to stat /mnt/windows: Input/output error] Ameii83 Linux - Software 1 04-09-2007 08:05 AM
Input/output error. Disk Error? Memory? bagpussnz Linux - General 1 06-11-2006 08:39 PM
cp - error reading /mnt/cdrom/mpegav/avseq01.dat input/output error manishsingh4u Linux - General 2 10-17-2005 06:02 AM
couple of problems with mounting CDs and disk 'input/output' errors. can anyone help? darksmiley Linux - General 5 01-24-2004 10:28 PM


All times are GMT -5. The time now is 03:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration