LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-03-2013, 08:03 AM   #1
sonatasin
LQ Newbie
 
Registered: Mar 2013
Posts: 11

Rep: Reputation: Disabled
implementation of leach protocol in ns2.34


hellow, i have installed ns-allinone2.34 in ubuntu 10.04 in ordre to integrate leach protocole i did all the steps and modifications but when i tape "leach_test" the result is : "leach_test:command not found" any help !!!
 
Old 03-03-2013, 10:05 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,953

Rep: Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602
Quote:
when I type "leach_test"
The word is 'type', not "tape".

"leach_test" is not in your PATH, and is not a command :

'leach_test' is an executable script, and you can do : ./leach_test

-

Last edited by knudfl; 03-03-2013 at 10:06 AM.
 
Old 03-03-2013, 05:35 PM   #3
sonatasin
LQ Newbie
 
Registered: Mar 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
oupss sorry it was miss writing with all that stress i couldn't pay attention to that mistake "not big deal"
i did what u showed me but nothing happened i am really desperate :/
 
Old 03-04-2013, 02:55 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,953

Rep: Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602
The basic "test simulation" is ./test, which will run 'leach_test'.
Code:
#!/bin/bash
cd tcl/ex
ns wireless-demo-csci694.tcl

sleep 2

cd ../../
./leach_test
I think there are some posts about test and leach_test in "the long leach thread"
http://www.linuxquestions.org/questi...68/page26.html
.. Look for answer by @ deepa_2111.

-
 
Old 03-04-2013, 05:20 PM   #5
sonatasin
LQ Newbie
 
Registered: Mar 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
i did the basic test-simulation nothing happened in the terminal but when i checked leach.out i did not find any thing however
leach.err has this error:
can't read "env(RCA_LIBRARY)": no such variable
while executing
"source $env(RCA_LIBRARY)/ns-ranode.tcl"
(file "mit/uAMPS/sims/uamps.tcl" line 9)
invoked from within
"source.orig mit/uAMPS/sims/uamps.tcl"
("uplevel" body line 1)
invoked from within
"uplevel source.orig[list $fileName]"
invoked from within
"if [$instance_ is_http_url $fileName] {
set buffer [$instance_ read_url $fileName]
uplevel eval $buffer
} else {
uplevel source.orig[list $fileName]
..."
(procedure "source" line 8)
invoked from within
"source mit/uAMPS/sims/uamps.tcl"
(file "tcl/mobility/leach.tcl" line 18)
invoked from within
"source.orig tcl/mobility/leach.tcl"
("uplevel" body line 1)
invoked from within
"uplevel source.orig[list $fileName]"
invoked from within
"if [$instance_ is_http_url $fileName] {
set buffer [$instance_ read_url $fileName]
uplevel eval $buffer
} else {
uplevel source.orig[list $fileName]
..."
(procedure "source" line 8)
invoked from within
"source tcl/mobility/$opt(rp).tcl"
(file "tcl/ex/wireless.tcl" line 187)
although i didn't make any changes what can i do !!?
 
Old 03-05-2013, 04:23 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,953

Rep: Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602
# 5 : Did you read the LEACH threads ?


LQ Search
→ Tag = leach
 
Old 03-05-2013, 01:48 PM   #7
sonatasin
LQ Newbie
 
Registered: Mar 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
yes i did , i even started from the beginning but always the same error pleaaaaaaaase i need your help
 
Old 03-06-2013, 11:15 AM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,953

Rep: Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602
Please ask deepa_2111 here :

http://www.linuxquestions.org/questi...68/page28.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
codes for leach protocol in ns2 shaddrack yaw nusenu Linux - Newbie 4 09-14-2014 10:16 AM
Leach Protocol for ns2.34 pushpita Linux - Software 36 07-08-2013 04:06 AM
LEACH and SEP protocol using ns2 renugaganapathy Linux - Newbie 3 11-03-2012 02:31 AM
LEACH protocol in ns2 swtjeeva Linux - Software 3 09-04-2012 12:53 PM
LEACH protocol installation on NS2.27 Scofield Linux - General 255 03-08-2012 05:19 PM


All times are GMT -5. The time now is 02:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration