LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-29-2003, 01:30 AM   #1
wr3ck3d
Member
 
Registered: Dec 2002
Location: IL
Distribution: NetBSD, Slackware, Gentoo, Debian, FreeBSD
Posts: 444

Rep: Reputation: 31
imlib2 compile problems


Trying to get Esetroot to work. According to Eterm configure i need imlib2, for that i needed freetype fonts. Got the fonts in fine, imlib configured, but during the make.....


Making all in loaders
make[2]: Entering directory `/usr/src/imlib2-1.0.6/loaders'
/bin/sh ../libtool --mode=link gcc -g -O2 -L/usr/X11R6/lib -L../src -o jpeg.la -rpath /usr/local/lib/loaders/image -no-undefined -module -avoid-version loader_jpeg.lo -ljpeg -L../src -lImlib2
rm -fr .libs/jpeg.la .libs/jpeg.* .libs/jpeg.*
gcc -shared loader_jpeg.lo -L/usr/X11R6/lib -L../src -ljpeg -lImlib2 -lc -Wl,-soname -Wl,jpeg.so -o .libs/jpeg.so
/usr/lib/gcc-lib/i386-slackware-linux/3.2.2/../../../../i386-slackware-linux/bin/ld: cannot find -lImlib2
collect2: ld returned 1 exit status
make[2]: *** [jpeg.la] Error 1
make[2]: Leaving directory `/usr/src/imlib2-1.0.6/loaders'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/imlib2-1.0.6'
make: *** [all-recursive-am] Error 2


Any help would be appreciated
 
Old 03-29-2003, 05:07 AM   #2
wr3ck3d
Member
 
Registered: Dec 2002
Location: IL
Distribution: NetBSD, Slackware, Gentoo, Debian, FreeBSD
Posts: 444

Original Poster
Rep: Reputation: 31
I got it...i just installed the next older version and it went fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Imlib2 phsythax Linux - Software 1 11-05-2005 01:14 PM
Enlightenment Compile Imlib2 davidanders Linux - Software 1 08-24-2005 07:02 PM
imlib2-config problems configuring adesklets Sk8trf69 Linux - Software 1 07-13-2005 08:25 PM
Imlib2 problems Maze the Kid Linux - Newbie 4 02-05-2005 08:10 PM
feh / Imlib2: "no imlib2 loader for that file format" froedi Linux - Software 2 11-30-2003 08:44 AM


All times are GMT -5. The time now is 09:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration