LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-20-2002, 12:23 AM   #1
digital bots
Member
 
Registered: Feb 2002
Distribution: Slack 10.1
Posts: 215

Rep: Reputation: 30
I need GCC 3.0.3


Ok i downloaded it to my pc then i did
./configure
then
make
then
make install

and it didnt take did i do something wrong i am running red hat with a gcc of 2.96 and in order to install the MPlayer i need either gcc-2.95.x or gcc-3.x i really think that this may be the reason why i cant seem to get some of these programs to run. Like I tried the XIME movie player and it didnt take either. So can you guys help me out or point me to a .RPM file i could use to fix this problem.
 
Old 02-20-2002, 06:30 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
heh, i guessed it would be for mplayer.

i'd recommend using an rpm install to have both versions of gcc on your system (assuming you're using redhat or something) then you'd specify the configure as

./configure --cc=gcc-3.0.3

i've not installed gcc from source before, so i'm not sure what executables it would create, you may well already have gcc-3.0.3 or something, i'm not sure. try some "locate gcc"'s and such like to track it down
 
Old 02-20-2002, 06:54 AM   #3
digital bots
Member
 
Registered: Feb 2002
Distribution: Slack 10.1
Posts: 215

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by acid_kewpie
heh, i guessed it would be for mplayer.

i'd recommend using an rpm install to have both versions of gcc on your system (assuming you're using redhat or something) then you'd specify the configure as

./configure --cc=gcc-3.0.3

i've not installed gcc from source before, so i'm not sure what executables it would create, you may well already have gcc-3.0.3 or something, i'm not sure. try some "locate gcc"'s and such like to track it down
well i do have RH7.2 but when i did the mplayer install it said i had GCC 2.7 i think its some version it did not support so it said upgrade to 3.0 or downgrade to 2.6 I will try to find a rpm of this thou thanks
 
Old 02-20-2002, 06:58 AM   #4
digital bots
Member
 
Registered: Feb 2002
Distribution: Slack 10.1
Posts: 215

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by acid_kewpie
heh, i guessed it would be for mplayer.

i'd recommend using an rpm install to have both versions of gcc on your system (assuming you're using redhat or something) then you'd specify the configure as

./configure --cc=gcc-3.0.3

i've not installed gcc from source before, so i'm not sure what executables it would create, you may well already have gcc-3.0.3 or something, i'm not sure. try some "locate gcc"'s and such like to track it down
well i do have RH7.2 but when i did the mplayer install it said i had GCC 2.97 i think its some version it did not support so it said upgrade to 3.0 or downgrade to 2.95.

Last edited by digital bots; 02-20-2002 at 07:07 AM.
 
Old 02-20-2002, 07:02 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
well, you'll have 2.96, so you should use 3+ or 2.95. you can force it to use 2.96 with ./configure --disable-gcc or somethign similar (use ./configure --help for options)

Last edited by acid_kewpie; 02-20-2002 at 07:08 AM.
 
Old 02-20-2002, 07:08 AM   #6
digital bots
Member
 
Registered: Feb 2002
Distribution: Slack 10.1
Posts: 215

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by acid_kewpie
well, you'll have 2.96, so you should use 3+ or 2.95
I did get the 2.95 rpm and it gave me this weird error.

<placepkgs /home/angomeka/gcc-2.95.3-0.20000503.1.i386.rpm;echo RESULT=$?
error: failed dependencies:
cpp = 2.95.3 is needed by gcc-2.95.3-0.20000503.1
gcc = 2.96-98 is needed by gcc-g77-2.96-98
gcc = 2.96-98 is needed by gcc-objc-2.96-98
gcc = 2.96-98 is needed by gcc-c++-2.96-98
RESULT=1

now i tried to upgrade and thats what i got. When i tried to replace this is what i got.

error: failed dependencies:
cpp = 2.95.3 is needed by gcc-2.95.3-0.20000503.1
RESULT=1

what did i do wrong all i did was double click on the icon and give it my shell password. lol
 
Old 02-20-2002, 07:12 AM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
the joys of dependencies. well, i'd ssuggest going to 3.x, but actaully rpmfind says redhat doesn't have a 3.0.x...

so, get the gcc-cpp 2.92.whatever package that was listed, and upgrade again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gcc wont install, 'failed dependencies: glibc-devel is needed by gcc-3.3.3-41' TdlSnare SUSE / openSUSE 3 11-29-2004 03:13 PM
Kernel compiling: gcc-3.3 is 586, should be gcc-3.3 386 Erik Plaggenmar Linux - Software 0 10-01-2004 12:38 PM
running software built with gcc 3.0.2 on Redhat 8 - gcc 3.2 dst1989 Linux - Software 3 03-08-2004 11:23 PM
a doubt with host gcc and arm-linux-gcc renjithgopal Linux - General 1 09-11-2003 05:02 PM
export CC=/usr/bin/gcc-3.2 - switch gcc version? ferreter Linux - Software 1 08-20-2003 01:07 AM


All times are GMT -5. The time now is 10:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration