LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   I have problems with on-line updates (http://www.linuxquestions.org/questions/linux-software-2/i-have-problems-with-on-line-updates-341502/)

rosco136 07-09-2005 02:27 AM

I have problems with on-line updates
 
I have just completed a clean install of Suse 9.2 Pro after having a massive lockup.
I did not run the on-line update during installation due to connection problems on the day.

As soon as the installation had completed I changed the screen resolution & font sizes to one that enabled me to see and read the information - I have pretty lousy eye-site.
Then I ran the online update. I removed the "manually select packages" option, as I thought that YOU was supposed to sort out the dependencies etc.

When that completed I looked in System Update and found a load of dependency problems that needed manual intervention.
Why does this happen? Have I set something up incorrectly, or should I select the "manual select packages" option and do my own dependency checks?

I saved the conflicts list & pasted it here:

#### YaST2 conflicts list - generated 2005-07-08 10:45:53 ####

kernel-default 2.6.8-24 conflict
Required by:
kernel-default-nongpl requires kernel-default = 2.6.8-24
Conflict Resolution:
( ) Downgrade kernel-default-2.6.8-24.16 to Version 2.6.8-24
( ) Remove the Referring Package
Delete kernel-default-nongpl
( ) Ignore Conflict and Risk System Inconsistencies
mailman 2.1.5-5 conflict
Broken Dependencies of Installed:
mailman requires python-xml
Conflict Resolution:
( ) Downgrade mailman-2.1.5-5.6 to Version 2.1.5-5
( ) Ignore Conflict and Risk System Inconsistencies
samba 3.0.7-5 conflict
Required by:
samba-vscan requires samba = 3.0.7-
Conflict Resolution:
( ) Downgrade samba-3.0.9-2.3 to Version 3.0.7-5
( ) Remove the Referring Package
Delete samba-vscan
( ) Ignore Conflict and Risk System Inconsistencies
samba-client 3.0.7-5 conflict
Required by:
samba requires samba-client = 3.0.7-
Conflict Resolution:
( ) Downgrade samba-client-3.0.9-2.3 to Version 3.0.7-5
( ) Remove All 2 Referring Packages
Delete samba-vscan
Delete samba
( ) Ignore Conflict and Risk System Inconsistencies

#### YaST2 conflicts list END ###


When I try to resolve these dependency problems, I am asked to insert the DVD and the system appears to roll-back to its state before I performed the update.
What am I doing wrong?
Is there anything I can read-up on this?

Any help would be most gratefully received.
There is a beer or two for solving my problem!

Generally, I much prefer Linux to Windoze, but then I preferred MS-DOS to Windoze.

Regards, Ross

Seagull 07-11-2005 04:54 AM

Manually Select Packages only allows you to choose which of the packages you wish to update that are offered for update.

This allows you NOT to select something that is offered as an update should you wish to do so. Why would you do this? Well it could be that the offered package will actually break something on your system. There was an instance of the gtk-qt-engine being updated which broke my installation of GIMP. I reverted to the old version of gtk-qt-engine and GIMP worked fine. Whenever updating with YOU I manually select which packages to install so that I can avoid those 'later' packages I know will cause me problems.

As far as I remember YOU doesn't do dependency checking, it just updates the installed packages to the latest security updates available. If you have extra installation sources defined (see this thread for adding YaST sources) then maybe you want to use the dependency check ability there after updating these packages. You've obviously got some later packages ..... but not all of their requirements.

Hope this helps some way ...

Chris


All times are GMT -5. The time now is 02:21 AM.