LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-04-2009, 07:07 AM   #1
kashif2131971
Member
 
Registered: Mar 2008
Posts: 60

Rep: Reputation: 16
I download firefox 3.5 but not know how to configure it in linux es4


i download firefox from decompress it with file roller but not know what to do with somebody help i have a facing problem to connect internet sides with 1.0.7 firefox
i uncompressed the files /tmp. cd firefox uncompressed folder
where I run.
./run-mozilla.sh


run-mozilla.sh: Cannot execute .

i got above message

thankx for help repo but it not work may i got some other problem. kindly bail me out from this problem
Attached Images
File Type: png screenshort1.png (157.2 KB, 10 views)

Last edited by kashif2131971; 07-04-2009 at 07:20 AM. Reason: the suggestion i receive is use by me
 
Old 07-04-2009, 07:13 AM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,516

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
cd to the directory where you uncompressed the files.
then type
Code:
./run-mozilla.sh
 
Old 07-04-2009, 07:45 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,145

Rep: Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642
Better use this
Code:
./firefox
or just click the 'firefox' script.

( run-mozilla.sh cannot start firefox.)
.....
 
Old 07-04-2009, 08:36 AM   #4
kashif2131971
Member
 
Registered: Mar 2008
Posts: 60

Original Poster
Rep: Reputation: 16
[root@localhost firefox]# ./firefox
./firefox-bin: error while loading shared libraries: libpangocairo-1.0.so.0: cannot open shared object file: No such file or directory

i checked the pango rpm it devel all the required rpm's configured properly

so kindly bring some tips for me
regards

Last edited by kashif2131971; 07-04-2009 at 08:37 AM.
 
Old 07-04-2009, 10:23 AM   #5
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,849

Rep: Reputation: Disabled
Quote:
Originally Posted by kashif2131971 View Post
[root@localhost firefox]# ./firefox
./firefox-bin: error while loading shared libraries: libpangocairo-1.0.so.0: cannot open shared object file: No such file or directory

i checked the pango rpm it devel all the required rpm's configured properly

so kindly bring some tips for me
regards
First off, you should not be running Firefox as root. It is unnecessary and dangerous and will cause problems with the location of your user profile.

Have you installed the libpango package?
cheers,
jdk

Last edited by jdkaye; 07-04-2009 at 10:25 AM.
 
Old 07-04-2009, 12:26 PM   #6
kashif2131971
Member
 
Registered: Mar 2008
Posts: 60

Original Poster
Rep: Reputation: 16
still enable to install firefox 3.5 on my redhat es4 machine

I do every possible step which I know but nothing happen. I don't think it is so hard to install firefox 3.5. because older version i m not able to visit facebook.com, my inbox in hotmail i was totally distrub know plz somebody help me on this issue fo installing firefox 3.5
regards to all who gave their valuable advice
 
Old 07-04-2009, 02:03 PM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,145

Rep: Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642
'libpangocairo-1.0.so.0' is provided by
the package 'evolution28-pango' , probably
already installed.
( One of 5 evolution28-xxx in /usr/evolution28/.)
.....

Other requirements

1)
glib-2.12.12 :
ftp://ftp.heanet.ie/mirrors/ftp.slac...source/l/glib/
./configure --prefix=/usr/local/glib212 &&
make && make install
.....
2)
dbus-1.1.2
http://www.freedesktop.org/wiki/Soft...ReleaseArchive
http://dbus.freedesktop.org/releases...s-1.1.2.tar.gz
export PKG_CONFIG_LIBDIR="${stagedir}/usr/local/glib212/lib/pkgconfig"
./configure --enable-doxygen-docs=no
&& make && make install
.....
3)
dbus-glib-0.73
http://dbus.freedesktop.org/releases/dbus-glib/
cd /usr/local/glib212/lib/pkgconfig/
# ln -s /usr/local/lib/pkgconfig/dbus-1.pc
export PKG_CONFIG_LIBDIR="${stagedir}/usr/local/glib212/lib/pkgconfig"
./configure --enable-doxygen-docs=no && make
# make install
.....
export LD_LIBRARY_PATH=/usr/evolution28/lib:/usr/local/lib
... and run ' ./firefox '.
.....
Be aware, that the 'export ..' commands are temporary :
the path will last till the terminal is closed.
.....
The much easier way :
# yum install firefox
The version is 3.0.10
Please see post # 3 here
http://www.linuxquestions.org/questi...rprise-736174/
.....

Last edited by knudfl; 07-09-2009 at 06:31 PM.
 
  


Reply

Tags
el4, evolution28, firefox3


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
requires flv downloader es4 linux kashif2131971 Linux - Software 1 07-03-2009 08:47 AM
how to configure postfix on linux es4 need step by step help om_juneja Linux - Enterprise 1 05-20-2008 10:20 AM
Proplem between LINUX ES4 and WIndows 2003 Server- How to solve??? redhat_vishipel Linux - Networking 2 01-19-2007 05:12 AM
loading oracle 10.1.0.3 for O.S.(Linux ES4 (Red Hat Enterprise Edition)) rohitc Linux - Enterprise 6 12-08-2006 01:44 PM
swap space on Linux ES4 with Oracle 10g R2 harmeet Linux - Enterprise 1 10-13-2006 07:19 AM


All times are GMT -5. The time now is 10:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration