LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   I Can't Update To The Most Recent Kernel/Headers (http://www.linuxquestions.org/questions/linux-software-2/i-cant-update-to-the-most-recent-kernel-headers-676584/)

davidx 10-15-2008 02:04 PM

I Can't Update To The Most Recent Kernel/Headers
 
Having ubuntu 8.04, when I updated my computer to the latest kernel and headers through Update Manager, an error popped up. The error stated that it wouldn't update at this time. When I tried to download again, the update was gone in Update Manager.

I checked and I don't have the most recent kernel installed. I still have 2.6.24-19. Accrding to http://www.kernel.org/, the most recent one is: 2.6.27. What do I do to fix this?

.

irishbitte 10-15-2008 03:55 PM

To be honest, I really wouldn't worry about it unless you have some particular reason for updating the kernel? Also, the ubuntu repos just updated to 2.6.24-21 I think, so 2.6.27 is a fair bit away!

irishbitte 10-15-2008 03:56 PM

Oh yes, do not compile your own kernel in ubuntu, it will break EVERYTHING! you have been warned!

davidx 10-15-2008 05:15 PM

Quote:

Originally Posted by irishbitte (Post 3311287)
Oh yes, do not compile your own kernel in ubuntu, it will break EVERYTHING! you have been warned!

thanks irishbite.

.

syg00 10-15-2008 08:26 PM

Ubuntu stabilize their kernels when a new release is due. Inrepid (8.10) beta currently runs 2.6.27; should be out (officially) shortly.

davidx 10-15-2008 11:34 PM

Hi, guys! The first time that I attempted to install the most recent kernel/headers for ubuntu, a Defconf window popped up asking me what I wanted to do. It gives me a list of seven options including, 'keep the local version currently installed' and 'install the package maintainer's version'. I closed the window and then a message came up that stated that the kernel/headers won't be updated. What do I do now?

.,

AuroraCA 10-15-2008 11:41 PM

Ubuntu 8.10 will be released on October 30th. That is just two weeks away on Friday. You will have the latest Linux kernel 2.6.27 when you upgrade to Ubuntu 8.10. You will also get the very latest AMD/ATI video drivers at that time.

syg00 10-16-2008 12:26 AM

Quote:

Originally Posted by davidx (Post 3311661)
I closed the window and then a message came up that stated that the kernel/headers won't be updated. What do I do now?

Probably means you didn't read the message window properly. I suspect that was for updating your grub config. I expect the kernel was installed o.k., but your menu.lst didn't get updated when you closed the dialog. Check your /boot, and manually add an entry if that is the case.

davidx 10-16-2008 12:02 PM

Quote:

Originally Posted by syg00 (Post 3311703)
Probably means you didn't read the message window properly. I suspect that was for updating your grub config. I expect the kernel was installed o.k., but your menu.lst didn't get updated when you closed the dialog. Check your /boot, and manually add an entry if that is the case.

Hi, syg00. Thanks for the reply.

1)You mentioned that I should add an entry to my /boot. What entry should I enter?

2) Also, the next time defconf pops up again, what option do I choose?

.

syg00 10-16-2008 03:59 PM

1) Do an "ls /boot" and note what entries are there; you'll note they come in "sets" for each kernel Ubuntu ship.
Then go edit /boot/grub/menu.lst (as root) and add an entry if you have a more recent kernel in /boot. Simplest to just copy-and-paste a block, and update the version - say 2.6.24-19-generic to 2.6.24-21-generic (3 times). Add it before the current default entry you see when you boot - that way it'll become the new default.

2) Your choice: if you have no changes to menu.lst, accept the maintainers version, and not have to worry about this again. Else keep your own menu.lst, and modify by hand each time.

davidx 10-16-2008 09:29 PM

Quote:

Originally Posted by syg00 (Post 3312634)
1) Do an "ls /boot" and note what entries are there; you'll note they come in "sets" for each kernel Ubuntu ship.
Then go edit /boot/grub/menu.lst (as root) and add an entry if you have a more recent kernel in /boot. Simplest to just copy-and-paste a block, and update the version - say 2.6.24-19-generic to 2.6.24-21-generic (3 times). Add it before the current default entry you see when you boot - that way it'll become the new default.

syg00, thanks for your needed reply. You must forgive me, but I'm a bit new at this, so I'll paste what I got from 'ls /boot' and 'menu.lst'. This way, you can tell me more precisely what I need to do. This will help me learn too!

From 'ls /boot':
isx@xx:~$ ls boot
ls: cannot access boot: No such file or directory
x@xx:~$ ls /boot
abi-2.6.22-14-generic
abi-2.6.24-16-generic
abi-2.6.24-19-generic
abi-2.6.24-21-generic
config-2.6.22-14-generic
config-2.6.24-16-generic
config-2.6.24-19-generic
config-2.6.24-21-generic
grub
initrd.img-2.6.22-14-generic
initrd.img-2.6.22-14-generic.bak
initrd.img-2.6.24-16-generic
initrd.img-2.6.24-16-generic.bak
initrd.img-2.6.24-19-generic
initrd.img-2.6.24-19-generic.bak
initrd.img-2.6.24-21-generic
initrd.img-2.6.24-21-generic.bak
memtest86+.bin
System.map-2.6.22-14-generic
System.map-2.6.24-16-generic
System.map-2.6.24-19-generic
System.map-2.6.24-21-generic
vmlinuz-2.6.22-14-generic
vmlinuz-2.6.24-16-generic
vmlinuz-2.6.24-19-generic
vmlinuz-2.6.24-21-generic




From 'menu.lst':
# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 3

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
## password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=00ef5e87-f11c-48a4-b599-c820a21b832f ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash clocksource=hpet

## should update-grub lock old automagic boot options
## e.g. lockold=false
## lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title Ubuntu 8.04.1, kernel 2.6.24-19-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.24-19-generic root=UUID=00ef5e87-f11c-48a4-b599-c820a21b832f ro quiet splash clocksource=hpet
initrd /boot/initrd.img-2.6.24-19-generic
quiet

title Ubuntu 8.04.1, kernel 2.6.24-19-generic (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.24-19-generic root=UUID=00ef5e87-f11c-48a4-b599-c820a21b832f ro single
initrd /boot/initrd.img-2.6.24-19-generic

title Ubuntu 8.04.1, memtest86+
root (hd0,0)
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST


.

syg00 10-17-2008 05:48 AM

As you can see, you have a 2.6.24-21 kernel that is not in your menu.lst. From a terminal use "sudo gedit /boot/grub/menu.lst" and update it so it looks like below. See my comments above for why ...
Code:

## ## End Default Options ##

title                Ubuntu 8.04.1, kernel 2.6.24-21-generic
root                (hd0,0)
kernel                /boot/vmlinuz-2.6.24-21-generic root=UUID=00ef5e87-f11c-48a4-b599-c820a21b832f ro quiet splash clocksource=hpet
initrd                /boot/initrd.img-2.6.24-21-generic
quiet

title                Ubuntu 8.04.1, kernel 2.6.24-21-generic (recovery mode)
root                (hd0,0)
kernel                /boot/vmlinuz-2.6.24-21-generic root=UUID=00ef5e87-f11c-48a4-b599-c820a21b832f ro single
initrd                /boot/initrd.img-2.6.24-21-generic

title                Ubuntu 8.04.1, kernel 2.6.24-19-generic
root                (hd0,0)
kernel                /boot/vmlinuz-2.6.24-19-generic root=UUID=00ef5e87-f11c-48a4-b599-c820a21b832f ro quiet splash clocksource=hpet
initrd                /boot/initrd.img-2.6.24-19-generic
quiet

title                Ubuntu 8.04.1, kernel 2.6.24-19-generic (recovery mode)
root                (hd0,0)
kernel                /boot/vmlinuz-2.6.24-19-generic root=UUID=00ef5e87-f11c-48a4-b599-c820a21b832f ro single
initrd                /boot/initrd.img-2.6.24-19-generic

title                Ubuntu 8.04.1, memtest86+
root                (hd0,0)
kernel                /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST


davidx 10-17-2008 07:47 AM

Quote:

Originally Posted by syg00 (Post 3313271)
As you can see, you have a 2.6.24-21 kernel that is not in your menu.lst. From a terminal use "sudo gedit /boot/grub/menu.lst" and update it so it looks like below. See my comments above for why ...
Code:

## ## End Default Options ##

title                Ubuntu 8.04.1, kernel 2.6.24-21-generic
root                (hd0,0)
kernel                /boot/vmlinuz-2.6.24-21-generic root=UUID=00ef5e87-f11c-48a4-b599-c820a21b832f ro quiet splash clocksource=hpet
initrd                /boot/initrd.img-2.6.24-21-generic
quiet

title                Ubuntu 8.04.1, kernel 2.6.24-21-generic (recovery mode)
root                (hd0,0)
kernel                /boot/vmlinuz-2.6.24-21-generic root=UUID=00ef5e87-f11c-48a4-b599-c820a21b832f ro single
initrd                /boot/initrd.img-2.6.24-21-generic

title                Ubuntu 8.04.1, kernel 2.6.24-19-generic
root                (hd0,0)
kernel                /boot/vmlinuz-2.6.24-19-generic root=UUID=00ef5e87-f11c-48a4-b599-c820a21b832f ro quiet splash clocksource=hpet
initrd                /boot/initrd.img-2.6.24-19-generic
quiet

title                Ubuntu 8.04.1, kernel 2.6.24-19-generic (recovery mode)
root                (hd0,0)
kernel                /boot/vmlinuz-2.6.24-19-generic root=UUID=00ef5e87-f11c-48a4-b599-c820a21b832f ro single
initrd                /boot/initrd.img-2.6.24-19-generic

title                Ubuntu 8.04.1, memtest86+
root                (hd0,0)
kernel                /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST


syg00, I did copy and paste your info into my menu.lst, but when I boot up, I see a bunch of lines come up and one line in particular with a red bullet states that "no module for a 'so-so' kernel is found". Also at bootup, I get an option to choose with kernel to bootup in. I get 2 options: the old kernel and the "new" one. And, when I restart my computer, again, I get a list of lines. At this point, I don't know what to do.

.

.

brianL 10-17-2008 07:59 AM

Two posts with same problem?
http://www.linuxquestions.org/questi...s-this-676652/

syg00 10-18-2008 03:49 PM

Did you update the menu.lst with those lines I added in (to show you where to add) or did you perhaps (wrongly) completely replace menu.lst with what I posted ???.
If you are seeing the boot messages, implies the bootsplash isn't working.

Might be best to restore your menu.lst - then re-do the edit if you're confident enough.


All times are GMT -5. The time now is 03:39 AM.