LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   I can't mount ntfs partitions with the latest ntfs-3g version (http://www.linuxquestions.org/questions/linux-software-2/i-cant-mount-ntfs-partitions-with-the-latest-ntfs-3g-version-617990/)

BK2 02-01-2008 02:25 PM

I can't mount ntfs partitions with the latest ntfs-3g version
 
Hello everyone
I have a problem with ntfs partitions. When I installed linux at the first time (mandriva 2008.0 one) everything was OK ,but after updating ntfs-3g several times look what happened :

Code:

  mount /dev/sda1
mount: unknown filesystem type 'ntfs-3g'

I don't know why the system can't recognize this type
this is my fstab:
Code:

[root@localhost ~]# cat /etc/fstab
/dev/hda7 / ext3 defaults 1 1
none /proc proc defaults 0 0
/dev/hda8 swap swap defaults 0 0
/dev/sda1 /media/H ntfs-3g locale=ar_SA.UTF-8 0 0
/dev/sda2 /media/hd2 ext3 sync,noatime 0 0
/dev/sda3 /media/hd3 ext3 sync,noatime 0 0
/dev/hda1 /media/C vfat umask=0022,users,iocharset=utf8,sync,noauto,exec 0 0
/dev/hda5 /media/D ntfs-3g locale=ar_SA.UTF-8 0 0
/dev/hda6 /media/E ntfs-3g locale=ar_SA.UTF-8 0 0

I think the configuration is right

this is mtab:

Code:

[root@localhost ~]# cat /etc/mtab
/dev/hda7 / ext3 rw 0 0
none /proc proc rw 0 0
/dev/sda2 /media/hd2 ext3 rw,sync,noatime 0 0
/dev/sda3 /media/hd3 ext3 rw,sync,noatime 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
none /sys/fs/fuse/connections fusectl rw 0 0
/dev/hda5 /media/D fuseblk rw,nosuid,nodev,allow_other,blksize=4096 0 0
/dev/hda6 /media/E fuseblk rw,nosuid,nodev,allow_other,blksize=4096 0 0

ntfs-3g version:

Code:

ntfs-3g 1.2129 integrated FUSE 27 - Third Generation NTFS Driver

Copyright (C) 2006-2008 Szabolcs Szakacsits
Copyright (C) 2005-2007 Yura Pakhuchiy

uname -a:

Code:

[root@localhost ~]# uname -a
Linux localhost 2.6.22.12-desktop586-1mdv #1 SMP Tue Nov 20 08:09:17 EST 2007 i686 Intel(R) Pentium(R) M processor 1.70GHz GNU/Linux

there is another thing , when I mount manually, the tool "mount" didn't work with "ntfs-3g"

e.g. :

Code:

[root@localhost ~]# mount -t ntfs-3g /dev/sda1 /media/H -o locale=ar_SA.UTF-8
mount: unknown filesystem type 'ntfs-3g'

but when I use ntfs-3g separately it works:

Code:

[root@localhost ~]# ntfs-3g /dev/sda1 /media/H -o locale=ar_SA.UTF-8
[root@localhost ~]# cd /media/H
[root@localhost H]#

important note: before updating to the newer version of ntfs-3g , all things were OK, should I get back the older version or what ?

waiting for an answer

my greets

igu 02-01-2008 08:08 PM

Bad Mandriva packaging, downgrade or upgrade. I can see ntfs-3g-1.2129-3mdv2008.1 has fix it already.


All times are GMT -5. The time now is 08:58 AM.