LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-27-2011, 06:24 AM   #1
simonbcn
LQ Newbie
 
Registered: Jan 2011
Location: Barcelona, Spain
Distribution: Ubuntu
Posts: 4

Rep: Reputation: Disabled
Question I can't configure virtual users in VSFTPd


Ubuntu 10.04 32 bits
vsftpd 2.3.4 installed from sources

Code:
    # cat vsftpd.conf 
    listen=YES
    anonymous_enable=NO
    local_enable=YES
    write_enable=YES
    anon_upload_enable=NO
    anon_mkdir_write_enable=NO
    connect_from_port_20=YES
    nopriv_user=ftp
    chroot_local_user=YES
    secure_chroot_dir=/usr/share/empty
    ls_recurse_enable=YES
    listen_port=1031
    log_ftp_protocol=YES
    syslog_enable=NO
    vsftpd_log_file=/var/log/vsftpd.log
    delete_failed_uploads=YES
    user_config_dir=/etc/vsftpd/user_conf
    anon_world_readable_only=NO
    anon_other_write_enable=NO
    no_anon_password=YES
    force_dot_files=NO
    guest_enable=YES
    pam_service_name=vsftpd.virtual
    virtual_use_local_privs=YES
Code:
    # cat /etc/pam.d/vsftpd.virtual 
    auth       required     /lib/security/pam_userdb.so db=/etc/vsftpd/virtual_users.db
    account    required     /lib/secutiry/pam_userdb.so db=/etc/vsftpd/virtual_users.db
I use db_load to create a simple hashed db with the following command:

Code:
db4.8_load -T -t hash -f logins /etc/vsftpd/virtual_users.db
Well, I can login with my system user and it enters in FTP folder.
But when I try to enter with virtual user it always shows: 530 Login incorrect.

I've tried with other tutorial ([http://www.ubuntututorials.net/insta...irtual-users/]) that uses htpasswd and libpam-pwdfile but it also doesn't work.

I've tried see the log files but neither shows anything. I've done several searches with "grep -i vsftpd /var/log/*" and "grep -i pam /var/log/*" but I don't find any clue.
 
Old 03-27-2011, 09:24 AM   #2
simonbcn
LQ Newbie
 
Registered: Jan 2011
Location: Barcelona, Spain
Distribution: Ubuntu
Posts: 4

Original Poster
Rep: Reputation: Disabled
Hi,
The problem was several:

1. I hadn't installed libpam0g-dev before I compiled vsftpd.
2. In the pam file doesn't put the db file extension.

Now it's solved.
 
Old 09-16-2011, 06:25 PM   #3
curtlee2002
LQ Newbie
 
Registered: Feb 2009
Posts: 1

Rep: Reputation: 0
'2. In the pam file doesn't put the db file extension.' Please clarify
 
  


Reply

Tags
pam, vsftpd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Allow System Users and Virtual Users in VSFTPd Nickbrandson Linux - Software 0 01-24-2008 08:06 AM
vsftpd virtual users paranoid times Linux - Software 0 07-09-2007 11:47 PM
vsftpd, web uploads, vsftpd virtual users, apache virtual hosts, home directories jerryasher Linux - Software 7 02-18-2007 06:29 AM
vsftpd and virtual users chrull Linux - Software 0 05-14-2004 05:09 PM
vsftpd and virtual users poweroff Linux - General 0 02-26-2004 07:04 AM


All times are GMT -5. The time now is 12:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration