LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-11-2010, 08:33 AM   #1
nkjha
Member
 
Registered: Apr 2008
Posts: 30

Rep: Reputation: 15
I am not able to Login as a root in my fedora 11 machine


Hello all,

I am not able to Login as a root in my fedora 11 machine , but I can login with other user. when I login with as a root user the error occured "user authentication failed " .
After login with user account when I open Terminal and try to login with same
username = root and Password= admin then I can login .
have you any idea about this ,Please reply .

Thanks a lot .
Nk
 
Old 02-11-2010, 09:42 AM   #2
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Quote:
Originally Posted by nkjha View Post
Hello all,

I am not able to Login as a root in my fedora 11 machine , but I can login with other user. when I login with as a root user the error occured "user authentication failed " .
After login with user account when I open Terminal and try to login with same
username = root and Password= admin then I can login .
have you any idea about this ,Please reply .

Thanks a lot .
Nk
To login as root is disabled in Fedora for very good reasons.
But if you insist to compromise you're system , this question is ask and answersed many times even on this forum .
So search for it
 
Old 02-11-2010, 09:52 AM   #3
udaykiran
LQ Newbie
 
Registered: Feb 2010
Distribution: OpenSUSE, fedora, CentOS, Ubuntu
Posts: 3

Rep: Reputation: 0
@nkjha

For security reasons root logins are disabled in fedora since version 9 onwards, Though i would insist of not doing root logins. Still there is a way you can do it.

Login using your normal account
change to root from terminal with the command su
Then edit the default runlevel of the system in the file /etc/inittab

At the bottom find
id:5:initdefault:

change that to
id:3:initdefault:

then reboot your system and you will now have a tty based login. Enter your root credentials. After logging in type command startx and you will be in.


If you would want your server to be secure do not stay logged in with root account. Just incase you have to do some administration works, do it and logout immediately.

Regards,
UdayKiran.
 
Old 02-12-2010, 07:20 AM   #4
nkjha
Member
 
Registered: Apr 2008
Posts: 30

Original Poster
Rep: Reputation: 15
Thumbs up

Actually I installed "the Gnome display manager"
for resolving some Gnome problem after that I was unable to
Login as root user .

But Now I am able to Login as root in GUI mode as earlier before
this problem .For resolving this I enable root login .

Thanks a Lot
nkjha



Quote:
Originally Posted by udaykiran View Post
@nkjha

For security reasons root logins are disabled in fedora since version 9 onwards, Though i would insist of not doing root logins. Still there is a way you can do it.

Login using your normal account
change to root from terminal with the command su
Then edit the default runlevel of the system in the file /etc/inittab

At the bottom find
id:5:initdefault:

change that to
id:3:initdefault:

then reboot your system and you will now have a tty based login. Enter your root credentials. After logging in type command startx and you will be in.


If you would want your server to be secure do not stay logged in with root account. Just incase you have to do some administration works, do it and logout immediately.

Regards,
UdayKiran.
 
Old 05-08-2010, 01:40 PM   #5
smithy2010
Member
 
Registered: May 2010
Location: UK
Distribution: Fedora 20 64 bit
Posts: 43

Rep: Reputation: 15
Thumbs up

you can try this:

gedit /etc/pam.d/gdm

or

vi /etc/pam.d/gdm

and then add # in fornt of the to look like this:

# auth required pam_succeed_if.so user != root quiet

it works on Fedora 11 and 12

cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Root login in Fedora 10 guanajuatense2008 Linux - Newbie 20 12-19-2010 08:55 PM
How to login in root in fedora 10 KapilSatav Linux - Wireless Networking 2 08-06-2009 06:50 PM
can't login to root fedora 10 podizoid Linux - Newbie 6 02-13-2009 07:37 PM
Root login on Fedora 10 danie1 Linux - General 2 01-22-2009 04:30 PM
How to login as root in the remote machine with NX client tanveer Linux - Software 5 11-18-2007 11:27 AM


All times are GMT -5. The time now is 06:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration